aboutsummaryrefslogtreecommitdiffstats
path: root/archivers
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2006-07-28 13:14:55 +0800
committerclsung <clsung@FreeBSD.org>2006-07-28 13:14:55 +0800
commit60abff4e84a977bf093a17b179bd5a657a022ac8 (patch)
tree6fe0b091a804a37668c91d06d60ee83491cea91b /archivers
parentd9da377eeacb345dbbc146e4cf63031c81d044a4 (diff)
downloadfreebsd-ports-gnome-60abff4e84a977bf093a17b179bd5a657a022ac8.tar.gz
freebsd-ports-gnome-60abff4e84a977bf093a17b179bd5a657a022ac8.tar.zst
freebsd-ports-gnome-60abff4e84a977bf093a17b179bd5a657a022ac8.zip
Add p5-POE-Filter-LZW 1.2, a POE filter wrapped around Compress::LZW.
PR: ports/100951 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Diffstat (limited to 'archivers')
-rw-r--r--archivers/Makefile1
-rw-r--r--archivers/p5-POE-Filter-LZW/Makefile25
-rw-r--r--archivers/p5-POE-Filter-LZW/distinfo3
-rw-r--r--archivers/p5-POE-Filter-LZW/pkg-descr5
-rw-r--r--archivers/p5-POE-Filter-LZW/pkg-plist8
5 files changed, 42 insertions, 0 deletions
diff --git a/archivers/Makefile b/archivers/Makefile
index 5ed78e34daa7..a71cf8ad8a6f 100644
--- a/archivers/Makefile
+++ b/archivers/Makefile
@@ -67,6 +67,7 @@
SUBDIR += p5-IO-Zlib
SUBDIR += p5-Mac-Macbinary
SUBDIR += p5-POE-Filter-Bzip2
+ SUBDIR += p5-POE-Filter-LZW
SUBDIR += p5-POE-Filter-Zlib
SUBDIR += p5-PerlIO-gzip
SUBDIR += p7zip
diff --git a/archivers/p5-POE-Filter-LZW/Makefile b/archivers/p5-POE-Filter-LZW/Makefile
new file mode 100644
index 000000000000..8f82ab7ff48b
--- /dev/null
+++ b/archivers/p5-POE-Filter-LZW/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-POE-Filter-LZW
+# Date created: 2006-07-28
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= POE-Filter-LZW
+PORTVERSION= 1.2
+CATEGORIES= archivers perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= POE
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= A POE filter wrapped around Compress::LZW
+
+RUN_DEPENDS= ${SITE_PERL}/Compress/LZW.pm:${PORTSDIR}/archivers/p5-Compress-LZW \
+ ${SITE_PERL}/POE.pm:${PORTSDIR}/devel/p5-POE
+
+PERL_CONFIGURE= yes
+
+MAN3= POE::Filter::LZW.3
+
+.include <bsd.port.mk>
diff --git a/archivers/p5-POE-Filter-LZW/distinfo b/archivers/p5-POE-Filter-LZW/distinfo
new file mode 100644
index 000000000000..359ba698b6d8
--- /dev/null
+++ b/archivers/p5-POE-Filter-LZW/distinfo
@@ -0,0 +1,3 @@
+MD5 (POE-Filter-LZW-1.2.tar.gz) = 3b6cffad7c0c17f887872495b13d4073
+SHA256 (POE-Filter-LZW-1.2.tar.gz) = 1ab0618d90fbaa1cf133959b3fb31671a6a6606ab414176f3a146a913f0babe8
+SIZE (POE-Filter-LZW-1.2.tar.gz) = 2349
diff --git a/archivers/p5-POE-Filter-LZW/pkg-descr b/archivers/p5-POE-Filter-LZW/pkg-descr
new file mode 100644
index 000000000000..f007d9ac3c05
--- /dev/null
+++ b/archivers/p5-POE-Filter-LZW/pkg-descr
@@ -0,0 +1,5 @@
+POE::Filter::LZW provides a POE filter for performing compression/
+uncompression using Compress::LZW. It is suitable for use with
+POE::Filter::Stackable.
+
+WWW: http://search.cpan.org/dist/POE-Filter-LZW/
diff --git a/archivers/p5-POE-Filter-LZW/pkg-plist b/archivers/p5-POE-Filter-LZW/pkg-plist
new file mode 100644
index 000000000000..6a8b805b1c27
--- /dev/null
+++ b/archivers/p5-POE-Filter-LZW/pkg-plist
@@ -0,0 +1,8 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Filter/LZW/.packlist
+%%SITE_PERL%%/POE/Filter/LZW.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Filter/LZW
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Filter
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE
+@dirrmtry %%SITE_PERL%%/POE/Filter
+@dirrmtry %%SITE_PERL%%/POE