aboutsummaryrefslogtreecommitdiffstats
path: root/archivers
diff options
context:
space:
mode:
authornaddy <naddy@FreeBSD.org>2009-09-21 22:07:42 +0800
committernaddy <naddy@FreeBSD.org>2009-09-21 22:07:42 +0800
commitc233c920bcb4c33c114d27b44139fce5e5b65b21 (patch)
treed4870b996013704e61431d01ce4637749dffcecc /archivers
parent2ce05ef4fba676bdb2014f905e442535b374367e (diff)
downloadfreebsd-ports-gnome-c233c920bcb4c33c114d27b44139fce5e5b65b21.tar.gz
freebsd-ports-gnome-c233c920bcb4c33c114d27b44139fce5e5b65b21.tar.zst
freebsd-ports-gnome-c233c920bcb4c33c114d27b44139fce5e5b65b21.zip
Update to 4.999.9beta.
This is the last beta release before XZ Utils 5.0.0. No big changes are planned before the first stable release. XZ Utils is the official successor to LZMA Utils. Feature safe: yes
Diffstat (limited to 'archivers')
-rw-r--r--archivers/xz/Makefile50
-rw-r--r--archivers/xz/distinfo6
-rw-r--r--archivers/xz/files/patch-Makefile.in11
-rw-r--r--archivers/xz/files/patch-src-xz-hardware.c17
-rw-r--r--archivers/xz/files/patch-src_liblzma_Makefile.in11
-rw-r--r--archivers/xz/pkg-descr23
-rw-r--r--archivers/xz/pkg-plist9
7 files changed, 82 insertions, 45 deletions
diff --git a/archivers/xz/Makefile b/archivers/xz/Makefile
index 036c83188d77..69de483fc6e5 100644
--- a/archivers/xz/Makefile
+++ b/archivers/xz/Makefile
@@ -1,38 +1,48 @@
-# New ports collection makefile for: lzmautils-devel
-# Date created: 09 Dec 2008
-# Whom: David Naylor <dragonsa@highveldmail.co.za>
+# New ports collection makefile for: xz
+# Date created: 2009-09-16
+# Whom: naddy
#
# $FreeBSD$
#
-PORTNAME= lzmautils
-DISTVERSION= 4.999.8
-PORTREVISION= 1
+PORTNAME= xz
+PORTVERSION= 4.999.9
CATEGORIES= archivers
-MASTER_SITES= http://tukaani.org/xz/ \
- http://freebsd.unixfreunde.de/sources/
-PKGNAMESUFFIX= -devel
-DISTNAME= xz-${DISTVERSION}beta
+MASTER_SITES= http://tukaani.org/xz/
+DISTNAME= ${PORTNAME}-${PORTVERSION}beta
-MAINTAINER= dragonsa@highveldmail.co.za
+MAINTAINER= naddy@FreeBSD.org
COMMENT= LZMA compression and decompression tools
-CONFLICTS= lzma-[0-9]* lzmautils-4.[0-3]* lzmautils-[0-3]* lzmalib-[0-9]*
+CONFLICTS= lzma-[0-9]* lzmautils-[0-9]* lzmalib-[0-9]*
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
+MAKE_JOBS_SAFE= yes
USE_GNOME= gnomehack
-CONFIGURE_ARGS+= --disable-static --disable-nls # No translations apparent
+CONFIGURE_ARGS= --enable-dynamic=yes
+CONFIGURE_ARGS+=--disable-nls # no translations available
-.if defined(WITHOUT_THREADS)
-CONFIGURE_ARGS+= --disable-threads
+.if !defined(NOPORTDOCS)
+INSTALL_TARGET= install install-dist_docDATA
.endif
-MAN1= lzdiff.1 lzgrep.1 lzmore.1
-MLINKS= lzdiff.1 lzcmp.1 \
- lzgrep.1 lzegrep.1 \
- lzgrep.1 lzfgrep.1 \
- lzmore.1 lzless.1
+MAN1= lzmainfo.1 xz.1 xzdec.1 xzdiff.1 xzgrep.1 xzless.1 xzmore.1
+
+MLINKS= xz.1 lzcat.1 xzdiff.1 lzcmp.1 \
+ xzdiff.1 lzdiff.1 xzgrep.1 lzegrep.1 \
+ xzgrep.1 lzfgrep.1 xzgrep.1 lzgrep.1 \
+ xzless.1 lzless.1 xz.1 lzma.1 \
+ xzdec.1 lzmadec.1 xzmore.1 lzmore.1 \
+ xz.1 unlzma.1 xz.1 unxz.1 \
+ xz.1 xzcat.1 xzdiff.1 xzcmp.1 \
+ xzgrep.1 xzegrep.1 xzgrep.1 xzfgrep.1
+
+PORTDOCS= AUTHORS COPYING COPYING.GPLv2 NEWS README THANKS TODO \
+ faq.txt history.txt lzma-file-format.txt xz-file-format.txt
+
+regression-test: build
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} check
.include <bsd.port.mk>
diff --git a/archivers/xz/distinfo b/archivers/xz/distinfo
index bae20c423812..403df8cc880e 100644
--- a/archivers/xz/distinfo
+++ b/archivers/xz/distinfo
@@ -1,3 +1,3 @@
-MD5 (xz-4.999.8beta.tar.gz) = f00967331a487e88d51207fe17c56f52
-SHA256 (xz-4.999.8beta.tar.gz) = 059da5a9fe51c28b38f67e5b8063a451c516f37fbb268177fd1081b70dd97f53
-SIZE (xz-4.999.8beta.tar.gz) = 879382
+MD5 (xz-4.999.9beta.tar.gz) = f2073579b6da2fe35d453adee1aaf1b2
+SHA256 (xz-4.999.9beta.tar.gz) = fa3901d1c034842da47fec1a24a9b5a5bd435f5ecfbb444c168512e2daddb86f
+SIZE (xz-4.999.9beta.tar.gz) = 1037541
diff --git a/archivers/xz/files/patch-Makefile.in b/archivers/xz/files/patch-Makefile.in
new file mode 100644
index 000000000000..bac0bf9cd09f
--- /dev/null
+++ b/archivers/xz/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig 2009-09-16 19:57:05.000000000 +0200
++++ Makefile.in 2009-09-16 19:59:02.000000000 +0200
+@@ -785,7 +785,7 @@ info: info-recursive
+
+ info-am:
+
+-install-data-am: install-dist_docDATA
++install-data-am:
+
+ install-dvi: install-dvi-recursive
+
diff --git a/archivers/xz/files/patch-src-xz-hardware.c b/archivers/xz/files/patch-src-xz-hardware.c
deleted file mode 100644
index 13c356f8e6cb..000000000000
--- a/archivers/xz/files/patch-src-xz-hardware.c
+++ /dev/null
@@ -1,17 +0,0 @@
---- src/xz/hardware.c~ 2009-08-18 08:15:18.000000000 +0200
-+++ src/xz/hardware.c 2009-08-18 08:17:50.000000000 +0200
-@@ -42,12 +42,12 @@
- static void
- hardware_cores(void)
- {
--#if defined(HAVE_NUM_PROCESSORS_SYSCONF)
-+#if defined(HAVE_NCPU_SYSCONF)
- const long cpus = sysconf(_SC_NPROCESSORS_ONLN);
- if (cpus > 0)
- opt_threads = (size_t)(cpus);
-
--#elif defined(HAVE_NUM_PROCESSORS_SYSCTL)
-+#elif defined(HAVE_NCPU_SYSCTL)
- int name[2] = { CTL_HW, HW_NCPU };
- int cpus;
- size_t cpus_size = sizeof(cpus);
diff --git a/archivers/xz/files/patch-src_liblzma_Makefile.in b/archivers/xz/files/patch-src_liblzma_Makefile.in
new file mode 100644
index 000000000000..c6e005dbca36
--- /dev/null
+++ b/archivers/xz/files/patch-src_liblzma_Makefile.in
@@ -0,0 +1,11 @@
+--- src/liblzma/Makefile.in.orig 2009-09-16 19:57:18.000000000 +0200
++++ src/liblzma/Makefile.in 2009-09-16 19:57:31.000000000 +0200
+@@ -1631,7 +1631,7 @@ info: info-recursive
+
+ info-am:
+
+-install-data-am: install-docDATA install-pkgconfigDATA
++install-data-am: install-pkgconfigDATA
+
+ install-dvi: install-dvi-recursive
+
diff --git a/archivers/xz/pkg-descr b/archivers/xz/pkg-descr
index 3a50d175635c..e7d0dd10d852 100644
--- a/archivers/xz/pkg-descr
+++ b/archivers/xz/pkg-descr
@@ -1,6 +1,19 @@
-LZMA Utils is an attempt to provide LZMA compression to POSIX-like
-systems. The idea is to have a gzip-like command line tool and
-zlib-like library, which would make it easy to adapt the new
-compression technology to existing applications.
+XZ Utils is free general-purpose data compression software with a
+high compression ratio. XZ Utils is the successor to LZMA Utils.
-WWW: http://tukaani.org/lzma/
+The core of the XZ Utils compression code is based on the LZMA SDK.
+The primary compression algorithm is currently LZMA2, which is used
+inside the .xz container format. With typical files, XZ Utils
+creates output 30% smaller than gzip and 15% smaller than bzip2.
+
+The XZ Utils package consists of several components:
+
+* liblzma is a compression library with an API similar to that of zlib.
+* xz is a command line tool with syntax similar to that of gzip.
+* xzdec is a decompression-only tool smaller than the full-featured xz tool.
+* A set of shell scripts (xzgrep, xzdiff, etc.) have been adapted
+ from gzip to ease viewing, grepping, and comparing compressed files.
+* Emulation of the command line tools of LZMA Utils eases transition
+ from LZMA Utils to XZ Utils.
+
+WWW: http://tukaani.org/xz/
diff --git a/archivers/xz/pkg-plist b/archivers/xz/pkg-plist
index f58fe5ca8b52..92d0fe9d460d 100644
--- a/archivers/xz/pkg-plist
+++ b/archivers/xz/pkg-plist
@@ -7,12 +7,20 @@ bin/lzgrep
bin/lzless
bin/lzma
bin/lzmadec
+bin/lzmainfo
bin/lzmore
bin/unlzma
bin/unxz
bin/xz
bin/xzcat
+bin/xzcmp
bin/xzdec
+bin/xzdiff
+bin/xzegrep
+bin/xzfgrep
+bin/xzgrep
+bin/xzless
+bin/xzmore
include/lzma.h
include/lzma/base.h
include/lzma/bcj.h
@@ -28,6 +36,7 @@ include/lzma/stream_flags.h
include/lzma/subblock.h
include/lzma/version.h
include/lzma/vli.h
+lib/liblzma.a
lib/liblzma.la
lib/liblzma.so
lib/liblzma.so.0