aboutsummaryrefslogtreecommitdiffstats
path: root/archivers
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2016-09-10 03:42:46 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2016-09-10 03:42:46 +0800
commit6e502d51f3f34690037f4f33bb5cf0f0f50e2ca7 (patch)
treeb3bdcd25b598432ef78aefb0f72e9412f429eee4 /archivers
parentb236a9c0408bb4c5dd28e3128687a5de61161a27 (diff)
downloadfreebsd-ports-gnome-6e502d51f3f34690037f4f33bb5cf0f0f50e2ca7.tar.gz
freebsd-ports-gnome-6e502d51f3f34690037f4f33bb5cf0f0f50e2ca7.tar.zst
freebsd-ports-gnome-6e502d51f3f34690037f4f33bb5cf0f0f50e2ca7.zip
Most commonly used build systems support silent builds, when they
hide actual commands executed and only show short summary line (like "CC foo.c"). CMake and ninja enable this by default, some autotools using ports do as well. This is unacceptable because we need complete build logs at any time, so we now switch to verbose build logs unconditionally. Note that this change deliberately affects ALL builds and not only package builds on cluster, because we need to be sure that user experiencing failure can always provide informative build log regardless of settings and without rerunning the build. Change summary: - Always do verbose builds for cmake, ninja and GNU configure (the latter includes check if --disable-silent-rules is actually supported by the configure script; there are isolated cases when it's not true) - Remove CMAKE_VERBOSE, NINJA_VERBOSE and CONFIGURE_ARGS=--disable-silent-rules from all ports which set them for this is no longer needed - Revert hacks for --disable-silent-rules support priorly committed to biology/ncbi-blast+ and net-p2p/mldonkey - no longer needed as well Submitted by: amdmi3 Reviewed by: mat Exp-run by: antoine Approved by: portmgr (mat, antoine) Differential Revision: D7534
Diffstat (limited to 'archivers')
-rw-r--r--archivers/gcpio/Makefile1
-rw-r--r--archivers/gtar/Makefile3
-rw-r--r--archivers/lhasa/Makefile3
3 files changed, 2 insertions, 5 deletions
diff --git a/archivers/gcpio/Makefile b/archivers/gcpio/Makefile
index 546ec2f62083..bb29246b7b03 100644
--- a/archivers/gcpio/Makefile
+++ b/archivers/gcpio/Makefile
@@ -17,7 +17,6 @@ CPE_VENDOR= gnu
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --program-prefix=g \
- --disable-silent-rules \
--with-rmt=/etc/rmt
TEST_TARGET= check
diff --git a/archivers/gtar/Makefile b/archivers/gtar/Makefile
index ad57cbba7742..2ded2ccdc8f6 100644
--- a/archivers/gtar/Makefile
+++ b/archivers/gtar/Makefile
@@ -18,8 +18,7 @@ INFO= tar
USES= charsetfix cpe iconv:${STATIC_ARGS} localbase makeinfo tar:xz
CPE_VENDOR= gnu
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --program-prefix=g \
- --disable-silent-rules
+CONFIGURE_ARGS= --program-prefix=g
CONFIGURE_ENV= DEFAULT_ARCHIVE=/dev/sa0 \
DEFAULT_RMT_COMMAND=/etc/rmt
# supply result to skip a test that will abort configure if run as root
diff --git a/archivers/lhasa/Makefile b/archivers/lhasa/Makefile
index 9cf50308214d..96901aa9df0e 100644
--- a/archivers/lhasa/Makefile
+++ b/archivers/lhasa/Makefile
@@ -17,8 +17,7 @@ USES= autoreconf pathfix libtool
PATHFIX_MAKEFILEIN= Makefile.am
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-CONFIGURE_ARGS= --disable-silent-rules \
- --program-suffix=sa
+CONFIGURE_ARGS= --program-suffix=sa
INSTALL_TARGET= install-strip
PORTDOCS= ChangeLog README AUTHORS TODO NEWS