aboutsummaryrefslogtreecommitdiffstats
path: root/archivers
diff options
context:
space:
mode:
authorerwin <erwin@FreeBSD.org>2006-08-25 19:45:43 +0800
committererwin <erwin@FreeBSD.org>2006-08-25 19:45:43 +0800
commitdec082e50ffc43124d6d0979901e23f2c0d15171 (patch)
treefe12c8173d6b40554f95a3e1e696148d8d06e39a /archivers
parentd3d05a0cd7e114fae03f5a88abcdb4dc48eeb2e3 (diff)
downloadfreebsd-ports-gnome-dec082e50ffc43124d6d0979901e23f2c0d15171.tar.gz
freebsd-ports-gnome-dec082e50ffc43124d6d0979901e23f2c0d15171.tar.zst
freebsd-ports-gnome-dec082e50ffc43124d6d0979901e23f2c0d15171.zip
- Respect CC
- Respect CFLAGS - Install docs if NOPORTDOCS is not set - Bump PORTREVISION PR: 101810 Submitted by: gabor Approved by: maintainer timeout
Diffstat (limited to 'archivers')
-rw-r--r--archivers/unadf/Makefile18
1 files changed, 16 insertions, 2 deletions
diff --git a/archivers/unadf/Makefile b/archivers/unadf/Makefile
index 7ca05afb5643..24cf2efd7d4e 100644
--- a/archivers/unadf/Makefile
+++ b/archivers/unadf/Makefile
@@ -7,7 +7,7 @@
PORTNAME= unadf
PORTVERSION= 0.7.9b
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= archivers
MASTER_SITES= http://perso.club-internet.fr/lclevy/adflib/
DISTNAME= adflib
@@ -17,12 +17,26 @@ COMMENT= Extracts files from .adf-files used by Amiga emulators
NO_WRKSUBDIR= yes
PLIST_FILES= bin/unadf
+PORTDOCS= API.txt api_device.html api_dir.html api_env.html api_file.html \
+ api_index.html api_native.html api_salv.html api_volume.html
USE_ZIP= yes
-pre-build:
+post-patch:
@${REINPLACE_CMD} -e "s@tests lib demo@lib demo@g" ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} 's|CFLAGS=-I$$(LIBDIR) -O2 -Wall -Wno-uninitialized -pedantic|CFLAGS+= -I$$(LIBDIR)|' \
+ ${WRKSRC}/Demo/Makefile
+ @${REINPLACE_CMD} -e 's|CFLAGS=|CFLAGS+=|' \
+ -e 's|-Wall -O2 -pedantic||' \
+ -e 's|CC=|CC?=|' \
+ ${WRKSRC}/Lib/Makefile
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/Demo/unadf ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for i in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/Docs/${i} ${DOCSDIR}
+.endfor
+.endif
.include <bsd.port.mk>