aboutsummaryrefslogtreecommitdiffstats
path: root/archivers
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-12-27 00:59:24 +0800
committerbapt <bapt@FreeBSD.org>2013-12-27 00:59:24 +0800
commit072c88b59e0307e777913dabd0bf1d68f9c95ee7 (patch)
treef38ef8b73f6bc6db212fa1552d0d4d552b5117a0 /archivers
parent5089ec2b7e4302c00d06ab90f78361df38084ede (diff)
downloadfreebsd-ports-gnome-072c88b59e0307e777913dabd0bf1d68f9c95ee7.tar.gz
freebsd-ports-gnome-072c88b59e0307e777913dabd0bf1d68f9c95ee7.tar.zst
freebsd-ports-gnome-072c88b59e0307e777913dabd0bf1d68f9c95ee7.zip
Support stage
Use bsdtar to extract zip
Diffstat (limited to 'archivers')
-rw-r--r--archivers/xmill/Makefile20
1 files changed, 8 insertions, 12 deletions
diff --git a/archivers/xmill/Makefile b/archivers/xmill/Makefile
index 52489451cafb..0c521be05cc3 100644
--- a/archivers/xmill/Makefile
+++ b/archivers/xmill/Makefile
@@ -5,6 +5,7 @@ PORTNAME= xmill
DISTVERSION= 0.8
CATEGORIES= archivers
MASTER_SITES= SF
+EXTRACT_SUFX= .zip
MAINTAINER= sylvio@FreeBSD.org
COMMENT= Efficient compressor for XML
@@ -12,9 +13,8 @@ COMMENT= Efficient compressor for XML
WRKSRC= ${WRKDIR}/${PORTNAME}
MAKEFILE= makefile
-NO_STAGE= yes
-USE_ZIP= yes
-USE_DOS2UNIX= ${MAKEFILE} XMill/BZlib.cpp
+USES= dos2unix
+DOS2UNIX_FILES= ${MAKEFILE} XMill/BZlib.cpp
PLIST_FILES= bin/xcmill bin/xdemill bin/xmilltest bin/xmillexample \
bin/xmillinspect bin/ppmzip
@@ -33,15 +33,11 @@ post-patch:
do-install:
.for p in ${PLIST_FILES:T}
- ${INSTALL_PROGRAM} ${WRKSRC}/unix/${p} ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/unix/${p} ${STAGEDIR}${PREFIX}/bin
.endfor
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/documentation/* ${DOCSDIR}
-.endif
-.if ${PORT_OPTIONS:MEXAMPLES}
- @${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/examples/* ${EXAMPLESDIR}
-.endif
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/documentation/* ${STAGEDIR}${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/* ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.mk>