aboutsummaryrefslogtreecommitdiffstats
path: root/archivers
diff options
context:
space:
mode:
authornox <nox@FreeBSD.org>2008-09-07 19:16:48 +0800
committernox <nox@FreeBSD.org>2008-09-07 19:16:48 +0800
commit4977ca146577e63411971d6360bf8a0e420886e9 (patch)
tree43eeb832a9e7a0888fe3794febde5b812ae709e3 /archivers
parentf4e2c5d6a877d648a63b1221c6adc8e599d89387 (diff)
downloadfreebsd-ports-gnome-4977ca146577e63411971d6360bf8a0e420886e9.tar.gz
freebsd-ports-gnome-4977ca146577e63411971d6360bf8a0e420886e9.tar.zst
freebsd-ports-gnome-4977ca146577e63411971d6360bf8a0e420886e9.zip
Update to 4.58
PR: ports/127159 Submitted by: chinsan
Diffstat (limited to 'archivers')
-rw-r--r--archivers/p7zip/Makefile2
-rw-r--r--archivers/p7zip/distinfo6
-rw-r--r--archivers/p7zip/files/patch-CPP-Windows-System.cpp11
3 files changed, 10 insertions, 9 deletions
diff --git a/archivers/p7zip/Makefile b/archivers/p7zip/Makefile
index d0458ddfa505..f55e9e6292fe 100644
--- a/archivers/p7zip/Makefile
+++ b/archivers/p7zip/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= p7zip
-PORTVERSION= 4.57
+PORTVERSION= 4.58
CATEGORIES= archivers
MASTER_SITES= SF
DISTNAME= ${PORTNAME}_${DISTVERSION}_src_all
diff --git a/archivers/p7zip/distinfo b/archivers/p7zip/distinfo
index c1f6d9401952..1f66d9e020ca 100644
--- a/archivers/p7zip/distinfo
+++ b/archivers/p7zip/distinfo
@@ -1,3 +1,3 @@
-MD5 (p7zip_4.57_src_all.tar.bz2) = 773f78d8b297eb858626667d4dfa93c7
-SHA256 (p7zip_4.57_src_all.tar.bz2) = 00e923386dd53d532a86331d1694eaeee626783afa503f91edf7370357e05b53
-SIZE (p7zip_4.57_src_all.tar.bz2) = 1473608
+MD5 (p7zip_4.58_src_all.tar.bz2) = 315b184102c17c4956f53218d973222d
+SHA256 (p7zip_4.58_src_all.tar.bz2) = 52391559b7782d2bad45b783579ea9825f28670ba6f234fd0d9248af3e82bedd
+SIZE (p7zip_4.58_src_all.tar.bz2) = 1948207
diff --git a/archivers/p7zip/files/patch-CPP-Windows-System.cpp b/archivers/p7zip/files/patch-CPP-Windows-System.cpp
index 3f2bd3453783..4f0c8f5df0a4 100644
--- a/archivers/p7zip/files/patch-CPP-Windows-System.cpp
+++ b/archivers/p7zip/files/patch-CPP-Windows-System.cpp
@@ -1,10 +1,11 @@
-Index: CPP/Windows/System.cpp
-@@ -35,7 +35,7 @@
- #elif defined (__FreeBSD__)
+--- CPP/Windows/System.cpp.orig 2008-09-07 02:29:34.000000000 +0800
++++ CPP/Windows/System.cpp 2008-09-07 02:30:23.000000000 +0800
+@@ -44,7 +44,7 @@
+ #elif defined (__FreeBSD__) || defined (__FreeBSD_kernel__)
UInt32 GetNumberOfProcessors() {
- int nbcpu = 1;
+ int nbcpu = 1;
- size_t value;
-+ int value;
++ int value;
size_t len = sizeof(value);
if (sysctlbyname("hw.ncpu", &value, &len, NULL, 0) == 0)
nbcpu = value;