aboutsummaryrefslogtreecommitdiffstats
path: root/archivers
diff options
context:
space:
mode:
authorjhale <jhale@FreeBSD.org>2017-08-04 03:38:28 +0800
committerjhale <jhale@FreeBSD.org>2017-08-04 03:38:28 +0800
commit6e04a2435becc5d76a0090a389459dc13e7317bc (patch)
tree81fb924b7bbf5ec737988ce02c1352acdab3ed7b /archivers
parent8aff54d1a81cb5aadae59d8ebbd67c121678e9b9 (diff)
downloadfreebsd-ports-gnome-6e04a2435becc5d76a0090a389459dc13e7317bc.tar.gz
freebsd-ports-gnome-6e04a2435becc5d76a0090a389459dc13e7317bc.tar.zst
freebsd-ports-gnome-6e04a2435becc5d76a0090a389459dc13e7317bc.zip
Update to 5.5.7
Simplify OPENSSL_AES broken message
Diffstat (limited to 'archivers')
-rw-r--r--archivers/libunrar5/Makefile14
-rw-r--r--archivers/libunrar5/distinfo6
-rw-r--r--archivers/libunrar5/files/patch-makefile28
-rw-r--r--archivers/libunrar5/files/patch-os.hpp6
-rw-r--r--archivers/libunrar5/files/patch-rijndael.cpp36
-rw-r--r--archivers/libunrar5/files/patch-rijndael.hpp4
6 files changed, 40 insertions, 54 deletions
diff --git a/archivers/libunrar5/Makefile b/archivers/libunrar5/Makefile
index a646843db454..6861d556080f 100644
--- a/archivers/libunrar5/Makefile
+++ b/archivers/libunrar5/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= libunrar5
-PORTVERSION= 5.4.5
-PORTREVISION= 1
+PORTVERSION= 5.5.7
CATEGORIES= archivers
MASTER_SITES= http://www.rarlab.com/rar/
DISTNAME= unrarsrc-${PORTVERSION}
@@ -18,7 +17,7 @@ LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
USES= gmake
USE_LDCONFIG= yes
-ALL_TARGET= lib liba
+ALL_TARGET= lib
MAKEFILE= makefile
MAKE_ARGS= AR="${AR}" \
CXX="${CXX}" \
@@ -37,6 +36,7 @@ OPENSSL_AES_DESC= Use OpenSSL implementation of AES
OPENSSL_AES_CPPFLAGS= -DOPENSSL_AES -I${OPENSSLINC}
OPENSSL_AES_LDFLAGS= -L${OPENSSLLIB} -lcrypto
OPENSSL_AES_USES= ssl
+OPENSSL_AES_VARS= BROKEN_SSL=openssl-devel
PLIST_FILES= lib/libunrar.a \
lib/libunrar.so \
@@ -50,10 +50,4 @@ do-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/include/libunrar5
${INSTALL_DATA} ${WRKSRC}/dll.hpp ${STAGEDIR}${PREFIX}/include/libunrar5/dll.hpp
-.include <bsd.port.pre.mk>
-
-.if ${PORT_OPTIONS:MOPENSSL_AES} && ${SSL_DEFAULT:Mopenssl-devel}
-BROKEN= OPENSSL_AES option does not build with openssl-devel
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/archivers/libunrar5/distinfo b/archivers/libunrar5/distinfo
index e547df384c18..be4ac8e011b3 100644
--- a/archivers/libunrar5/distinfo
+++ b/archivers/libunrar5/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1483207045
-SHA256 (unrarsrc-5.4.5.tar.gz) = e470c584332422893fb52e049f2cbd99e24dc6c6da971008b4e2ae4284f8796c
-SIZE (unrarsrc-5.4.5.tar.gz) = 226320
+TIMESTAMP = 1501787450
+SHA256 (unrarsrc-5.5.7.tar.gz) = 8aef0a0d91bf9c9ac48fab8a26049ac7ac49907e75a2dcbd511a4ba375322d8f
+SIZE (unrarsrc-5.5.7.tar.gz) = 222293
diff --git a/archivers/libunrar5/files/patch-makefile b/archivers/libunrar5/files/patch-makefile
deleted file mode 100644
index e9c930d5b8e0..000000000000
--- a/archivers/libunrar5/files/patch-makefile
+++ /dev/null
@@ -1,28 +0,0 @@
---- makefile.orig 2016-05-10 09:51:35 UTC
-+++ makefile
-@@ -98,7 +98,7 @@ LINK=$(CXX)
- WHAT=UNRAR
-
- UNRAR_OBJ=filestr.o recvol.o rs.o scantree.o qopen.o
--LIB_OBJ=filestr.o scantree.o dll.o qopen.o
-+LIB_OBJ=dll.o
-
- OBJECTS=rar.o strlist.o strfn.o pathfn.o smallfn.o global.o file.o filefn.o filcreat.o \
- archive.o arcread.o unicode.o system.o isnt.o crypt.o crc.o rawread.o encname.o \
-@@ -131,9 +131,14 @@ sfx: clean $(OBJECTS)
-
- lib: WHAT=RARDLL
- lib: CXXFLAGS+=$(LIBFLAGS)
--lib: clean $(OBJECTS) $(LIB_OBJ)
-+lib: $(OBJECTS) $(LIB_OBJ) $(UNRAR_OBJ)
- @rm -f libunrar.so
-- $(LINK) -shared -o libunrar.so $(LDFLAGS) $(OBJECTS) $(LIB_OBJ)
-+ $(LINK) -shared -o libunrar.so $(LDFLAGS) $(OBJECTS) $(LIB_OBJ) $(UNRAR_OBJ)
-+
-+liba: WHAT=RARDLL
-+liba: $(OBJECTS) $(LIB_OBJ) $(UNRAR_OBJ)
-+ @rm -f libunrar.a
-+ $(AR) rcs libunrar.a $(OBJECTS) $(LIB_OBJ) $(UNRAR_OBJ)
-
- install-unrar:
- install -D unrar $(DESTDIR)/bin/unrar
diff --git a/archivers/libunrar5/files/patch-os.hpp b/archivers/libunrar5/files/patch-os.hpp
index 0a23dbaaa41e..dff506575c08 100644
--- a/archivers/libunrar5/files/patch-os.hpp
+++ b/archivers/libunrar5/files/patch-os.hpp
@@ -1,9 +1,9 @@
---- os.hpp.orig 2013-12-01 08:10:14 UTC
+--- os.hpp.orig 2017-04-28 17:28:46 UTC
+++ os.hpp
-@@ -151,6 +151,10 @@
- #include <utime.h>
+@@ -150,6 +150,10 @@
#include <locale.h>
+
+#ifdef OPENSSL_AES
+#include <openssl/evp.h>
+#endif // OPENSSL_AES
diff --git a/archivers/libunrar5/files/patch-rijndael.cpp b/archivers/libunrar5/files/patch-rijndael.cpp
index e6cc85144360..0d48cdad9eaa 100644
--- a/archivers/libunrar5/files/patch-rijndael.cpp
+++ b/archivers/libunrar5/files/patch-rijndael.cpp
@@ -1,4 +1,4 @@
---- rijndael.cpp.orig 2014-06-10 17:14:06 UTC
+--- rijndael.cpp.orig 2017-04-28 17:28:47 UTC
+++ rijndael.cpp
@@ -7,6 +7,8 @@
***************************************************************************/
@@ -9,7 +9,7 @@
#ifdef USE_SSE
#include <wmmintrin.h>
#endif
-@@ -56,6 +58,7 @@
+@@ -56,6 +58,7 @@ inline void Copy128(byte *dest,const byt
#endif
}
@@ -17,7 +17,7 @@
//////////////////////////////////////////////////////////////////////////////////////////////////////////////////
// API
-@@ -63,14 +66,35 @@
+@@ -63,14 +66,35 @@ inline void Copy128(byte *dest,const byt
Rijndael::Rijndael()
{
@@ -53,15 +53,35 @@
#ifdef USE_SSE
// Check SSE here instead of constructor, so if object is a part of some
// structure memset'ed before use, this variable is not lost.
-@@ -111,6 +135,7 @@
+@@ -111,6 +135,7 @@ void Rijndael::Init(bool Encrypt,const b
if(!Encrypt)
keyEncToDec();
+#endif // OPENSSL_AES
}
+ void Rijndael::blockEncrypt(const byte *input,size_t inputLen,byte *outBuffer)
+@@ -118,6 +143,11 @@ void Rijndael::blockEncrypt(const byte *
+ if (inputLen <= 0)
+ return;
+
++#ifdef OPENSSL_AES
++ int outLen;
++ EVP_CipherUpdate(&ctx, outBuffer, &outLen, input, inputLen);
++ return;
++#else // OPENSSL_AES
+ size_t numBlocks = inputLen/16;
+ #ifdef USE_SSE
+ if (AES_NI)
+@@ -176,6 +206,7 @@ void Rijndael::blockEncrypt(const byte *
+ input += 16;
+ }
+ Copy128(m_initVector,prevBlock);
++#endif // OPENSSL_AES
+ }
+
-@@ -120,6 +145,11 @@
+@@ -217,6 +248,11 @@ void Rijndael::blockDecrypt(const byte *
if (inputLen <= 0)
return;
@@ -73,7 +93,7 @@
size_t numBlocks=inputLen/16;
#ifdef USE_SSE
if (AES_NI)
-@@ -182,6 +212,8 @@
+@@ -279,6 +315,8 @@ void Rijndael::blockDecrypt(const byte *
}
memcpy(m_initVector,iv,16);
@@ -82,7 +102,7 @@
}
-@@ -217,7 +249,7 @@
+@@ -314,7 +352,7 @@ void Rijndael::blockDecryptSSE(const byt
}
#endif
@@ -91,7 +111,7 @@
//////////////////////////////////////////////////////////////////////////////////////////////////////////////////
// ALGORITHM
//////////////////////////////////////////////////////////////////////////////////////////////////////////////////
-@@ -357,7 +389,7 @@
+@@ -454,7 +492,7 @@ void Rijndael::GenerateTables()
U1[b][0]=U2[b][1]=U3[b][2]=U4[b][3]=T5[i][0]=T6[i][1]=T7[i][2]=T8[i][3]=FFmul0e(b);
}
}
diff --git a/archivers/libunrar5/files/patch-rijndael.hpp b/archivers/libunrar5/files/patch-rijndael.hpp
index ca305b23e5a7..8cf2a821ed90 100644
--- a/archivers/libunrar5/files/patch-rijndael.hpp
+++ b/archivers/libunrar5/files/patch-rijndael.hpp
@@ -1,4 +1,4 @@
---- rijndael.hpp.orig 2014-06-10 17:14:06 UTC
+--- rijndael.hpp.orig 2017-04-28 17:28:47 UTC
+++ rijndael.hpp
@@ -16,6 +16,9 @@
class Rijndael
@@ -10,7 +10,7 @@
#ifdef USE_SSE
void blockEncryptSSE(const byte *input,size_t numBlocks,byte *outBuffer);
void blockDecryptSSE(const byte *input, size_t numBlocks, byte *outBuffer);
-@@ -25,6 +28,7 @@
+@@ -25,6 +28,7 @@ class Rijndael
void keySched(byte key[_MAX_KEY_COLUMNS][4]);
void keyEncToDec();
void GenerateTables();