aboutsummaryrefslogtreecommitdiffstats
path: root/archivers
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2012-05-16 13:14:28 +0800
committermiwi <miwi@FreeBSD.org>2012-05-16 13:14:28 +0800
commit9cd4c9f9046de9d07807f56170be285d501d6cf3 (patch)
treeb24f170bedc7c2cc672caac0a11d8a9018d82071 /archivers
parentbe0dbcde8dea45a9b8befaf93b43d09b93110adb (diff)
downloadfreebsd-ports-gnome-9cd4c9f9046de9d07807f56170be285d501d6cf3.tar.gz
freebsd-ports-gnome-9cd4c9f9046de9d07807f56170be285d501d6cf3.tar.zst
freebsd-ports-gnome-9cd4c9f9046de9d07807f56170be285d501d6cf3.zip
zlib is designed to be a free, general-purpose, legally unencumbered -- that is,
not covered by any patents -- lossless data-compression library for use on virtually any computer hardware and operating system. The zlib data format is itself portable across platforms. Unlike the LZW compression method used in Unix compress(1) and in the GIF image format, the compression method currently used in zlib essentially never expands the data. (LZW can double or triple the file size in extreme cases.) zlib's memory footprint is also independent of the input data and can be reduced, if necessary, at some cost in compression. WWW: http://zlib.net/ PR: ports/166991 Submitted by: Muhammad Moinur Rahman <5u623l20@gmail.com>
Diffstat (limited to 'archivers')
-rw-r--r--archivers/Makefile1
-rw-r--r--archivers/zlib/Makefile36
-rw-r--r--archivers/zlib/distinfo2
-rw-r--r--archivers/zlib/pkg-descr10
4 files changed, 49 insertions, 0 deletions
diff --git a/archivers/Makefile b/archivers/Makefile
index 9cf10002a321..eed9fa27f130 100644
--- a/archivers/Makefile
+++ b/archivers/Makefile
@@ -205,6 +205,7 @@
SUBDIR += zip
SUBDIR += zipmix
SUBDIR += zipper
+ SUBDIR += zlib
SUBDIR += zoo
SUBDIR += zutils
diff --git a/archivers/zlib/Makefile b/archivers/zlib/Makefile
new file mode 100644
index 000000000000..79ccf487d1fd
--- /dev/null
+++ b/archivers/zlib/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: zlib
+# Date created: 17 April 2012
+# Whom: Muhammad Moinur Rahman <5u623l20@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= zlib
+PORTVERSION= 1.2.6
+CATEGORIES= archivers
+MASTER_SITES= SF/libpng/${PORTNAME}/${PORTVERSION} \
+ http://zlib.net/
+
+MAINTAINER= 5u623l20@gmail.com
+COMMENT= A Massively Spiffy Yet Delicately Unobtrusive Compression Library
+
+USE_BZIP2= yes
+
+MAN3= zlib.3
+NO_MANCOMPRESS= yes
+PLIST_FILES= include/zconf.h \
+ include/zlib.h \
+ lib/libz.so \
+ lib/libz.a \
+ lib/libz.so.1 \
+ lib/libz.so.1.2.6 \
+ lib/pkgconfig/zlib.pc
+PLIST_DIRS= lib/pkgconfig
+
+HAS_CONFIGURE= yes
+
+USE_LDCONFIG= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e '/mandir/s/share\///' ${WRKSRC}/configure
+.include <bsd.port.mk>
diff --git a/archivers/zlib/distinfo b/archivers/zlib/distinfo
new file mode 100644
index 000000000000..6fa452de3733
--- /dev/null
+++ b/archivers/zlib/distinfo
@@ -0,0 +1,2 @@
+SHA256 (zlib-1.2.6.tar.bz2) = fa3e3e4881fa5810b8903f2c7e0dcd5a0a673535f0438021c4bbb5db1b918c8e
+SIZE (zlib-1.2.6.tar.bz2) = 501388
diff --git a/archivers/zlib/pkg-descr b/archivers/zlib/pkg-descr
new file mode 100644
index 000000000000..b133ec01a074
--- /dev/null
+++ b/archivers/zlib/pkg-descr
@@ -0,0 +1,10 @@
+zlib is designed to be a free, general-purpose, legally unencumbered -- that is,
+not covered by any patents -- lossless data-compression library for use on
+virtually any computer hardware and operating system. The zlib data format is
+itself portable across platforms. Unlike the LZW compression method used in Unix
+compress(1) and in the GIF image format, the compression method currently used
+in zlib essentially never expands the data. (LZW can double or triple the file
+size in extreme cases.) zlib's memory footprint is also independent of the input
+data and can be reduced, if necessary, at some cost in compression.
+
+WWW: http://zlib.net/