aboutsummaryrefslogtreecommitdiffstats
path: root/archivers
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2013-08-17 10:24:38 +0800
committervanilla <vanilla@FreeBSD.org>2013-08-17 10:24:38 +0800
commitc2ca75825177d46a0ec16b251e7f7fdf8f425cec (patch)
treeae8082eba071199b2abdf9960c4f46e4ba29c7d0 /archivers
parentafd5b621c860815237dce3b1fdc3c76547dd6c48 (diff)
downloadfreebsd-ports-gnome-c2ca75825177d46a0ec16b251e7f7fdf8f425cec.tar.gz
freebsd-ports-gnome-c2ca75825177d46a0ec16b251e7f7fdf8f425cec.tar.zst
freebsd-ports-gnome-c2ca75825177d46a0ec16b251e7f7fdf8f425cec.zip
Add lz4 r101, fast compressor using LZ4 algorithm.
PR: ports/181287 Submitted by: Alexey Degtyarev <alexey@renatasystems.org>
Diffstat (limited to 'archivers')
-rw-r--r--archivers/Makefile1
-rw-r--r--archivers/lz4/Makefile21
-rw-r--r--archivers/lz4/distinfo2
-rw-r--r--archivers/lz4/files/patch-Makefile10
-rw-r--r--archivers/lz4/patch-Makefile18
-rw-r--r--archivers/lz4/pkg-descr6
6 files changed, 58 insertions, 0 deletions
diff --git a/archivers/Makefile b/archivers/Makefile
index 18769dbd21ba..eee4428061bd 100644
--- a/archivers/Makefile
+++ b/archivers/Makefile
@@ -70,6 +70,7 @@
SUBDIR += linux-f10-ucl
SUBDIR += linux-f10-upx
SUBDIR += lrzip
+ SUBDIR += lz4
SUBDIR += lzip
SUBDIR += lzlib
SUBDIR += lzma
diff --git a/archivers/lz4/Makefile b/archivers/lz4/Makefile
new file mode 100644
index 000000000000..a5adb55bc974
--- /dev/null
+++ b/archivers/lz4/Makefile
@@ -0,0 +1,21 @@
+# Created by: Alexey Degtyarev <alexey@renatasystems.org>
+# $FreeBSD$
+
+PORTNAME= lz4
+PORTVERSION= r101
+CATEGORIES= archivers
+MASTER_SITES= https://dl.dropboxusercontent.com/u/59565338/LZ4/ \
+ ftp://ftp.renatasystems.org/pub/FreeBSD/ports/distfiles/
+
+MAINTAINER= alexey@renatasystems.org
+COMMENT= Fast compressor using LZ4 algorithm
+
+USES= gmake
+ALL_TARGET= lz4c
+
+PLIST_FILES= bin/lz4c
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/lz4c.exe ${PREFIX}/bin/lz4c
+
+.include <bsd.port.mk>
diff --git a/archivers/lz4/distinfo b/archivers/lz4/distinfo
new file mode 100644
index 000000000000..976663535fa2
--- /dev/null
+++ b/archivers/lz4/distinfo
@@ -0,0 +1,2 @@
+SHA256 (lz4-r101.tar.gz) = db645ba773002b40394875779d35c447450fcf0c459968a0776899f0c7d1435c
+SIZE (lz4-r101.tar.gz) = 128678
diff --git a/archivers/lz4/files/patch-Makefile b/archivers/lz4/files/patch-Makefile
new file mode 100644
index 000000000000..522ae207f896
--- /dev/null
+++ b/archivers/lz4/files/patch-Makefile
@@ -0,0 +1,10 @@
+--- Makefile.orig 2013-08-17 10:13:57.000000000 +0800
++++ Makefile 2013-08-17 10:14:10.000000000 +0800
+@@ -1,5 +1,5 @@
+-CC=gcc
+-CFLAGS=-I. -std=c99 -Wall -W -Wundef -Wno-implicit-function-declaration
++CC:=$(CC)
++CFLAGS:=-I. -std=c99 -Wall -W -Wundef -Wno-implicit-function-declaration
+
+ OS := $(shell uname)
+ ifeq ($(OS),Linux)
diff --git a/archivers/lz4/patch-Makefile b/archivers/lz4/patch-Makefile
new file mode 100644
index 000000000000..cd2fbd6e7834
--- /dev/null
+++ b/archivers/lz4/patch-Makefile
@@ -0,0 +1,18 @@
+--- Makefile.orig 2013-08-08 02:43:06.000000000 +0800
++++ Makefile 2013-08-17 10:11:19.000000000 +0800
+@@ -1,12 +1,7 @@
+-CC=gcc
+-CFLAGS=-I. -std=c99 -Wall -W -Wundef -Wno-implicit-function-declaration
++CC:=$(CC)
++CFLAGS+=-I. -std=c99 -Wall -W -Wundef -Wno-implicit-function-declaration
+
+-OS := $(shell uname)
+-ifeq ($(OS),Linux)
+-EXT =
+-else
+-EXT =.exe
+-endif
++EXT=
+
+ default: lz4c
+
diff --git a/archivers/lz4/pkg-descr b/archivers/lz4/pkg-descr
new file mode 100644
index 000000000000..b53ee523f3b8
--- /dev/null
+++ b/archivers/lz4/pkg-descr
@@ -0,0 +1,6 @@
+LZ4 is a very fast lossless compression algorithm, providing compression speed
+at 300 MB/s per core, scalable with multi-cores CPU. It also features an
+extremely fast decoder, with speed in GB/s per core, typically reaching RAM
+speed limits on multi-core systems.
+
+WWW: https://code.google.com/p/lz4/