aboutsummaryrefslogtreecommitdiffstats
path: root/archivers
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2006-07-28 11:10:53 +0800
committerclsung <clsung@FreeBSD.org>2006-07-28 11:10:53 +0800
commite3ae385aa3efddefb618d00908e6ae4f4442f853 (patch)
treed27e5ed0f8ae90141c76c77eae337f1925074867 /archivers
parent36a15bf99a4781b4eb00f83933630a9a75808396 (diff)
downloadfreebsd-ports-gnome-e3ae385aa3efddefb618d00908e6ae4f4442f853.tar.gz
freebsd-ports-gnome-e3ae385aa3efddefb618d00908e6ae4f4442f853.tar.zst
freebsd-ports-gnome-e3ae385aa3efddefb618d00908e6ae4f4442f853.zip
Add p5-Compress-LZW 0.01, pure perl implementation of LZW.
PR: ports/100950 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Diffstat (limited to 'archivers')
-rw-r--r--archivers/Makefile1
-rw-r--r--archivers/p5-Compress-LZW/Makefile22
-rw-r--r--archivers/p5-Compress-LZW/distinfo3
-rw-r--r--archivers/p5-Compress-LZW/pkg-descr6
-rw-r--r--archivers/p5-Compress-LZW/pkg-plist6
5 files changed, 38 insertions, 0 deletions
diff --git a/archivers/Makefile b/archivers/Makefile
index 2f449f8ed57b..5a03e07ff845 100644
--- a/archivers/Makefile
+++ b/archivers/Makefile
@@ -62,6 +62,7 @@
SUBDIR += p5-Archive-Tar
SUBDIR += p5-Archive-Zip
SUBDIR += p5-Compress-Bzip2
+ SUBDIR += p5-Compress-LZW
SUBDIR += p5-Compress-Zlib
SUBDIR += p5-IO-Zlib
SUBDIR += p5-Mac-Macbinary
diff --git a/archivers/p5-Compress-LZW/Makefile b/archivers/p5-Compress-LZW/Makefile
new file mode 100644
index 000000000000..d000665d12f9
--- /dev/null
+++ b/archivers/p5-Compress-LZW/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: p5-Compress-LZW
+# Date created: 2006-07-28
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Compress-LZW
+PORTVERSION= 0.01
+CATEGORIES= archivers perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Compress
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Pure perl implementation of LZW
+
+PERL_CONFIGURE= yes
+
+MAN3= Compress::LZW.3
+
+.include <bsd.port.mk>
diff --git a/archivers/p5-Compress-LZW/distinfo b/archivers/p5-Compress-LZW/distinfo
new file mode 100644
index 000000000000..405cb427ce61
--- /dev/null
+++ b/archivers/p5-Compress-LZW/distinfo
@@ -0,0 +1,3 @@
+MD5 (Compress-LZW-0.01.tar.gz) = 7fdd6198f2caf9de276c308f8bd8db70
+SHA256 (Compress-LZW-0.01.tar.gz) = baa1eaaf45b329898fcd5a79af3c468a5a727f944a0fff354f8727f30a72edf0
+SIZE (Compress-LZW-0.01.tar.gz) = 3106
diff --git a/archivers/p5-Compress-LZW/pkg-descr b/archivers/p5-Compress-LZW/pkg-descr
new file mode 100644
index 000000000000..2971e18a9126
--- /dev/null
+++ b/archivers/p5-Compress-LZW/pkg-descr
@@ -0,0 +1,6 @@
+Compress::LZW it a perl implementation of the newly free LZW
+compression algorithm. It defaults to building a 16-bit codeword table,
+but provides the ability to choose a 12-bit table also. Depending on
+the size of your data, the 12-bit table may provide better compression.
+
+WWW: http://search.cpan.org/dist/Compress-LZW/
diff --git a/archivers/p5-Compress-LZW/pkg-plist b/archivers/p5-Compress-LZW/pkg-plist
new file mode 100644
index 000000000000..dde86a60d5d8
--- /dev/null
+++ b/archivers/p5-Compress-LZW/pkg-plist
@@ -0,0 +1,6 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Compress/LZW/.packlist
+%%SITE_PERL%%/Compress/LZW.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Compress/LZW
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Compress
+@dirrmtry %%SITE_PERL%%/Compress