aboutsummaryrefslogtreecommitdiffstats
path: root/archivers
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2014-01-03 22:42:07 +0800
committeradamw <adamw@FreeBSD.org>2014-01-03 22:42:07 +0800
commitf20cf81a9dae51d30a97893f5b9054a05b6d19b2 (patch)
tree085773118d73f7f339d8cb24c4d7c2fbd3b9673b /archivers
parentc70bd1db8e0c6ab27fab3a411d5de8f3eb1115c1 (diff)
downloadfreebsd-ports-gnome-f20cf81a9dae51d30a97893f5b9054a05b6d19b2.tar.gz
freebsd-ports-gnome-f20cf81a9dae51d30a97893f5b9054a05b6d19b2.tar.zst
freebsd-ports-gnome-f20cf81a9dae51d30a97893f5b9054a05b6d19b2.zip
Remove NOPORT* from archivers. The only holdouts here are ruby@ now.
Diffstat (limited to 'archivers')
-rw-r--r--archivers/bzip2/Makefile3
-rw-r--r--archivers/dact/Makefile5
-rw-r--r--archivers/deutex/Makefile4
-rw-r--r--archivers/freeze/Makefile4
-rw-r--r--archivers/javatar/Makefile4
-rw-r--r--archivers/lbrate/Makefile4
-rw-r--r--archivers/macutils/Makefile4
-rw-r--r--archivers/ocaml-bz2/Makefile2
-rw-r--r--archivers/rar/Makefile2
-rw-r--r--archivers/ruby-libarchive/Makefile4
-rw-r--r--archivers/torrentzip/Makefile4
11 files changed, 28 insertions, 12 deletions
diff --git a/archivers/bzip2/Makefile b/archivers/bzip2/Makefile
index cd81717260f9..8cfaeb376a83 100644
--- a/archivers/bzip2/Makefile
+++ b/archivers/bzip2/Makefile
@@ -24,6 +24,7 @@ MLINKS= bzip2.1 bunzip2.1 bzip2.1 bzcat.1 bzip2.1 bz2cat.1 \
.error You have `USE_BZIP2' variable defined either in environment or in make(1) arguments. Please undefine and try again.
.endif
+.include <bsd.port.options.mk>
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bzip2 ${PREFIX}/bin
${LN} -sf ${PREFIX}/bin/bzip2 ${PREFIX}/bin/bunzip2
@@ -42,7 +43,7 @@ do-install:
${INSTALL_MAN} ${WRKSRC}/bzip2.1 ${PREFIX}/man/man1
${INSTALL_MAN} ${WRKSRC}/bzgrep.1 ${PREFIX}/man/man1
${INSTALL_MAN} ${WRKSRC}/bzmore.1 ${PREFIX}/man/man1
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${PREFIX}/share/doc/bzip2
${INSTALL_DATA} ${WRKSRC}/manual* ${PREFIX}/share/doc/bzip2
${INSTALL_DATA} ${WRKSRC}/bzip2.txt ${PREFIX}/share/doc/bzip2
diff --git a/archivers/dact/Makefile b/archivers/dact/Makefile
index 1395a145bbc2..c511c4199d99 100644
--- a/archivers/dact/Makefile
+++ b/archivers/dact/Makefile
@@ -23,6 +23,7 @@ MAKE_ARGS= TOBUILD="dact libdact.so dact.conf"
MAN1= dact.1
USE_LDCONFIG= yes
+.include <bsd.port.options.mk>
post-patch:
@${REINPLACE_CMD} -e "s|prefix = @prefix@|prefix = ${PREFIX}|" \
-e "s|libdir = @libdir@|libdir = ${PREFIX}/lib|" \
@@ -32,11 +33,11 @@ pre-install:
@${RM} -f ${WRKSRC}/libdact.a
post-install:
-.if !defined(NOPORTEXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
@${MKDIR} ${EXAMPLESDIR}
${CP} -n ${WRKSRC}/dact.conf ${EXAMPLESDIR} || ${TRUE}
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/Docs/dact.txt ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
diff --git a/archivers/deutex/Makefile b/archivers/deutex/Makefile
index 4c79a135b1c1..36f94626bc02 100644
--- a/archivers/deutex/Makefile
+++ b/archivers/deutex/Makefile
@@ -20,6 +20,8 @@ MAN6= ${PORTNAME}.6
PLIST_FILES= bin/deusf bin/deutex
PORTDOCS= *
+.include <bsd.port.options.mk>
+
post-extract:
@${REINPLACE_CMD} -e 's,-mkdir,mkdir -p,' ${WRKSRC}/Makefile
@${REINPLACE_CMD} -e 's,malloc\.h,stdlib.h,' ${WRKSRC}/src/tools.c
@@ -29,7 +31,7 @@ post-extract:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/deusf ${WRKSRC}/deutex ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/${MAN6} ${MANPREFIX}/man/man6
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/CHANGES ${WRKSRC}/TODO ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/dtexman6.txt ${DOCSDIR}/MANUAL
diff --git a/archivers/freeze/Makefile b/archivers/freeze/Makefile
index 6ca2c5d71259..86231f61ad79 100644
--- a/archivers/freeze/Makefile
+++ b/archivers/freeze/Makefile
@@ -20,8 +20,10 @@ MAN1= freeze.1 melt.1 unfreeze.1 fcat.1 statist.1
PLIST_FILES= bin/fcat bin/freeze bin/melt bin/statist bin/unfreeze
PORTDOCS= README
+.include <bsd.port.options.mk>
+
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
diff --git a/archivers/javatar/Makefile b/archivers/javatar/Makefile
index a2400723f5b0..117ce2e38b6b 100644
--- a/archivers/javatar/Makefile
+++ b/archivers/javatar/Makefile
@@ -24,11 +24,13 @@ PORTDOCS= api LICENSE License.html readme.html tarman.html
JARFILES= tar.jar
PLIST_FILES= ${JARFILES:S,^,%%JAVAJARDIR%%/,}
+.include <bsd.port.options.mk>
+
do-install:
@${ECHO_MSG} -n ">> Install JAR file in ${JAVAJARDIR}..."
@${INSTALL_DATA} ${WRKSRC}/jars/tar.jar ${JAVAJARDIR}/
@${ECHO_MSG} " [ DONE ]"
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${ECHO_MSG} -n ">> Installing documentation in ${DOCSDIR}..."
@${MKDIR} ${DOCSDIR}
@cd ${WRKSRC}/doc && ${FIND} ${PORTDOCS} \
diff --git a/archivers/lbrate/Makefile b/archivers/lbrate/Makefile
index e613748ee713..f2b778e61988 100644
--- a/archivers/lbrate/Makefile
+++ b/archivers/lbrate/Makefile
@@ -20,10 +20,12 @@ MAN1= lbrate.1
PORTDOCS= ChangeLog README TODO
PLIST_FILES= bin/lbrate
+.include <bsd.port.options.mk>
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/lbrate ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/lbrate.1 ${MANPREFIX}/man/man1
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
(cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR})
.endif
diff --git a/archivers/macutils/Makefile b/archivers/macutils/Makefile
index 16c27d3a0361..816a50be5c87 100644
--- a/archivers/macutils/Makefile
+++ b/archivers/macutils/Makefile
@@ -23,6 +23,8 @@ DOCFILES= README.crc README.hexbin README.macput README.unpit \
README.zoom README.crc.orig README.macget README.scan \
README.unsit ../README
+.include <bsd.port.options.mk>
+
# The distribution has a naff install target which doesn't install man
# pages so here is a decent one.
#
@@ -44,7 +46,7 @@ do-install:
${INSTALL_MAN} ${WRKSRC}/man/tomac.1 ${MANPREFIX}/man/man1
${INSTALL_MAN} ${WRKSRC}/man/frommac.1 ${MANPREFIX}/man/man1
${INSTALL_MAN} ${WRKSRC}/man/macutil.1 ${MANPREFIX}/man/man1
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${ECHO_MSG} "===> Installing supplementary documents..."
@${MKDIR} ${DOCSDIR}
.for file in ${DOCFILES}
diff --git a/archivers/ocaml-bz2/Makefile b/archivers/ocaml-bz2/Makefile
index aa7bf14df7e3..365a48bc2d0f 100644
--- a/archivers/ocaml-bz2/Makefile
+++ b/archivers/ocaml-bz2/Makefile
@@ -27,7 +27,7 @@ PORTDOCS= *
.include <bsd.port.pre.mk>
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
(cd ${WRKSRC}/doc && ${COPYTREE_SHARE} \* ${DOCSDIR})
diff --git a/archivers/rar/Makefile b/archivers/rar/Makefile
index 2b1bcb3c5dec..b503e6c48d54 100644
--- a/archivers/rar/Makefile
+++ b/archivers/rar/Makefile
@@ -44,7 +44,7 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/default.sfx ${PREFIX}/lib
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
.for i in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
diff --git a/archivers/ruby-libarchive/Makefile b/archivers/ruby-libarchive/Makefile
index b0968891b0bd..63a4daf2632f 100644
--- a/archivers/ruby-libarchive/Makefile
+++ b/archivers/ruby-libarchive/Makefile
@@ -21,8 +21,10 @@ WRKSRC= ${WRKDIR}/ext
DOCS= README.txt doc
+.include <bsd.port.options.mk>
+
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${RUBY_MODDOCDIR}
cd ${WRKDIR}; ${COPYTREE_SHARE} "${DOCS}" ${RUBY_MODDOCDIR}/
.endif
diff --git a/archivers/torrentzip/Makefile b/archivers/torrentzip/Makefile
index 16bba00eed54..52bb90be9361 100644
--- a/archivers/torrentzip/Makefile
+++ b/archivers/torrentzip/Makefile
@@ -23,7 +23,9 @@ PORTDOCS= README
run-autotools:: run-autotools-aclocal run-autotools-autoheader \
run-autotools-autoconf run-autotools-automake
-.if !defined(NOPORTDOCS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MDOCS}
pre-install:
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}/README