aboutsummaryrefslogtreecommitdiffstats
path: root/archivers
diff options
context:
space:
mode:
authorperky <perky@FreeBSD.org>2004-05-28 22:33:03 +0800
committerperky <perky@FreeBSD.org>2004-05-28 22:33:03 +0800
commitf2b7e0850f6e92933e7bb06a278ad0424cd3be0c (patch)
treedecab1a65423fe592b0acac2188c74a74641788c /archivers
parent1652d2764301251d96fbee0a11ee6a5a438f6954 (diff)
downloadfreebsd-ports-gnome-f2b7e0850f6e92933e7bb06a278ad0424cd3be0c.tar.gz
freebsd-ports-gnome-f2b7e0850f6e92933e7bb06a278ad0424cd3be0c.tar.zst
freebsd-ports-gnome-f2b7e0850f6e92933e7bb06a278ad0424cd3be0c.zip
Add py-lzma, a 7zip compression library for Python.
Diffstat (limited to 'archivers')
-rw-r--r--archivers/Makefile1
-rw-r--r--archivers/py-lzma/Makefile21
-rw-r--r--archivers/py-lzma/distinfo2
-rw-r--r--archivers/py-lzma/pkg-descr10
-rw-r--r--archivers/py-lzma/pkg-plist4
5 files changed, 38 insertions, 0 deletions
diff --git a/archivers/Makefile b/archivers/Makefile
index 062567e940fb..1333b6c07436 100644
--- a/archivers/Makefile
+++ b/archivers/Makefile
@@ -52,6 +52,7 @@
SUBDIR += pear-Archive_Tar
SUBDIR += ppunpack
SUBDIR += py-bzip2
+ SUBDIR += py-lzma
SUBDIR += py-tarfile
SUBDIR += rar
SUBDIR += rox-archive
diff --git a/archivers/py-lzma/Makefile b/archivers/py-lzma/Makefile
new file mode 100644
index 000000000000..aa182f0fccdd
--- /dev/null
+++ b/archivers/py-lzma/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: py-lzma
+# Date created: 28 May 2004
+# Whom: Hye-Shik Chang
+#
+# $FreeBSD$
+#
+
+PORTNAME= lzma
+PORTVERSION= 0.0.3
+CATEGORIES= archivers python
+MASTER_SITES= http://www.joachim-bauch.de/projects/python/pylzma/releases/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= pylzma-${PORTVERSION}
+
+MAINTAINER= perky@FreeBSD.org
+COMMENT= Python binding for the LZMA compression library
+
+USE_PYTHON= yes
+USE_PYDISTUTILS=yes
+
+.include <bsd.port.mk>
diff --git a/archivers/py-lzma/distinfo b/archivers/py-lzma/distinfo
new file mode 100644
index 000000000000..551866873dd7
--- /dev/null
+++ b/archivers/py-lzma/distinfo
@@ -0,0 +1,2 @@
+MD5 (pylzma-0.0.3.tar.gz) = 312416b2cdf6f4b82ec8fc7a816f74a4
+SIZE (pylzma-0.0.3.tar.gz) = 73057
diff --git a/archivers/py-lzma/pkg-descr b/archivers/py-lzma/pkg-descr
new file mode 100644
index 000000000000..3fe021a9295c
--- /dev/null
+++ b/archivers/py-lzma/pkg-descr
@@ -0,0 +1,10 @@
+Python binding for the LZMA compression library.
+
+Supported Features:
+ * Compression / decompression of a single block of data
+ * Compression from a file-like object (must provide a read method)
+ * Streaming decompression through multiple calls to decompress.
+ * An initial library that supports reading of 7-zip archives (both
+ solid and non-solid)
+
+WWW: http://www.joachim-bauch.de/projects/python/pylzma
diff --git a/archivers/py-lzma/pkg-plist b/archivers/py-lzma/pkg-plist
new file mode 100644
index 000000000000..fbbe07f7fee3
--- /dev/null
+++ b/archivers/py-lzma/pkg-plist
@@ -0,0 +1,4 @@
+%%PYTHON_SITELIBDIR%%/py7zlib.py
+%%PYTHON_SITELIBDIR%%/py7zlib.pyc
+%%PYTHON_SITELIBDIR%%/py7zlib.pyo
+%%PYTHON_SITELIBDIR%%/pylzma.so