aboutsummaryrefslogtreecommitdiffstats
path: root/archivers
diff options
context:
space:
mode:
authorjohans <johans@FreeBSD.org>2010-07-07 00:47:50 +0800
committerjohans <johans@FreeBSD.org>2010-07-07 00:47:50 +0800
commit3230804d9192be919dbb0ceca72d93d33f3bdea0 (patch)
tree5195750c0d510536e6e383b580d3c3f40c248b61 /archivers
parent2da28846e03132043eeb03c240caf0fdcfb621e9 (diff)
downloadfreebsd-ports-gnome-3230804d9192be919dbb0ceca72d93d33f3bdea0.tar.gz
freebsd-ports-gnome-3230804d9192be919dbb0ceca72d93d33f3bdea0.tar.zst
freebsd-ports-gnome-3230804d9192be919dbb0ceca72d93d33f3bdea0.zip
- Add extra patch that should fix the rpm build on FreeBSD 6.x
Reported by: pointyhat via erwin Feature safe: yes
Diffstat (limited to 'archivers')
-rw-r--r--archivers/rpm4/Makefile3
-rw-r--r--archivers/rpm4/files/extra-patch-lib_fs.c11
2 files changed, 14 insertions, 0 deletions
diff --git a/archivers/rpm4/Makefile b/archivers/rpm4/Makefile
index acb2af54c2ae..479104e5d1f8 100644
--- a/archivers/rpm4/Makefile
+++ b/archivers/rpm4/Makefile
@@ -81,6 +81,9 @@ PORTDOCS= *
.if ${OSVERSION} < 800502
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-rpmio_rpmsq.c
.endif
+.if ${OSVERSION} < 700000
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-lib_fs.c
+.endif
post-patch:
${REINPLACE_CMD} -e '/^pkgconfigdir/s:/:data/:' \
diff --git a/archivers/rpm4/files/extra-patch-lib_fs.c b/archivers/rpm4/files/extra-patch-lib_fs.c
new file mode 100644
index 000000000000..810cc5448ebe
--- /dev/null
+++ b/archivers/rpm4/files/extra-patch-lib_fs.c
@@ -0,0 +1,11 @@
+--- lib/fs.c.orig 2010-07-06 07:27:10.000000000 +0200
++++ lib/fs.c 2010-07-06 07:27:12.000000000 +0200
+@@ -134,6 +134,8 @@ exit:
+
+ #else /* HAVE_MNTCTL */
+
++#include <sys/mount.h>
++
+ /**
+ * Get information for mounted file systems.
+ * @todo determine rdonly for non-linux file systems.