aboutsummaryrefslogtreecommitdiffstats
path: root/archivers
diff options
context:
space:
mode:
authornaddy <naddy@FreeBSD.org>2010-05-22 00:23:46 +0800
committernaddy <naddy@FreeBSD.org>2010-05-22 00:23:46 +0800
commit49639d17a2fdbc05df5cd315a85b532aa16d2589 (patch)
tree1c14ace8b2285b597feb56698cf475e81b2591b1 /archivers
parent22a2c1c2a6ad16ea36eb8e89262f2e501955bf56 (diff)
downloadfreebsd-ports-gnome-49639d17a2fdbc05df5cd315a85b532aa16d2589.tar.gz
freebsd-ports-gnome-49639d17a2fdbc05df5cd315a85b532aa16d2589.tar.zst
freebsd-ports-gnome-49639d17a2fdbc05df5cd315a85b532aa16d2589.zip
The xz utils and lzma library have been imported into base, so make
the dependency on the archivers/xz port conditional on OSVERSION.
Diffstat (limited to 'archivers')
-rw-r--r--archivers/gtar/Makefile10
-rw-r--r--archivers/libarchive/Makefile10
-rw-r--r--archivers/py-liblzma/Makefile9
-rw-r--r--archivers/rpm5/Makefile5
4 files changed, 26 insertions, 8 deletions
diff --git a/archivers/gtar/Makefile b/archivers/gtar/Makefile
index 9a10ed294382..dfd88494860b 100644
--- a/archivers/gtar/Makefile
+++ b/archivers/gtar/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= naddy@FreeBSD.org
COMMENT= GNU version of the traditional tape archiver
# only force dependencies for compressors that have a single-letter option
-RUN_DEPENDS= xz:${PORTSDIR}/archivers/xz
+#RUN_DEPENDS= # see below
INFO= tar
@@ -50,4 +50,10 @@ PLIST_SUB+= NLS="@comment "
regression-test: build
@cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} check
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 800505 || (${OSVERSION} >= 900000 && ${OSVERSION} < 900012)
+RUN_DEPENDS+= xz:${PORTSDIR}/archivers/xz
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/archivers/libarchive/Makefile b/archivers/libarchive/Makefile
index 4d05d7035081..cfa9ae7b9e96 100644
--- a/archivers/libarchive/Makefile
+++ b/archivers/libarchive/Makefile
@@ -13,8 +13,6 @@ MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
MAINTAINER= glewis@FreeBSD.org
COMMENT= Library to create and read several streaming archive formats
-LIB_DEPENDS= lzma.0:${PORTSDIR}/archivers/xz
-
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
USE_GNOME= libxml2
@@ -55,4 +53,10 @@ CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib" \
check:
(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} check)
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 800505 || (${OSVERSION} >= 900000 && ${OSVERSION} < 900012)
+LIB_DEPENDS+= lzma.0:${PORTSDIR}/archivers/xz
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/archivers/py-liblzma/Makefile b/archivers/py-liblzma/Makefile
index 78642f50187d..eec72d1e8465 100644
--- a/archivers/py-liblzma/Makefile
+++ b/archivers/py-liblzma/Makefile
@@ -16,11 +16,16 @@ MAINTAINER= naylor.b.david@gmail.com
COMMENT= Python binding for the LZMA compression library
BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkg-config
-LIB_DEPENDS= lzma.0:${PORTSDIR}/archivers/xz
USE_BZIP2= yes
USE_PYTHON= 2.6+
USE_PYDISTUTILS=yes
PYDISTUTILS_PKGNAME= py${PORTNAME}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 800505 || (${OSVERSION} >= 900000 && ${OSVERSION} < 900012)
+LIB_DEPENDS+= lzma.0:${PORTSDIR}/archivers/xz
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/archivers/rpm5/Makefile b/archivers/rpm5/Makefile
index 7671c5012e6e..6bd3d0130c0b 100644
--- a/archivers/rpm5/Makefile
+++ b/archivers/rpm5/Makefile
@@ -22,7 +22,6 @@ LIB_DEPENDS= db-${DB_VERSION:C/(.)/\1./}:${PORTSDIR}/databases/db${DB_VERSION} \
neon.28:${PORTSDIR}/www/neon28 \
magic:${PORTSDIR}/sysutils/file \
xar:${PORTSDIR}/archivers/xar \
- lzma:${PORTSDIR}/archivers/xz \
pcre.0:${PORTSDIR}/devel/pcre
BUILD_DEPENDS= ${LOCALBASE}/bin/gsed:${PORTSDIR}/textproc/gsed
.if !defined(NOPORTDOCS)
@@ -118,6 +117,10 @@ PORTDOCS= *
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 800505 || (${OSVERSION} >= 900000 && ${OSVERSION} < 900012)
+LIB_DEPENDS+= lzma:${PORTSDIR}/archivers/xz
+.endif
+
.if ${ARCH} == "amd64"
CFLAGS+= -fPIC
.endif