aboutsummaryrefslogtreecommitdiffstats
path: root/archivers
diff options
context:
space:
mode:
authorjhale <jhale@FreeBSD.org>2017-01-01 23:45:43 +0800
committerjhale <jhale@FreeBSD.org>2017-01-01 23:45:43 +0800
commit5b57624948d457aa91a540313787eaaec3546099 (patch)
treef74246bb203e8184aeae4cfcc4f8a49d29f72ed3 /archivers
parent315cc62e0cf6488a18bdff50e295e14c94fae2e6 (diff)
downloadfreebsd-ports-gnome-5b57624948d457aa91a540313787eaaec3546099.tar.gz
freebsd-ports-gnome-5b57624948d457aa91a540313787eaaec3546099.tar.zst
freebsd-ports-gnome-5b57624948d457aa91a540313787eaaec3546099.zip
Add -fPIC to CXXFLAGS to fix build with amd64 and other archs that likely
need it Reported by: pkg-fallout
Diffstat (limited to 'archivers')
-rw-r--r--archivers/libunrar5/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/archivers/libunrar5/Makefile b/archivers/libunrar5/Makefile
index b1d55606a999..a646843db454 100644
--- a/archivers/libunrar5/Makefile
+++ b/archivers/libunrar5/Makefile
@@ -2,6 +2,7 @@
PORTNAME= libunrar5
PORTVERSION= 5.4.5
+PORTREVISION= 1
CATEGORIES= archivers
MASTER_SITES= http://www.rarlab.com/rar/
DISTNAME= unrarsrc-${PORTVERSION}
@@ -21,7 +22,7 @@ ALL_TARGET= lib liba
MAKEFILE= makefile
MAKE_ARGS= AR="${AR}" \
CXX="${CXX}" \
- CXXFLAGS="${CXXFLAGS}" \
+ CXXFLAGS="${CXXFLAGS} -fPIC" \
LDFLAGS="-Wl,-soname,${SONAME} -pthread ${LDFLAGS}" \
STRIP="${STRIP_CMD}"
SONAME= libunrar.so.5