aboutsummaryrefslogtreecommitdiffstats
path: root/archivers
diff options
context:
space:
mode:
authoraraujo <araujo@FreeBSD.org>2009-03-16 02:27:46 +0800
committeraraujo <araujo@FreeBSD.org>2009-03-16 02:27:46 +0800
commit805f15b3c11f79c2e6826987ceca8eae23b7097e (patch)
treeb06b9b2d563971ca14373f35fd5cde92eb007c22 /archivers
parent0d627b3b7e4f618fb65ae4933f022f672e2f5a06 (diff)
downloadfreebsd-ports-gnome-805f15b3c11f79c2e6826987ceca8eae23b7097e.tar.gz
freebsd-ports-gnome-805f15b3c11f79c2e6826987ceca8eae23b7097e.tar.zst
freebsd-ports-gnome-805f15b3c11f79c2e6826987ceca8eae23b7097e.zip
- Fixes a missed offset update when using quiet mode with par2create.
This bug has been referenced here: http://sourceforge.net/tracker/index.php?func=detail&aid=1802742&group_id=30568&atid=399698 http://sourceforge.net/tracker/index.php?func=detail&aid=1085638&group_id=30568&atid=399698 PR: ports/132494 Submitted by: Ganael Laplanche <ganael.laplanche@martymac.com> (maintainer)
Diffstat (limited to 'archivers')
-rw-r--r--archivers/par2cmdline/Makefile4
-rw-r--r--archivers/par2cmdline/files/patch-par2creatorsourcefile.cpp13
2 files changed, 15 insertions, 2 deletions
diff --git a/archivers/par2cmdline/Makefile b/archivers/par2cmdline/Makefile
index 588bd0991d27..68c838313212 100644
--- a/archivers/par2cmdline/Makefile
+++ b/archivers/par2cmdline/Makefile
@@ -7,7 +7,7 @@
PORTNAME= par2cmdline
PORTVERSION= 0.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= archivers
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= parchive
@@ -25,7 +25,7 @@ PLIST_FILES= bin/par2 bin/par2create bin/par2repair bin/par2verify
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
- ${INSTALL_MAN} ${WRKSRC}/README ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/README ${DOCSDIR}/
.endif
.include <bsd.port.mk>
diff --git a/archivers/par2cmdline/files/patch-par2creatorsourcefile.cpp b/archivers/par2cmdline/files/patch-par2creatorsourcefile.cpp
new file mode 100644
index 000000000000..b275a374dfb6
--- /dev/null
+++ b/archivers/par2cmdline/files/patch-par2creatorsourcefile.cpp
@@ -0,0 +1,13 @@
+--- par2creatorsourcefile.cpp.orig 2009-03-10 07:10:35.860499029 +0000
++++ par2creatorsourcefile.cpp 2009-03-10 07:12:53.111712521 +0000
+@@ -224,6 +224,10 @@
+ cout << newfraction/10 << '.' << newfraction%10 << "%\r" << flush;
+ }
+ }
++ else
++ {
++ offset += want;
++ }
+ }
+
+ // Did we finish the last block