aboutsummaryrefslogtreecommitdiffstats
path: root/archivers
diff options
context:
space:
mode:
authorfeld <feld@FreeBSD.org>2017-10-13 01:30:49 +0800
committerfeld <feld@FreeBSD.org>2017-10-13 01:30:49 +0800
commit86e183509710ee05c7764119b194c98e84917af8 (patch)
treee99e50f43bd226bd84d010ee7f3b220078be42ee /archivers
parent78928a97fa1820603d47199fd5ea2c3aec665b12 (diff)
downloadfreebsd-ports-gnome-86e183509710ee05c7764119b194c98e84917af8.tar.gz
freebsd-ports-gnome-86e183509710ee05c7764119b194c98e84917af8.tar.zst
freebsd-ports-gnome-86e183509710ee05c7764119b194c98e84917af8.zip
czipfile is a replacement for Python's builtin "zipfile" module, and
provides much faster, C-based zipfile decryption. The code is actually 95% identical to Python 2.6.5's Lib/zipfile.py, with some very minor modifications to allow it to compile in Cython, and the _ZipDecrypter class adapted to take advantage of native C datatypes. WWW: http://pypi.python.org/pypi/czipfile
Diffstat (limited to 'archivers')
-rw-r--r--archivers/Makefile1
-rw-r--r--archivers/py-czipfile/Makefile18
-rw-r--r--archivers/py-czipfile/distinfo3
-rw-r--r--archivers/py-czipfile/pkg-descr7
4 files changed, 29 insertions, 0 deletions
diff --git a/archivers/Makefile b/archivers/Makefile
index 4aec29edace8..e54846724179 100644
--- a/archivers/Makefile
+++ b/archivers/Makefile
@@ -171,6 +171,7 @@
SUBDIR += py-borgbackup
SUBDIR += py-brotli
SUBDIR += py-bz2file
+ SUBDIR += py-czipfile
SUBDIR += py-libarchive-c
SUBDIR += py-librtfcomp
SUBDIR += py-lz4
diff --git a/archivers/py-czipfile/Makefile b/archivers/py-czipfile/Makefile
new file mode 100644
index 000000000000..fc7020673f06
--- /dev/null
+++ b/archivers/py-czipfile/Makefile
@@ -0,0 +1,18 @@
+# Created by: Mark Felder <feld@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= czipfile
+PORTVERSION= 1.0.0
+CATEGORIES= archivers python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= feld@FreeBSD.org
+COMMENT= Fast C-based zipfile decryption for Python
+
+LICENSE= PSFL
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>
diff --git a/archivers/py-czipfile/distinfo b/archivers/py-czipfile/distinfo
new file mode 100644
index 000000000000..e0d8300c54c5
--- /dev/null
+++ b/archivers/py-czipfile/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1507829056
+SHA256 (czipfile-1.0.0.tar.gz) = 1b6f94fabab92eb8e0ca1c7e3fa52c0f20895c05101ca954dd43d60cff84bb0a
+SIZE (czipfile-1.0.0.tar.gz) = 144418
diff --git a/archivers/py-czipfile/pkg-descr b/archivers/py-czipfile/pkg-descr
new file mode 100644
index 000000000000..2fb99e8af3d6
--- /dev/null
+++ b/archivers/py-czipfile/pkg-descr
@@ -0,0 +1,7 @@
+czipfile is a replacement for Python's builtin "zipfile" module, and
+provides much faster, C-based zipfile decryption. The code is actually
+95% identical to Python 2.6.5's Lib/zipfile.py, with some very minor
+modifications to allow it to compile in Cython, and the _ZipDecrypter
+class adapted to take advantage of native C datatypes.
+
+WWW: http://pypi.python.org/pypi/czipfile