aboutsummaryrefslogtreecommitdiffstats
path: root/archivers
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2018-02-13 03:03:13 +0800
committersunpoet <sunpoet@FreeBSD.org>2018-02-13 03:03:13 +0800
commit8dd7cdad32bb2f10dfbd3fd34e46dc820c810d51 (patch)
treea76e5b4e575e29f6b6db3006897fc9c423572d30 /archivers
parentc8947ef97cd0b88b4945d5de7753faf55de73132 (diff)
downloadfreebsd-ports-gnome-8dd7cdad32bb2f10dfbd3fd34e46dc820c810d51.tar.gz
freebsd-ports-gnome-8dd7cdad32bb2f10dfbd3fd34e46dc820c810d51.tar.zst
freebsd-ports-gnome-8dd7cdad32bb2f10dfbd3fd34e46dc820c810d51.zip
Add p5-Archive-Tar-Wrapper 0.23
Archive::Tar::Wrapper is an API wrapper around the 'tar' command line utility. It never stores anything in memory, but works on temporary directory structures on disk instead. It provides a mapping between the logical paths in the tarball and the 'real' files in the temporary directory on disk. It differs from Archive::Tar in two ways: - Archive::Tar::Wrapper doesn't hold anything in memory. Everything is stored on disk. - Archive::Tar::Wrapper is 100% compliant with the platform's tar utility, because it uses it internally. WWW: http://search.cpan.org/dist/Archive-Tar-Wrapper/
Diffstat (limited to 'archivers')
-rw-r--r--archivers/Makefile1
-rw-r--r--archivers/p5-Archive-Tar-Wrapper/Makefile25
-rw-r--r--archivers/p5-Archive-Tar-Wrapper/distinfo3
-rw-r--r--archivers/p5-Archive-Tar-Wrapper/pkg-descr12
-rw-r--r--archivers/p5-Archive-Tar-Wrapper/pkg-plist2
5 files changed, 43 insertions, 0 deletions
diff --git a/archivers/Makefile b/archivers/Makefile
index 3a115820926e..24f1222dad5e 100644
--- a/archivers/Makefile
+++ b/archivers/Makefile
@@ -105,6 +105,7 @@
SUBDIR += p5-Archive-Rar
SUBDIR += p5-Archive-SimpleExtractor
SUBDIR += p5-Archive-Tar
+ SUBDIR += p5-Archive-Tar-Wrapper
SUBDIR += p5-Archive-Zip
SUBDIR += p5-Compress-Bzip2
SUBDIR += p5-Compress-LZ4
diff --git a/archivers/p5-Archive-Tar-Wrapper/Makefile b/archivers/p5-Archive-Tar-Wrapper/Makefile
new file mode 100644
index 000000000000..2902966c486a
--- /dev/null
+++ b/archivers/p5-Archive-Tar-Wrapper/Makefile
@@ -0,0 +1,25 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= Archive-Tar-Wrapper
+PORTVERSION= 0.23
+CATEGORIES= archivers perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= API wrapper around the 'tar' utility
+
+LICENSE= ART10 GPLv1+
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-File-Which>=0:sysutils/p5-File-Which \
+ p5-IPC-Run>=0:devel/p5-IPC-Run \
+ p5-Log-Log4perl>=0:devel/p5-Log-Log4perl
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+NO_ARCH= yes
+USE_PERL5= configure
+USES= perl5
+
+.include <bsd.port.mk>
diff --git a/archivers/p5-Archive-Tar-Wrapper/distinfo b/archivers/p5-Archive-Tar-Wrapper/distinfo
new file mode 100644
index 000000000000..8870fdba350e
--- /dev/null
+++ b/archivers/p5-Archive-Tar-Wrapper/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1518456093
+SHA256 (Archive-Tar-Wrapper-0.23.tar.gz) = 4c02393a513619e123cff5f6bd3021b64b3e3146fac9dc2da02329de440674fa
+SIZE (Archive-Tar-Wrapper-0.23.tar.gz) = 16287
diff --git a/archivers/p5-Archive-Tar-Wrapper/pkg-descr b/archivers/p5-Archive-Tar-Wrapper/pkg-descr
new file mode 100644
index 000000000000..3bceca2fe945
--- /dev/null
+++ b/archivers/p5-Archive-Tar-Wrapper/pkg-descr
@@ -0,0 +1,12 @@
+Archive::Tar::Wrapper is an API wrapper around the 'tar' command line utility.
+It never stores anything in memory, but works on temporary directory structures
+on disk instead. It provides a mapping between the logical paths in the tarball
+and the 'real' files in the temporary directory on disk.
+
+It differs from Archive::Tar in two ways:
+- Archive::Tar::Wrapper doesn't hold anything in memory. Everything is stored on
+ disk.
+- Archive::Tar::Wrapper is 100% compliant with the platform's tar utility,
+ because it uses it internally.
+
+WWW: http://search.cpan.org/dist/Archive-Tar-Wrapper/
diff --git a/archivers/p5-Archive-Tar-Wrapper/pkg-plist b/archivers/p5-Archive-Tar-Wrapper/pkg-plist
new file mode 100644
index 000000000000..e99e487bc236
--- /dev/null
+++ b/archivers/p5-Archive-Tar-Wrapper/pkg-plist
@@ -0,0 +1,2 @@
+%%SITE_PERL%%/Archive/Tar/Wrapper.pm
+%%PERL5_MAN3%%/Archive::Tar::Wrapper.3.gz