aboutsummaryrefslogtreecommitdiffstats
path: root/archivers
diff options
context:
space:
mode:
authortz <tz@FreeBSD.org>2017-11-16 18:48:48 +0800
committertz <tz@FreeBSD.org>2017-11-16 18:48:48 +0800
commit9c489fdd6e8643dedbe20c8b8fbcfc2d73c2109c (patch)
treea2ff3d816b255016827738be132f8fc8bff8f5d9 /archivers
parent27bd51e10cb05bed8f12f0c893e867200727f95c (diff)
downloadfreebsd-ports-gnome-9c489fdd6e8643dedbe20c8b8fbcfc2d73c2109c.tar.gz
freebsd-ports-gnome-9c489fdd6e8643dedbe20c8b8fbcfc2d73c2109c.tar.zst
freebsd-ports-gnome-9c489fdd6e8643dedbe20c8b8fbcfc2d73c2109c.zip
Add PHP 7.2 RC6
Notable changes: - mcrypt module was removed - sodium module was added - sybase_ct artifacts removed Also many PECL ports will not work with this version since some files got renamed. Reviewed by: mat, ale, Rainer Duffner <rainer@ultra-secure.de> Differential Revision: https://reviews.freebsd.org/D12980
Diffstat (limited to 'archivers')
-rw-r--r--archivers/Makefile4
-rw-r--r--archivers/php72-bz2/Makefile9
-rw-r--r--archivers/php72-phar/Makefile9
-rw-r--r--archivers/php72-phar/files/patch-config.m441
-rw-r--r--archivers/php72-phar/files/patch-phar.c11
-rw-r--r--archivers/php72-zip/Makefile9
-rw-r--r--archivers/php72-zlib/Makefile9
-rw-r--r--archivers/php72-zlib/files/patch-zlib.c10
8 files changed, 102 insertions, 0 deletions
diff --git a/archivers/Makefile b/archivers/Makefile
index e54846724179..e86d4eb76ef3 100644
--- a/archivers/Makefile
+++ b/archivers/Makefile
@@ -159,6 +159,10 @@
SUBDIR += php71-phar
SUBDIR += php71-zip
SUBDIR += php71-zlib
+ SUBDIR += php72-bz2
+ SUBDIR += php72-phar
+ SUBDIR += php72-zip
+ SUBDIR += php72-zlib
SUBDIR += pigz
SUBDIR += pixz
SUBDIR += plzip
diff --git a/archivers/php72-bz2/Makefile b/archivers/php72-bz2/Makefile
new file mode 100644
index 000000000000..2193091f43da
--- /dev/null
+++ b/archivers/php72-bz2/Makefile
@@ -0,0 +1,9 @@
+# $FreeBSD$
+
+CATEGORIES= archivers
+
+MASTERDIR= ${.CURDIR}/../../lang/php72
+
+PKGNAMESUFFIX= -bz2
+
+.include "${MASTERDIR}/Makefile"
diff --git a/archivers/php72-phar/Makefile b/archivers/php72-phar/Makefile
new file mode 100644
index 000000000000..8adfdb8f76aa
--- /dev/null
+++ b/archivers/php72-phar/Makefile
@@ -0,0 +1,9 @@
+# $FreeBSD$
+
+CATEGORIES= archivers
+
+MASTERDIR= ${.CURDIR}/../../lang/php72
+
+PKGNAMESUFFIX= -phar
+
+.include "${MASTERDIR}/Makefile"
diff --git a/archivers/php72-phar/files/patch-config.m4 b/archivers/php72-phar/files/patch-config.m4
new file mode 100644
index 000000000000..1aba3bd9a5a8
--- /dev/null
+++ b/archivers/php72-phar/files/patch-config.m4
@@ -0,0 +1,41 @@
+--- config.m4.orig 2016-06-21 19:56:50 UTC
++++ config.m4
+@@ -4,8 +4,38 @@ dnl config.m4 for extension phar
+ PHP_ARG_ENABLE(phar, for phar archive support,
+ [ --disable-phar Disable phar support], yes)
+
++PHP_ARG_WITH(pcre-dir, pcre install prefix,
++[ --with-pcre-dir PHAR: pcre install prefix], no, no)
++
++
+ if test "$PHP_PHAR" != "no"; then
++
++ dnl This is PECL build, check if bundled PCRE library is used
++ old_CPPFLAGS=$CPPFLAGS
++ CPPFLAGS=$INCLUDES
++ AC_EGREP_CPP(yes,[
++#include <main/php_config.h>
++#if defined(HAVE_BUNDLED_PCRE) && !defined(COMPILE_DL_PCRE)
++yes
++#endif
++ ],[
++ PHP_PCRE_REGEX=yes
++ ],[
++ AC_EGREP_CPP(yes,[
++#include <main/php_config.h>
++#if defined(HAVE_PCRE) && !defined(COMPILE_DL_PCRE)
++yes
++#endif
++ ],[
++ PHP_PCRE_REGEX=pecl
++ PHP_ADD_INCLUDE($PHP_PCRE_DIR/include)
++ ],[
++ PHP_PCRE_REGEX=no
++ ])
++ ])
++
+ PHP_NEW_EXTENSION(phar, util.c tar.c zip.c stream.c func_interceptors.c dirstream.c phar.c phar_object.c phar_path_check.c, $ext_shared,, -DZEND_ENABLE_STATIC_TSRMLS_CACHE=1)
++ PHP_HASH=yes
+ AC_MSG_CHECKING([for phar openssl support])
+ if test "$PHP_HASH_SHARED" != "yes"; then
+ if test "$PHP_HASH" != "no"; then
diff --git a/archivers/php72-phar/files/patch-phar.c b/archivers/php72-phar/files/patch-phar.c
new file mode 100644
index 000000000000..e7ae6cb3328d
--- /dev/null
+++ b/archivers/php72-phar/files/patch-phar.c
@@ -0,0 +1,11 @@
+--- phar.c.orig 2016-06-21 19:56:49 UTC
++++ phar.c
+@@ -3589,7 +3589,7 @@ static const zend_module_dep phar_deps[]
+ ZEND_MOD_OPTIONAL("openssl")
+ ZEND_MOD_OPTIONAL("zlib")
+ ZEND_MOD_OPTIONAL("standard")
+-#if defined(HAVE_HASH) && !defined(COMPILE_DL_HASH)
++#if defined(HAVE_HASH)
+ ZEND_MOD_REQUIRED("hash")
+ #endif
+ #if HAVE_SPL
diff --git a/archivers/php72-zip/Makefile b/archivers/php72-zip/Makefile
new file mode 100644
index 000000000000..3b4f0a2b308f
--- /dev/null
+++ b/archivers/php72-zip/Makefile
@@ -0,0 +1,9 @@
+# $FreeBSD$
+
+CATEGORIES= archivers
+
+MASTERDIR= ${.CURDIR}/../../lang/php72
+
+PKGNAMESUFFIX= -zip
+
+.include "${MASTERDIR}/Makefile"
diff --git a/archivers/php72-zlib/Makefile b/archivers/php72-zlib/Makefile
new file mode 100644
index 000000000000..65f534fc0c81
--- /dev/null
+++ b/archivers/php72-zlib/Makefile
@@ -0,0 +1,9 @@
+# $FreeBSD$
+
+CATEGORIES= archivers
+
+MASTERDIR= ${.CURDIR}/../../lang/php72
+
+PKGNAMESUFFIX= -zlib
+
+.include "${MASTERDIR}/Makefile"
diff --git a/archivers/php72-zlib/files/patch-zlib.c b/archivers/php72-zlib/files/patch-zlib.c
new file mode 100644
index 000000000000..be02c50d1df6
--- /dev/null
+++ b/archivers/php72-zlib/files/patch-zlib.c
@@ -0,0 +1,10 @@
+--- zlib.c.orig 2016-06-21 19:57:08 UTC
++++ zlib.c
+@@ -1480,6 +1480,7 @@ static PHP_MSHUTDOWN_FUNCTION(zlib)
+ /* {{{ PHP_RINIT_FUNCTION */
+ static PHP_RINIT_FUNCTION(zlib)
+ {
++ ZLIBG(output_compression) = 0;
+ ZLIBG(compression_coding) = 0;
+ if (!ZLIBG(handler_registered)) {
+ ZLIBG(output_compression) = ZLIBG(output_compression_default);