aboutsummaryrefslogtreecommitdiffstats
path: root/archivers
diff options
context:
space:
mode:
authorkoobs <koobs@FreeBSD.org>2016-01-31 16:21:49 +0800
committerkoobs <koobs@FreeBSD.org>2016-01-31 16:21:49 +0800
commitb0fe847bde1bfaa48780345978154ad12c0e0ae4 (patch)
treedf5f77182ab69211ea1c75fc51db5067e475c2c7 /archivers
parent66bb7811a4a4ec3879ca662ee4250ec65da11b40 (diff)
downloadfreebsd-ports-gnome-b0fe847bde1bfaa48780345978154ad12c0e0ae4.tar.gz
freebsd-ports-gnome-b0fe847bde1bfaa48780345978154ad12c0e0ae4.tar.zst
freebsd-ports-gnome-b0fe847bde1bfaa48780345978154ad12c0e0ae4.zip
archivers/py3-libarchive-c: Add Python 3.x version of port
Add a Python 3.x sub-port of py-libarchive-c, in order for a port of the Debian diffoscope project to be created, which is Python 3 only. This (py3-*) hack^W workaround ensures a py3x-* package can be created by default. - Allow USES to be overriden in base port accordingly While I'm here - Enable NO_ARCH Requested by: emaste, bapt (for diffoscope, reproducible builds)
Diffstat (limited to 'archivers')
-rw-r--r--archivers/py-libarchive-c/Makefile4
-rw-r--r--archivers/py3-libarchive-c/Makefile8
2 files changed, 11 insertions, 1 deletions
diff --git a/archivers/py-libarchive-c/Makefile b/archivers/py-libarchive-c/Makefile
index 3d0d977f3958..2d7bab19de6c 100644
--- a/archivers/py-libarchive-c/Makefile
+++ b/archivers/py-libarchive-c/Makefile
@@ -13,13 +13,15 @@ LICENSE= LGPL20+
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=0:${PORTSDIR}/devel/py-pytest
-USES= python
+USES?= python
USE_GITHUB= yes
USE_PYTHON= autoplist distutils
GH_ACCOUNT= Changaco
GH_PROJECT= python-${PORTNAME}
+NO_ARCH= yes
+
do-test:
@cd ${WRKSRC} && ${PYTHON_CMD} -m pytest
diff --git a/archivers/py3-libarchive-c/Makefile b/archivers/py3-libarchive-c/Makefile
new file mode 100644
index 000000000000..12df1c925687
--- /dev/null
+++ b/archivers/py3-libarchive-c/Makefile
@@ -0,0 +1,8 @@
+# Created by: Kubilay Kocak <koobs@FreeBSD.org>
+# $FreeBSD$
+
+MASTERDIR= ${.CURDIR}/../py-libarchive-c
+
+USES= python:3.3+
+
+.include "${MASTERDIR}/Makefile"