aboutsummaryrefslogtreecommitdiffstats
path: root/archivers
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2016-04-17 01:56:03 +0800
committerantoine <antoine@FreeBSD.org>2016-04-17 01:56:03 +0800
commitd90fb3c6c62d5e8fae30ed80869f2964772865ef (patch)
treec597775d82b28df08ba8fc31723a571742dd6c47 /archivers
parent2ee13934ec2714b3e5e97cb82033225c69318b94 (diff)
downloadfreebsd-ports-gnome-d90fb3c6c62d5e8fae30ed80869f2964772865ef.tar.gz
freebsd-ports-gnome-d90fb3c6c62d5e8fae30ed80869f2964772865ef.tar.zst
freebsd-ports-gnome-d90fb3c6c62d5e8fae30ed80869f2964772865ef.zip
- Remove obsolete ${PORTSDIR} from DEPENDS
- Remove inapproriate NO_PACKAGE
Diffstat (limited to 'archivers')
-rw-r--r--archivers/py-borgbackup/Makefile16
1 files changed, 8 insertions, 8 deletions
diff --git a/archivers/py-borgbackup/Makefile b/archivers/py-borgbackup/Makefile
index 486f227454db..e14063443a48 100644
--- a/archivers/py-borgbackup/Makefile
+++ b/archivers/py-borgbackup/Makefile
@@ -13,26 +13,26 @@ COMMENT= Deduplicating backup program
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>=1.7:${PORTSDIR}/devel/py-setuptools_scm
-LIB_DEPENDS= liblz4.so:${PORTSDIR}/archivers/liblz4
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}msgpack-python>=0.4.6:${PORTSDIR}/devel/py-msgpack-python
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>=1.7:devel/py-setuptools_scm
+LIB_DEPENDS= liblz4.so:archivers/liblz4
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}msgpack-python>=0.4.6:devel/py-msgpack-python
OPTIONS_DEFINE= FUSE
FUSE_DESC= Support to mount locally borg backup files
OPTIONS_DEFAULT=
-FUSE_RUN_DEPENDS= ${PYTHONPREFIX_SITELIBDIR}/llfuse.so:${PORTSDIR}/devel/py-llfuse
+FUSE_RUN_DEPENDS= ${PYTHONPREFIX_SITELIBDIR}/llfuse.so:devel/py-llfuse
USES= python:3.4+
USE_PYTHON= autoplist distutils
USE_OPENSSL= yes
-# Leave py3 only ports as manual port builds.
-# See https://lists.freebsd.org/pipermail/freebsd-python/2016-April/010151.html
-NO_PACKAGE= yes
-
.include <bsd.port.pre.mk>
+.if defined(PACKAGE_BUILDING) && ${PYTHON_VER} != ${PYTHON_DEFAULT}
+IGNORE= you have python ${PYTHON_DEFAULT} set as the default, and this needs ${PYTHON_VER}
+.endif
+
# borg requires openssl>=1.0.0
.if ${OSVERSION} < 1000015
WITH_OPENSSL_PORT=yes