aboutsummaryrefslogtreecommitdiffstats
path: root/archivers
diff options
context:
space:
mode:
authorjhale <jhale@FreeBSD.org>2018-08-25 01:22:01 +0800
committerjhale <jhale@FreeBSD.org>2018-08-25 01:22:01 +0800
commit859f805dd52ddf18be9fd8d2b3e270945f86b241 (patch)
tree755180fd4810fbf33aa78186166afc94eafc7a8e /archivers
parentff6fe9727fc72b86994dcb93553626b705f579f9 (diff)
downloadfreebsd-ports-gnome-859f805dd52ddf18be9fd8d2b3e270945f86b241.tar.gz
freebsd-ports-gnome-859f805dd52ddf18be9fd8d2b3e270945f86b241.tar.zst
freebsd-ports-gnome-859f805dd52ddf18be9fd8d2b3e270945f86b241.zip
Update security/cryptopp to 7.0.0
We now install a pkgconfig file which will allow ports to check whether cryptopp was built with assembly instructions enabled or not. There are a few functions that will be undefined if built without assembly and -DCRYPTOPP_DISABLE_ASM needs to be passed to the compiler in that case to avoid build failures. This is not new, but the pkgconf file should make it easier to determine if the flag is needed or not. Fix several ports due to API changes and to use the new pkgconf file to determine cryptopp location and build flags. Special cases below. deskutils/cdcat - Use cryptopp shared library instead of static, detect with pkgconf devel/xeus - Fix dependencies and remove header-only libraries from RUN_DEPENDS - Rework to use the cryptopp pkgconf file - net/cppzmq CMake files were fixed in r477649, remove hacks for that as they were seemingly causing devel/xeus-cling to link to cryptopp unnecessarily - Remove C++17 code from cryptopp checks for compatibility devel/xeus-cling - Fix dependencies - Remove hacks for previously broken cppzmq CMake files and no longer needed cryptopp dependency Changes: https://www.cryptopp.com/#news PR: 230579 (original patch, not used) Submitted by: yuri
Diffstat (limited to 'archivers')
-rw-r--r--archivers/urbackup-client/Makefile17
-rw-r--r--archivers/urbackup-server/Makefile25
2 files changed, 35 insertions, 7 deletions
diff --git a/archivers/urbackup-client/Makefile b/archivers/urbackup-client/Makefile
index 3a6729ea33a6..b2ec73ad14f8 100644
--- a/archivers/urbackup-client/Makefile
+++ b/archivers/urbackup-client/Makefile
@@ -2,6 +2,7 @@
PORTNAME= urbackup-client
DISTVERSION= 2.2.6
+PORTREVISION= 1
CATEGORIES= archivers
MASTER_SITES= https://hndl.urbackup.org/Client/${DISTVERSION}/
@@ -13,7 +14,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libcryptopp.so:security/cryptopp
-USES= gettext dos2unix localbase
+USES= dos2unix gettext localbase pkgconfig
USE_RC_SUBR= urbackup_client
USERS= urbackup
@@ -21,6 +22,7 @@ GROUPS= urbackup
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-clientupdate
+CXXFLAGS+= `pkgconf --cflags-only-other libcryptopp`
SUB_FILES= pkg-message urbackupclient.conf.sample-daemon
@@ -48,6 +50,19 @@ XPMFILES= backup-bad.xpm \
backup-no-server.xpm \
backup-progress-pause.xpm
+post-patch:
+ @(cd ${WRKSRC} && ${REINPLACE_CMD} -E -e 's|[[:<:]]byte[[:>:]]|CryptoPP::byte|g' \
+ cryptoplugin/AESDecryption.cpp \
+ cryptoplugin/AESEncryption.cpp \
+ cryptoplugin/AESGCMDecryption.cpp \
+ cryptoplugin/AESGCMEncryption.cpp \
+ cryptoplugin/CryptoFactory.cpp \
+ cryptoplugin/ECDHKeyExchange.cpp \
+ cryptoplugin/ZlibCompression.cpp \
+ cryptoplugin/ZlibDecompression.cpp \
+ md5.h \
+ )
+
do-install:
${MKDIR} ${STAGEDIR}${PREFIX}/share/urbackup/scripts
${MKDIR} ${STAGEDIR}${PREFIX}/etc/urbackup
diff --git a/archivers/urbackup-server/Makefile b/archivers/urbackup-server/Makefile
index a06afa262ae9..ff2661daf59c 100644
--- a/archivers/urbackup-server/Makefile
+++ b/archivers/urbackup-server/Makefile
@@ -2,7 +2,7 @@
PORTNAME= urbackup-server
DISTVERSION= 2.2.11
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= archivers
MASTER_SITES= https://hndl.urbackup.org/Server/${DISTVERSION}/
@@ -13,20 +13,33 @@ LICENSE= AGPLv3
LICENSE_FILE= ${WRKSRC}/server-license.txt
LIB_DEPENDS= libcryptopp.so:security/cryptopp \
- libcurl.so:ftp/curl
+ libcurl.so:ftp/curl
-USES+= fakeroot
+USES= fakeroot pkgconfig
+USE_RC_SUBR= urbackup_server
USERS= urbackup
GROUPS= urbackup
-GNU_CONFIGURE= YES
+GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-packaging
-
-USE_RC_SUBR= urbackup_server
+CXXFLAGS+= `pkgconf --cflags-only-other libcryptopp`
SUB_FILES= pkg-message urbackupsrv.conf.sample-daemon
+post-patch:
+ @(cd ${WRKSRC} && ${REINPLACE_CMD} -E -e 's|[[:<:]]byte[[:>:]]|CryptoPP::byte|g' \
+ cryptoplugin/AESDecryption.cpp \
+ cryptoplugin/AESEncryption.cpp \
+ cryptoplugin/AESGCMDecryption.cpp \
+ cryptoplugin/AESGCMEncryption.cpp \
+ cryptoplugin/CryptoFactory.cpp \
+ cryptoplugin/ECDHKeyExchange.cpp \
+ cryptoplugin/ZlibCompression.cpp \
+ cryptoplugin/ZlibDecompression.cpp \
+ md5.h \
+ )
+
post-install:
${MKDIR} ${STAGEDIR}${PREFIX}/etc/urbackup
${INSTALL_DATA} ${WRKDIR}/urbackupsrv.conf.sample-daemon \