aboutsummaryrefslogtreecommitdiffstats
path: root/archivers
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2010-03-10 05:49:57 +0800
committerdanfe <danfe@FreeBSD.org>2010-03-10 05:49:57 +0800
commitae55d9654a82acd0eebbfb2b4d4bda3fedd1dc85 (patch)
tree00d5b2c681b5668fe5e55e16d21bf4e2182870e9 /archivers
parent9b411fbe9e1dde8f42dfd2f348a4d166ecdc5ab1 (diff)
downloadfreebsd-ports-gnome-ae55d9654a82acd0eebbfb2b4d4bda3fedd1dc85.tar.gz
freebsd-ports-gnome-ae55d9654a82acd0eebbfb2b4d4bda3fedd1dc85.tar.zst
freebsd-ports-gnome-ae55d9654a82acd0eebbfb2b4d4bda3fedd1dc85.zip
Make this port actually usable on arches were sizeof(long) != 4.
Reported by: alepulver Tested on: amd64, ia64
Diffstat (limited to 'archivers')
-rw-r--r--archivers/nwreckdum/Makefile2
-rw-r--r--archivers/nwreckdum/files/patch-nwreckdu.c7
2 files changed, 7 insertions, 2 deletions
diff --git a/archivers/nwreckdum/Makefile b/archivers/nwreckdum/Makefile
index 36b06525cd72..d7c599e7cc78 100644
--- a/archivers/nwreckdum/Makefile
+++ b/archivers/nwreckdum/Makefile
@@ -7,7 +7,7 @@
PORTNAME= nwreckdum
PORTVERSION= 0.0.6
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= archivers games
MASTER_SITES= http://freebsd.nsu.ru/distfiles/
diff --git a/archivers/nwreckdum/files/patch-nwreckdu.c b/archivers/nwreckdum/files/patch-nwreckdu.c
index 81ac5d59c2b6..4b301f2c88e4 100644
--- a/archivers/nwreckdum/files/patch-nwreckdu.c
+++ b/archivers/nwreckdum/files/patch-nwreckdu.c
@@ -1,6 +1,11 @@
--- nwreckdu.c.orig Mon Jun 8 17:47:02 1998
+++ nwreckdu.c Fri Nov 3 02:30:05 2006
-@@ -27,7 +27,7 @@
+@@ -23,11 +23,11 @@
+
+ typedef struct {
+ char name[56];
+- unsigned long offset, length;
++ uint32_t offset, length;
} dirrec;
int asmpak(FILE *);