aboutsummaryrefslogtreecommitdiffstats
path: root/archivers
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-01-31 18:07:37 +0800
committerpav <pav@FreeBSD.org>2005-01-31 18:07:37 +0800
commitb3d6f00f3068b1c86f572e24c64713d12ee33f06 (patch)
treee13c6f213b6063ef169252f711ccbcd2b6be0d50 /archivers
parentf045423e0bc0182d90250a1707ebbe385468bb28 (diff)
downloadfreebsd-ports-gnome-b3d6f00f3068b1c86f572e24c64713d12ee33f06.tar.gz
freebsd-ports-gnome-b3d6f00f3068b1c86f572e24c64713d12ee33f06.tar.zst
freebsd-ports-gnome-b3d6f00f3068b1c86f572e24c64713d12ee33f06.zip
- Update to 0.1.5.9-cvs-2004.02.07 tarball provided by Debian
This is needed for games/wesnoth, as it have no chance to build with last official zipios++ release (which is 4 years old). Requested by: mezz Nodded to by: edwin (games/enigma maintainer)
Diffstat (limited to 'archivers')
-rw-r--r--archivers/zipios++/Makefile23
-rw-r--r--archivers/zipios++/distinfo4
-rw-r--r--archivers/zipios++/files/patch-deflateoutputstreambuf.cpp10
-rw-r--r--archivers/zipios++/files/patch-directory.h97
-rw-r--r--archivers/zipios++/files/patch-fileentry.h13
-rw-r--r--archivers/zipios++/files/patch-simplesmartptr.h37
-rw-r--r--archivers/zipios++/files/patch-test_simplesmartptr.cpp13
-rw-r--r--archivers/zipios++/files/patch-ziphead.cpp10
-rw-r--r--archivers/zipios++/files/patch-zipios_common.h11
-rw-r--r--archivers/zipios++/pkg-descr4
-rw-r--r--archivers/zipios++/pkg-plist6
11 files changed, 30 insertions, 198 deletions
diff --git a/archivers/zipios++/Makefile b/archivers/zipios++/Makefile
index 8dae13322ed8..c7b6df5ebc50 100644
--- a/archivers/zipios++/Makefile
+++ b/archivers/zipios++/Makefile
@@ -7,14 +7,31 @@
#
PORTNAME= zipios++
-PORTVERSION= 0.1.5
+PORTVERSION= 0.1.5.9
CATEGORIES= archivers
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= zipios
+MASTER_SITES= http://http.us.debian.org/debian/pool/main/z/zipios++/
+DISTNAME= ${PORTNAME}_${PORTVERSION}+cvs.2004.02.07.orig
MAINTAINER= ports@FreeBSD.org
COMMENT= A java.util.zip-like C++ library for reading and writing Zip files
GNU_CONFIGURE= yes
+INSTALLS_SHLIB= yes
+# port don't strictly need it, but Wesnoth use it so must we
+USE_GCC= 3.4
+USE_REINPLACE= yes
+WANT_AUTOMAKE_VER=19
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}+cvs.2004.02.07
+
+# tests need CppUnit
+post-patch:
+ @${REINPLACE_CMD} -e 's| tests||' ${WRKSRC}/Makefile.in
+
+pre-configure:
+.for i in install-sh missing depcomp mkinstalldirs
+ @${RM} ${WRKSRC}/${i}
+ @${CP} ${AUTOMAKE_DIR}/${i} ${WRKSRC}
+.endfor
.include <bsd.port.mk>
diff --git a/archivers/zipios++/distinfo b/archivers/zipios++/distinfo
index a3c7b4630da4..d07923b82406 100644
--- a/archivers/zipios++/distinfo
+++ b/archivers/zipios++/distinfo
@@ -1,2 +1,2 @@
-MD5 (zipios++-0.1.5.tar.gz) = da66383f6dd70b4766252fec3ff3d7bb
-SIZE (zipios++-0.1.5.tar.gz) = 152224
+MD5 (zipios++_0.1.5.9+cvs.2004.02.07.orig.tar.gz) = b58a4161bd6e816b240f7b5209a2b191
+SIZE (zipios++_0.1.5.9+cvs.2004.02.07.orig.tar.gz) = 612363
diff --git a/archivers/zipios++/files/patch-deflateoutputstreambuf.cpp b/archivers/zipios++/files/patch-deflateoutputstreambuf.cpp
deleted file mode 100644
index 9a69f119e550..000000000000
--- a/archivers/zipios++/files/patch-deflateoutputstreambuf.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/deflateoutputstreambuf.cpp.orig Fri Aug 25 15:03:42 2000
-+++ src/deflateoutputstreambuf.cpp Sat Sep 7 10:46:20 2002
-@@ -7,6 +7,7 @@
-
- #include "zipios++/fcollexceptions.h"
- #include "zipios++/deflateoutputstreambuf.h"
-+#include "outputstringstream.h"
-
- namespace zipios {
-
diff --git a/archivers/zipios++/files/patch-directory.h b/archivers/zipios++/files/patch-directory.h
deleted file mode 100644
index c423873baa10..000000000000
--- a/archivers/zipios++/files/patch-directory.h
+++ /dev/null
@@ -1,97 +0,0 @@
---- src/directory.h.orig Fri Aug 4 09:26:00 2000
-+++ src/directory.h Sat Sep 7 10:46:20 2002
-@@ -89,7 +89,7 @@
-
- class proxy
- {
-- friend dir_it;
-+ friend class dir_it;
- proxy(std::string const &ent): entry(ent) {}
- public:
- std::string operator*() const { return entry; }
-@@ -296,31 +296,33 @@
-
- class unknown_uid: public std::invalid_argument
- {
-- public:
-- unknown_uid(uid_t u): std::invalid_argument("unknown user ID"), m_uid(u) {}
-- uid_t uid() const { return m_uid; }
- private:
- uid_t m_uid;
-+ public:
-+ unknown_uid(uid_t u) throw() : std::invalid_argument("unknown user ID"), m_uid(u) {}
-+ ~unknown_uid() throw() {}
-+ uid_t uid() const { return m_uid; }
- };
- struct uid { typedef uid_t value_type; };
- template<> uid_t get<uid>(dir_it const &);
- template<> void set<uid>(dir_it const &, uid_t);
-- class unknown_uname: public invalid_argument
-+ class unknown_uname: public std::invalid_argument
- {
-- public:
-- unknown_uname(string u): std::invalid_argument("unknown user name"), m_uname(u) {}
-- string uname() const { return m_uname; }
- private:
-- string m_uname;
-+ std::string m_uname;
-+ public:
-+ unknown_uname(std::string u) throw() : std::invalid_argument("unknown user name"), m_uname(u) {}
-+ ~unknown_uname() throw () {}
-+ std::string uname() const { return m_uname; }
- };
-- struct uname { typedef string value_type; };
-- template<> string get<uname>(dir_it const &);
-- template<> void set<uname>(dir_it const &, string );
-+ struct uname { typedef std::string value_type; };
-+ template<> std::string get<uname>(dir_it const &);
-+ template<> void set<uname>(dir_it const &, std::string );
-
-- class unknown_gid: public invalid_argument
-+ class unknown_gid: public std::invalid_argument
- {
- public:
-- unknown_gid(gid_t g): std::invalid_argument("unknown group ID"), m_gid(g) {}
-+ unknown_gid(gid_t g) throw() : std::invalid_argument("unknown group ID"), m_gid(g) {}
- gid_t gid() const { return m_gid; }
- private:
- gid_t m_gid;
-@@ -328,17 +330,18 @@
- struct gid { typedef gid_t value_type; };
- template<> gid_t get<gid>(dir_it const &);
- template<> void set<gid>(dir_it const &, gid_t);
-- class unknown_gname: public invalid_argument
-+ class unknown_gname: public std::invalid_argument
- {
- public:
-- unknown_gname(string g): std::invalid_argument("unknown group name"), m_gname(g) {}
-- string gname() const { return m_gname; }
-+ unknown_gname(std::string g) throw() : std::invalid_argument("unknown group name"), m_gname(g) {}
-+ ~unknown_gname() throw() {}
-+ std::string gname() const { return m_gname; }
- private:
-- string m_gname;
-+ std::string m_gname;
- };
-- struct gname { typedef string value_type; };
-- template<> string get<gname>(dir_it const &);
-- template<> void set<gname>(dir_it const &, string );
-+ struct gname { typedef std::string value_type; };
-+ template<> std::string get<gname>(dir_it const &);
-+ template<> void set<gname>(dir_it const &, std::string );
-
- #endif
-
-@@ -352,9 +355,9 @@
- {
- public:
- typedef ptrdiff_t difference_type;
-- typedef string value_type;
-- typedef string *pointer;
-- typedef string &reference;
-+ typedef std::string value_type;
-+ typedef std::string *pointer;
-+ typedef std::string &reference;
- typedef input_iterator_tag iterator_category;
- };
- } // namespace std
diff --git a/archivers/zipios++/files/patch-fileentry.h b/archivers/zipios++/files/patch-fileentry.h
deleted file mode 100644
index 2e0f3ad367e6..000000000000
--- a/archivers/zipios++/files/patch-fileentry.h
+++ /dev/null
@@ -1,13 +0,0 @@
---- zipios++/fileentry.h.orig Wed Aug 23 14:30:30 2000
-+++ zipios++/fileentry.h Sat Sep 7 10:46:20 2002
-@@ -166,8 +166,8 @@
- class MatchName ;
- class MatchFileName ;
- protected:
-- friend SimpleSmartPointer< FileEntry > ;
-- friend SimpleSmartPointer< const FileEntry > ;
-+ friend class SimpleSmartPointer< FileEntry > ;
-+ friend class SimpleSmartPointer< const FileEntry > ;
- void ref() const { _refcount.ref() ; }
- unsigned int unref() const { return _refcount.unref() ; }
-
diff --git a/archivers/zipios++/files/patch-simplesmartptr.h b/archivers/zipios++/files/patch-simplesmartptr.h
deleted file mode 100644
index fd50e16159cc..000000000000
--- a/archivers/zipios++/files/patch-simplesmartptr.h
+++ /dev/null
@@ -1,37 +0,0 @@
---- zipios++/simplesmartptr.h.orig Sun Jul 15 15:42:34 2001
-+++ zipios++/simplesmartptr.h Sat Sep 7 10:46:20 2002
-@@ -99,13 +99,14 @@
- class ReferenceCount {
- /** SimpleSmartPointer needs to be a friend to invoke the private
- ref() and unref() methods. */
-- friend SimpleSmartPointer< Type > ;
-- friend SimpleSmartPointer< const Type > ;
-+ friend class SimpleSmartPointer< Type > ;
-+ friend class SimpleSmartPointer< const Type > ;
- /** Type also needs to be a friend to invoke the private ref() and
- unref() methods, in case Type doesn't want to inherit
- ReferenceCount and thus needs to invoke ref() and unref()
- through forwarding member functions. */
-- friend Type ;
-+ /* Note: template parameters cannot be friends */
-+ //friend Type ;
- public:
- /** Constructor intializes count to zero. */
- ReferenceCount() : _ref_count( 0 ) {}
-@@ -117,7 +118,6 @@
- /** The assignment operator doesn't copy the reference count, it
- leaves it unchanged. */
- const ReferenceCount &operator= ( const ReferenceCount &src ) {}
--private:
-
- /** Increases the reference count. */
- void ref() const { ++_ref_count ; }
-@@ -127,6 +127,8 @@
-
- /** Returns the reference count - For debugging purposes. */
- unsigned int getReferenceCount() const { return _ref_count; }
-+
-+private:
-
- /** Holds the actual reference count */
- mutable unsigned short _ref_count ;
diff --git a/archivers/zipios++/files/patch-test_simplesmartptr.cpp b/archivers/zipios++/files/patch-test_simplesmartptr.cpp
deleted file mode 100644
index 65d4c43dbf9f..000000000000
--- a/archivers/zipios++/files/patch-test_simplesmartptr.cpp
+++ /dev/null
@@ -1,13 +0,0 @@
---- tests/test_simplesmartptr.cpp.orig Sun Jul 15 15:51:14 2001
-+++ tests/test_simplesmartptr.cpp Sat Sep 7 10:46:20 2002
-@@ -26,8 +26,8 @@
- Bogus(bool &isAlive) : _isAlive(isAlive) {}
- ~Bogus() { _isAlive = false; }
- protected:
-- friend SimpleSmartPointer< Bogus > ;
-- friend SimpleSmartPointer< const Bogus > ;
-+ friend class SimpleSmartPointer< Bogus > ;
-+ friend class SimpleSmartPointer< const Bogus > ;
-
- void ref() const { _refcount.ref() ; }
- unsigned int unref() const { return _refcount.unref() ; }
diff --git a/archivers/zipios++/files/patch-ziphead.cpp b/archivers/zipios++/files/patch-ziphead.cpp
deleted file mode 100644
index 325666c3547b..000000000000
--- a/archivers/zipios++/files/patch-ziphead.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/ziphead.cpp.orig Thu Jul 17 20:38:24 2003
-+++ src/ziphead.cpp Thu Jul 17 20:38:33 2003
-@@ -2,6 +2,7 @@
- #include "zipios++/zipios-config.h"
-
- #include "zipios++/meta-iostreams.h"
-+#include <assert.h>
- #include <iterator>
- #include <string>
-
diff --git a/archivers/zipios++/files/patch-zipios_common.h b/archivers/zipios++/files/patch-zipios_common.h
deleted file mode 100644
index d099ed1c2400..000000000000
--- a/archivers/zipios++/files/patch-zipios_common.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/zipios_common.h.orig Fri Aug 4 09:26:00 2000
-+++ src/zipios_common.h Sat Sep 7 10:46:20 2002
-@@ -13,7 +13,7 @@
-
- template< class Type >
- void operator += ( vector< Type > &v1, const vector< Type > &v2 ) {
-- std::vector<Type>::const_iterator cit ;
-+ typename std::vector<Type>::const_iterator cit ;
- for ( cit = v2.begin() ; cit != v2.end() ; cit++ )
- v1.push_back( *cit ) ;
- }
diff --git a/archivers/zipios++/pkg-descr b/archivers/zipios++/pkg-descr
index ab222ef5f0a7..b65e5f94ad10 100644
--- a/archivers/zipios++/pkg-descr
+++ b/archivers/zipios++/pkg-descr
@@ -1,6 +1,8 @@
Zipios++ is a java.util.zip-like C++ library for reading and writing Zip
files. Access to individual entries is provided through standard C++
iostreams. A simple read-only virtual file system that mounts regular
-directories and zip files is also provided.
+directories and zip files is also provided.
+
+This port use Debian tarball of CVS version, as last release is from 2001.
WWW: http://zipios.sourceforge.net/
diff --git a/archivers/zipios++/pkg-plist b/archivers/zipios++/pkg-plist
index e9e297dff403..63bdc1ba60c0 100644
--- a/archivers/zipios++/pkg-plist
+++ b/archivers/zipios++/pkg-plist
@@ -8,6 +8,8 @@ include/zipios++/fileentry.h
include/zipios++/filepath.h
include/zipios++/filterinputstreambuf.h
include/zipios++/filteroutputstreambuf.h
+include/zipios++/gzipoutputstream.h
+include/zipios++/gzipoutputstreambuf.h
include/zipios++/inflateinputstreambuf.h
include/zipios++/meta-iostreams.h
include/zipios++/simplesmartptr.h
@@ -17,9 +19,11 @@ include/zipios++/ziphead.h
include/zipios++/zipheadio.h
include/zipios++/zipinputstream.h
include/zipios++/zipinputstreambuf.h
-include/zipios++/zipios-config.h
include/zipios++/zipios_defs.h
include/zipios++/zipoutputstream.h
include/zipios++/zipoutputstreambuf.h
@dirrm include/zipios++
lib/libzipios.a
+lib/libzipios.la
+lib/libzipios.so
+lib/libzipios.so.0