aboutsummaryrefslogtreecommitdiffstats
path: root/astro/aa/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2006-08-13 05:40:18 +0800
committerpav <pav@FreeBSD.org>2006-08-13 05:40:18 +0800
commit00bec19998af3ae202596bfbb8762960bd77648f (patch)
treeba275b605083238a73b314f0fd7c26f17df2a804 /astro/aa/Makefile
parent0fb4e0be9cb278c482b3b6ee45526ad6e608d24b (diff)
downloadfreebsd-ports-gnome-00bec19998af3ae202596bfbb8762960bd77648f.tar.gz
freebsd-ports-gnome-00bec19998af3ae202596bfbb8762960bd77648f.tar.zst
freebsd-ports-gnome-00bec19998af3ae202596bfbb8762960bd77648f.zip
This program computes ephemerides of Sun, Moon, planets, comets, and stars
using rigorous reduction methods from the _Astronomical Almanac_ and related sources. Includes PLAN404 series for positions of the planets, and a long-term extension of modern Lunar theory for the Moon's position. Reads ASCII file catalogues of stars and orbital elements. Displays all adjustments as it finds local azimuth and elevation, rise and set times, etc. Latest update 2005-11-09. WWW: http://moshier.net/aadoc.html PR: ports/101850 Submitted by: Frank W. Josellis <frank@dynamical-systems.org>
Diffstat (limited to 'astro/aa/Makefile')
-rw-r--r--astro/aa/Makefile47
1 files changed, 47 insertions, 0 deletions
diff --git a/astro/aa/Makefile b/astro/aa/Makefile
new file mode 100644
index 000000000000..fe352e5f34ee
--- /dev/null
+++ b/astro/aa/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: aa
+# Date created: 11 August 2006
+# Whom: Frank W. Josellis <frank@dynamical-systems.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= aa
+PORTVERSION= 56
+CATEGORIES= astro
+MASTER_SITES= http://moshier.net/ \
+ http://www.mirrorservice.org/sites/www.moshier.net/
+
+MAINTAINER= frank@dynamical-systems.org
+COMMENT= Self-contained ephemeris calculator
+
+EXTRACT_AFTER_ARGS= -d ${WRKSRC}
+EXTRACT_BEFORE_ARGS= -aqo
+
+USE_ZIP= yes
+MAKEFILE= makefile
+ALL_TARGET= aa
+
+SUB_FILES= pkg-message
+
+PORTDOCS= read.me readme.404 Readme.FreeBSD
+PLIST_FILES= bin/aa etc/aa.ini.default
+
+post-patch:
+ @${REINPLACE_CMD} 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/kfiles.c
+ @${REINPLACE_CMD} 's|CFLAGS= -O2|CFLAGS+=|' ${WRKSRC}/makefile
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/aa ${TARGETDIR}/bin
+ @${INSTALL_DATA} ${WRKSRC}/aa.ini ${TARGETDIR}/etc/aa.ini.default
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${CAT} ${PKGMESSAGE} > ${WRKSRC}/Readme.FreeBSD
+ @${MKDIR} ${DOCSDIR}
+.for i in ${PORTDOCS}
+ @${INSTALL_MAN} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.endif
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>