aboutsummaryrefslogtreecommitdiffstats
path: root/astro/astrometry
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2015-01-25 22:06:46 +0800
committerdanfe <danfe@FreeBSD.org>2015-01-25 22:06:46 +0800
commitfcf00df3eb97968e151db4597cde1716c2003872 (patch)
treeebbb232ba2d6b1b136df3797bc0429fe7d2b3c55 /astro/astrometry
parent11370096ef803f0ed3e00d30046206e329a5dd45 (diff)
downloadfreebsd-ports-gnome-fcf00df3eb97968e151db4597cde1716c2003872.tar.gz
freebsd-ports-gnome-fcf00df3eb97968e151db4597cde1716c2003872.tar.zst
freebsd-ports-gnome-fcf00df3eb97968e151db4597cde1716c2003872.zip
- Define LICENSE (GPLv2), specify path in USE_LDCONFIG as needed
- Transfer maintainership to the submitter and bump port revision - Wrap overly long lines and beautify them while I'm here again PR: 197038
Diffstat (limited to 'astro/astrometry')
-rw-r--r--astro/astrometry/Makefile15
1 files changed, 9 insertions, 6 deletions
diff --git a/astro/astrometry/Makefile b/astro/astrometry/Makefile
index bc497184bcd5..288484c46eb6 100644
--- a/astro/astrometry/Makefile
+++ b/astro/astrometry/Makefile
@@ -3,13 +3,16 @@
PORTNAME= astrometry
PORTVERSION= 0.50
+PORTREVISION= 1
CATEGORIES= astro
MASTER_SITES= http://www.astrometry.net/downloads/
DISTNAME= ${PORTNAME}.net-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= antont@inbox.lv
COMMENT= Software for describing astronomical images
+LICENSE= GPLv2
+
BUILD_DEPENDS= ${PYNUMPY}
LIB_DEPENDS= libcairo.so:${PORTSDIR}/graphics/cairo \
libcfitsio.so:${PORTSDIR}/astro/cfitsio \
@@ -19,7 +22,7 @@ LIB_DEPENDS= libcairo.so:${PORTSDIR}/graphics/cairo \
RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= gmake pkgconfig python tar:bzip2
-USE_LDCONFIG= yes
+USE_LDCONFIG= ${PREFIX}/${PORTNAME}/lib
ALL_TARGET= all extra
MAKE_ENV= INSTALL_DIR=${STAGEDIR}${PREFIX}/${PORTNAME}
MAKE_JOBS_UNSAFE= yes
@@ -36,9 +39,9 @@ post-patch:
post-install:
@${REINPLACE_CMD} -i '' -e 's|${STAGEDIR}||' \
${STAGEDIR}${PREFIX}/${PORTNAME}/etc/${PORTNAME}.cfg
- @${FIND} ${STAGEDIR}${PREFIX}/${PORTNAME}/bin -type f -not -name "*.py" \
- -exec ${STRIP_CMD} {} \;
- @${FIND} ${STAGEDIR}${PREFIX}/${PORTNAME}/lib -type f -name "*.so" \
- -exec ${STRIP_CMD} {} \;
+ @${FIND} ${STAGEDIR}${PREFIX}/${PORTNAME}/bin \
+ -type f -not -name "*.py" -exec ${STRIP_CMD} {} \;
+ @${FIND} ${STAGEDIR}${PREFIX}/${PORTNAME}/lib \
+ -type f -name "*.so" -exec ${STRIP_CMD} {} \;
.include <bsd.port.mk>