aboutsummaryrefslogtreecommitdiffstats
path: root/astro/celestia
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2018-10-28 19:16:35 +0800
committerlinimon <linimon@FreeBSD.org>2018-10-28 19:16:35 +0800
commit14a9f807b4a12d457ad7fd059f8a0ebd4171c38e (patch)
tree4ba0c35d8f4171eb7be7fe79dab3ae02a6886149 /astro/celestia
parent4a527d79dc3761ae4430e08fde0e40d095ee2b66 (diff)
downloadfreebsd-ports-gnome-14a9f807b4a12d457ad7fd059f8a0ebd4171c38e.tar.gz
freebsd-ports-gnome-14a9f807b4a12d457ad7fd059f8a0ebd4171c38e.tar.zst
freebsd-ports-gnome-14a9f807b4a12d457ad7fd059f8a0ebd4171c38e.zip
Fix build with GCC-based architectures.
PR: 232015 Submitted by: Piotr Kubaj Approved by: portmgr (tier-2 blanket)
Diffstat (limited to 'astro/celestia')
-rw-r--r--astro/celestia/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/astro/celestia/Makefile b/astro/celestia/Makefile
index 776bfb9c8e84..ecc07ec4c628 100644
--- a/astro/celestia/Makefile
+++ b/astro/celestia/Makefile
@@ -15,7 +15,7 @@ LICENSE= GPLv2
LIB_DEPENDS= libpng.so:graphics/png
-USES= gettext gmake jpeg libtool lua pkgconfig
+USES= compiler:c++11-lang gettext gl gmake jpeg libtool lua pkgconfig
USE_GL= gl
GNU_CONFIGURE= yes
EXTRA_PATCHES= ${FILESDIR}/celestia-1.6.1-lua-5.2.patch:-p1 \
@@ -48,6 +48,7 @@ USE_GL+= glut
LDFLAGS+= -lGL
.elif ${CELESTIA_UI} == "gtk"
CONFIGURE_ARGS+= --with-gtk
+USES+= gnome
USE_GNOME+= gtk20
PLIST_FILES= share/applications/celestia.desktop
.elif ${CELESTIA_UI} == "gnome"