aboutsummaryrefslogtreecommitdiffstats
path: root/astro/gkrellmearth/Makefile
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2001-07-03 07:23:12 +0800
committerlioux <lioux@FreeBSD.org>2001-07-03 07:23:12 +0800
commitbe1c21bde0a5d17e145f2069cc24768797d42b1b (patch)
tree2a9e2fe25485eda0e4cc2552f28a30a8d83bdab7 /astro/gkrellmearth/Makefile
parent137f590f8a5fef3aa9b3873cbf28bf33b9f81c75 (diff)
downloadfreebsd-ports-gnome-be1c21bde0a5d17e145f2069cc24768797d42b1b.tar.gz
freebsd-ports-gnome-be1c21bde0a5d17e145f2069cc24768797d42b1b.tar.zst
freebsd-ports-gnome-be1c21bde0a5d17e145f2069cc24768797d42b1b.zip
o New port for a GKrellM plugin that display a rotating earth
o Port version 0.3 Submitted by: Patrick Li <pat@databits.net>
Diffstat (limited to 'astro/gkrellmearth/Makefile')
-rw-r--r--astro/gkrellmearth/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/astro/gkrellmearth/Makefile b/astro/gkrellmearth/Makefile
new file mode 100644
index 000000000000..2a1996455b38
--- /dev/null
+++ b/astro/gkrellmearth/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: gkrellm-earth
+# Date Created: Thu Jun 28 01:54:57 EDT 2001
+# Whom: Patrick Li <pat@databits.net>
+# With help from: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= earth
+PORTVERSION= 0.3
+CATEGORIES= astro
+MASTER_SITES= http://www.geocities.com/saintdead/
+PKGNAMEPREFIX= gkrellm
+DISTNAME= ${PORTNAME}_anim-${PORTVERSION}
+
+MAINTAINER= pat@databits.net
+
+BUILD_DEPENDS= ${X11BASE}/include/gkrellm/gkrellm.h:${PORTSDIR}/sysutils/gkrellm
+RUN_DEPENDS= gkrellm:${PORTSDIR}/sysutils/gkrellm
+
+WRKSRC= ${WRKDIR}/${PORTNAME}_anim
+USE_X_PREFIX= yes
+USE_IMLIB= yes
+MAKE_ENV= PTHREAD_LIBS="${PTHREAD_LIBS}" \
+ PTHREAD_CFLAGS="${PTHREAD_CFLAGS}"
+ALL_TARGET= ${PORTNAME}_anim.so
+
+.include <bsd.port.mk>