aboutsummaryrefslogtreecommitdiffstats
path: root/astro/gpstk/Makefile
diff options
context:
space:
mode:
authorbms <bms@FreeBSD.org>2007-01-11 04:02:08 +0800
committerbms <bms@FreeBSD.org>2007-01-11 04:02:08 +0800
commit02c6803cf56276e5cdc8e5b63741f00bf7ec7987 (patch)
tree34b888648ed695634028f6d36c22f410bc21aefe /astro/gpstk/Makefile
parentbd71b3576930439676df945fb23b0ade79741caa (diff)
downloadfreebsd-ports-gnome-02c6803cf56276e5cdc8e5b63741f00bf7ec7987.tar.gz
freebsd-ports-gnome-02c6803cf56276e5cdc8e5b63741f00bf7ec7987.tar.zst
freebsd-ports-gnome-02c6803cf56276e5cdc8e5b63741f00bf7ec7987.zip
Mark as requiring gcc 3.4.x; 4.x is not supported by gpstk.
Pass CC and CXX into Jam environment as appropriate.
Diffstat (limited to 'astro/gpstk/Makefile')
-rw-r--r--astro/gpstk/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/astro/gpstk/Makefile b/astro/gpstk/Makefile
index 0f037164a89d..6f90f0c21c6d 100644
--- a/astro/gpstk/Makefile
+++ b/astro/gpstk/Makefile
@@ -17,14 +17,15 @@ COMMENT= Toolkit for developing GPS applications
BUILD_DEPENDS= ${LOCALBASE}/bin/jam:${PORTSDIR}/devel/jam
-USE_GCC= 3.4+
+USE_GCC= 3.4
USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
JAM= ${LOCALBASE}/bin/jam
JAM_ENV= BINDIR=${PREFIX}/bin \
INCDIR=${PREFIX}/include/$(PORTNAME) \
- LIBDIR=${PREFIX}/lib
+ LIBDIR=${PREFIX}/lib \
+ CC=${CC} C++=${CXX}
do-build:
cd ${WRKSRC} && ${SETENV} ${JAM_ENV} ${JAM}