aboutsummaryrefslogtreecommitdiffstats
path: root/astro/gpstk/Makefile
diff options
context:
space:
mode:
authorbms <bms@FreeBSD.org>2006-11-02 21:13:17 +0800
committerbms <bms@FreeBSD.org>2006-11-02 21:13:17 +0800
commit15496dcf6bde03fc81386e7245efd69adc2d0d0d (patch)
treeb21e26e7f2f0064ea90fe4ed3ce0d3dc2667ec72 /astro/gpstk/Makefile
parentb92c2164d5efe20d08eb2a1602b27343b3c99c32 (diff)
downloadfreebsd-ports-gnome-15496dcf6bde03fc81386e7245efd69adc2d0d0d.tar.gz
freebsd-ports-gnome-15496dcf6bde03fc81386e7245efd69adc2d0d0d.tar.zst
freebsd-ports-gnome-15496dcf6bde03fc81386e7245efd69adc2d0d0d.zip
Add new port gpstk, the ARL GPS Toolkit; a software library for working
with raw GPS data, NMEA feeds, ephemerii, etc. Requested by: Tom McHugh
Diffstat (limited to 'astro/gpstk/Makefile')
-rw-r--r--astro/gpstk/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/astro/gpstk/Makefile b/astro/gpstk/Makefile
new file mode 100644
index 000000000000..6b6d9c5f71c9
--- /dev/null
+++ b/astro/gpstk/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: gpstk
+# Date created: 12 May 2004
+# Whom: bms@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= gpstk
+PORTVERSION= 1.1
+CATEGORIES= astro devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= bms@FreeBSD.org
+COMMENT= Toolkit for developing GPS applications
+
+BUILD_DEPENDS= ${LOCALBASE}/bin/jam:${PORTSDIR}/devel/jam
+
+USE_LDCONFIG= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+JAM= ${LOCALBASE}/bin/jam
+JAM_ENV= BINDIR=${PREFIX}/bin \
+ INCDIR=${PREFIX}/include \
+ LIBDIR=${PREFIX}/lib
+
+do-build:
+ cd ${WRKSRC} && ${SETENV} ${JAM_ENV} ${JAM}
+
+do-install:
+ cd ${WRKSRC} && ${SETENV} ${JAM_ENV} ${JAM} install
+
+.include <bsd.port.mk>