aboutsummaryrefslogtreecommitdiffstats
path: root/astro/gpstk
diff options
context:
space:
mode:
authorbms <bms@FreeBSD.org>2007-01-02 12:33:32 +0800
committerbms <bms@FreeBSD.org>2007-01-02 12:33:32 +0800
commitdd9302e0ba534e358694385dfa3e9636cd3e9abd (patch)
tree64555a5ce562ef12abdb0057d9cfa42c67a470b0 /astro/gpstk
parent09af5b974421c05a646fa1f9e86f6a9c5a605ec1 (diff)
downloadfreebsd-ports-gnome-dd9302e0ba534e358694385dfa3e9636cd3e9abd.tar.gz
freebsd-ports-gnome-dd9302e0ba534e358694385dfa3e9636cd3e9abd.tar.zst
freebsd-ports-gnome-dd9302e0ba534e358694385dfa3e9636cd3e9abd.zip
Fix install target.
Diffstat (limited to 'astro/gpstk')
-rw-r--r--astro/gpstk/Makefile7
-rw-r--r--astro/gpstk/files/patch-Jamrules2
2 files changed, 4 insertions, 5 deletions
diff --git a/astro/gpstk/Makefile b/astro/gpstk/Makefile
index c7905fff8111..0f037164a89d 100644
--- a/astro/gpstk/Makefile
+++ b/astro/gpstk/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gpstk
PORTVERSION= 1.1
+PORTREVISION= 1
CATEGORIES= astro devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -16,22 +17,20 @@ COMMENT= Toolkit for developing GPS applications
BUILD_DEPENDS= ${LOCALBASE}/bin/jam:${PORTSDIR}/devel/jam
-BROKEN= Does not build
-
USE_GCC= 3.4+
USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
JAM= ${LOCALBASE}/bin/jam
JAM_ENV= BINDIR=${PREFIX}/bin \
- INCDIR=${PREFIX}/include \
+ INCDIR=${PREFIX}/include/$(PORTNAME) \
LIBDIR=${PREFIX}/lib
do-build:
cd ${WRKSRC} && ${SETENV} ${JAM_ENV} ${JAM}
do-install:
- ${MKDIR} ${PREFIX}/include/gpstk
+ ${MKDIR} ${PREFIX}/include/${PORTNAME}
cd ${WRKSRC} && ${SETENV} ${JAM_ENV} ${JAM} install
.include <bsd.port.mk>
diff --git a/astro/gpstk/files/patch-Jamrules b/astro/gpstk/files/patch-Jamrules
index b2af4fae9dee..e16d70802906 100644
--- a/astro/gpstk/files/patch-Jamrules
+++ b/astro/gpstk/files/patch-Jamrules
@@ -25,7 +25,7 @@
BINDIR = [ FDirName $(PREFIX) bin ] ;
LIBDIR = [ FDirName $(PREFIX) lib ] ;
- INCDIR = [ FDirName $(PREFIX) include ] ;
-+ INCDIR = [ FDirName $(PREFIX) include/gpstk ] ;
++ INCDIR = [ FDirName $(PREFIX) include gpstk ] ;
}
# debug - edit this as needed.