aboutsummaryrefslogtreecommitdiffstats
path: root/astro/orsa
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2007-06-16 05:03:03 +0800
committerdanfe <danfe@FreeBSD.org>2007-06-16 05:03:03 +0800
commit6a173f14b98bb9eb4bbd912deaf7ced91129072c (patch)
tree2e97d03994240b56459aec98eb2a2aff79f6632e /astro/orsa
parentbafeda72767a331b8b66a8b9fd87a8cbef0da444 (diff)
downloadfreebsd-ports-gnome-6a173f14b98bb9eb4bbd912deaf7ced91129072c.tar.gz
freebsd-ports-gnome-6a173f14b98bb9eb4bbd912deaf7ced91129072c.tar.zst
freebsd-ports-gnome-6a173f14b98bb9eb4bbd912deaf7ced91129072c.zip
Fix the build with recent GCC. [1]
Reported by: pointyhat (logs)
Diffstat (limited to 'astro/orsa')
-rw-r--r--astro/orsa/Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/astro/orsa/Makefile b/astro/orsa/Makefile
index 1c1cc7d14d0b..04d4dcaf760d 100644
--- a/astro/orsa/Makefile
+++ b/astro/orsa/Makefile
@@ -29,4 +29,17 @@ GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_LDCONFIG= yes
+post-patch:
+ @${REINPLACE_CMD} -e 's,Body::,,' \
+ ${WRKSRC}/src/liborsa/orsa_body.h
+ @${REINPLACE_CMD} -E 's,[[:alnum:]]+::(compare\(),\1,' \
+ ${WRKSRC}/src/libxorsa/xorsa_analysis.h \
+ ${WRKSRC}/src/libxorsa/xorsa_import_astorb_objects.h \
+ ${WRKSRC}/src/libxorsa/xorsa_object_selector.cc \
+ ${WRKSRC}/src/orsa/xorsa.h
+ @${REINPLACE_CMD} -e 's,^extern,& "C",' \
+ ${WRKSRC}/src/libxorsa/xorsa_plot_area.h
+ @${REINPLACE_CMD} -e '/nprintf/s,std::,,' \
+ ${WRKSRC}/src/libxorsa/xorsa_wrapper.cc
+
.include <bsd.port.mk>