aboutsummaryrefslogtreecommitdiffstats
path: root/astro/p5-Astro-Hipparcos/Makefile
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2017-10-10 19:20:38 +0800
committersunpoet <sunpoet@FreeBSD.org>2017-10-10 19:20:38 +0800
commit6ce66fcd5e085615f07af7b1a4c33d4d5460c035 (patch)
tree0012c0c7088fb26b57a482e3df8f7d365f49a367 /astro/p5-Astro-Hipparcos/Makefile
parent5bdce5840d2cb0452b5ebbc34c8e6418a4a70c7c (diff)
downloadfreebsd-ports-gnome-6ce66fcd5e085615f07af7b1a4c33d4d5460c035.tar.gz
freebsd-ports-gnome-6ce66fcd5e085615f07af7b1a4c33d4d5460c035.tar.zst
freebsd-ports-gnome-6ce66fcd5e085615f07af7b1a4c33d4d5460c035.zip
Add LICENSE
- Use = instead of += for MAKE_ARGS - Strip shared library - Bump PORTREVISION for package change - Sort PLIST
Diffstat (limited to 'astro/p5-Astro-Hipparcos/Makefile')
-rw-r--r--astro/p5-Astro-Hipparcos/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/astro/p5-Astro-Hipparcos/Makefile b/astro/p5-Astro-Hipparcos/Makefile
index 09c528aa8cb8..fc3409927e30 100644
--- a/astro/p5-Astro-Hipparcos/Makefile
+++ b/astro/p5-Astro-Hipparcos/Makefile
@@ -3,7 +3,7 @@
PORTNAME= Astro-Hipparcos
PORTVERSION= 0.09
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= astro perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -11,10 +11,16 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Perl extension for reading the Hipparcos star catalog
+LICENSE= ART10 GPLv1+
+LICENSE_COMB= dual
+
BUILD_DEPENDS= p5-ExtUtils-XSpp>=0.06:devel/p5-ExtUtils-XSpp
-MAKE_ARGS+= CC="${CXX}"
+MAKE_ARGS= CC="${CXX}"
USES= perl5
USE_PERL5= configure
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Astro/Hipparcos/Hipparcos.so
+
.include <bsd.port.mk>