aboutsummaryrefslogtreecommitdiffstats
path: root/astro/p5-Astro-WaveBand
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2012-07-10 14:57:31 +0800
committersunpoet <sunpoet@FreeBSD.org>2012-07-10 14:57:31 +0800
commitc3c9ace5e1b18e5f9c4326adaafaa44f25aa036f (patch)
treef5e47e2c790bbcd30a56dbab3df3cc34d7b7ee51 /astro/p5-Astro-WaveBand
parentc32d541cc5ac62d8de5158fe6e83385bbccb3dc9 (diff)
downloadfreebsd-ports-gnome-c3c9ace5e1b18e5f9c4326adaafaa44f25aa036f.tar.gz
freebsd-ports-gnome-c3c9ace5e1b18e5f9c4326adaafaa44f25aa036f.tar.zst
freebsd-ports-gnome-c3c9ace5e1b18e5f9c4326adaafaa44f25aa036f.zip
- Add p5-Astro-WaveBand 0.08
Class to transparently deal with the conversion between filters, wavelength, frequency and other methods of specifying a location in the electro-magentic spectrum. Astro::WaveBand tries to determine the natural form of the numbers such that a request for a summary of the object when it contains 2.2 microns would return the filter name but would return the wavelength if it was not a standard filter. In ambiguous cases an instrument name is required to decide what to return. In really ambiguous cases the user can specify the unit in which to display the numbers on stringification. Used mainly as a way of storing a single number in a database table but using logic to determine the number that an observer is most likely to understand. Numerical comparison operators can be used to compare two Astro::WaveBand objects. When checking equality, the "natural" and "instrument" methods are used, so if two Astro::WaveBand objects return the same value from those methods, they are considered to be equal. When checking other comparisons such as greater than, the wavelength is used. WWW: http://search.cpan.org/dist/Astro-WaveBand/
Diffstat (limited to 'astro/p5-Astro-WaveBand')
-rw-r--r--astro/p5-Astro-WaveBand/Makefile24
-rw-r--r--astro/p5-Astro-WaveBand/distinfo2
-rw-r--r--astro/p5-Astro-WaveBand/pkg-descr21
-rw-r--r--astro/p5-Astro-WaveBand/pkg-plist2
4 files changed, 49 insertions, 0 deletions
diff --git a/astro/p5-Astro-WaveBand/Makefile b/astro/p5-Astro-WaveBand/Makefile
new file mode 100644
index 000000000000..319132400025
--- /dev/null
+++ b/astro/p5-Astro-WaveBand/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: p5-Astro-WaveBand
+# Date created: 2012-07-01
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Astro-WaveBand
+PORTVERSION= 0.08
+CATEGORIES= astro perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Transparently work in waveband, wavelength or filter
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+PERL_MODBUILD= yes
+
+MAN3= Astro::WaveBand.3
+
+.include <bsd.port.mk>
diff --git a/astro/p5-Astro-WaveBand/distinfo b/astro/p5-Astro-WaveBand/distinfo
new file mode 100644
index 000000000000..e8a64b639006
--- /dev/null
+++ b/astro/p5-Astro-WaveBand/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Astro-WaveBand-0.08.tar.gz) = 782d5d258bf3b3a5de5279583898a3eb9da5be906a7cc4af8f55377391169532
+SIZE (Astro-WaveBand-0.08.tar.gz) = 14618
diff --git a/astro/p5-Astro-WaveBand/pkg-descr b/astro/p5-Astro-WaveBand/pkg-descr
new file mode 100644
index 000000000000..8548cadbf15e
--- /dev/null
+++ b/astro/p5-Astro-WaveBand/pkg-descr
@@ -0,0 +1,21 @@
+Class to transparently deal with the conversion between filters, wavelength,
+frequency and other methods of specifying a location in the electro-magentic
+spectrum.
+
+Astro::WaveBand tries to determine the natural form of the numbers such that a
+request for a summary of the object when it contains 2.2 microns would return
+the filter name but would return the wavelength if it was not a standard filter.
+In ambiguous cases an instrument name is required to decide what to return. In
+really ambiguous cases the user can specify the unit in which to display the
+numbers on stringification.
+
+Used mainly as a way of storing a single number in a database table but using
+logic to determine the number that an observer is most likely to understand.
+
+Numerical comparison operators can be used to compare two Astro::WaveBand
+objects. When checking equality, the "natural" and "instrument" methods are
+used, so if two Astro::WaveBand objects return the same value from those
+methods, they are considered to be equal. When checking other comparisons such
+as greater than, the wavelength is used.
+
+WWW: http://search.cpan.org/dist/Astro-WaveBand/
diff --git a/astro/p5-Astro-WaveBand/pkg-plist b/astro/p5-Astro-WaveBand/pkg-plist
new file mode 100644
index 000000000000..2fcecc88c305
--- /dev/null
+++ b/astro/p5-Astro-WaveBand/pkg-plist
@@ -0,0 +1,2 @@
+%%SITE_PERL%%/Astro/WaveBand.pm
+@dirrmtry %%SITE_PERL%%/Astro