aboutsummaryrefslogtreecommitdiffstats
path: root/astro/p5-GPS/Makefile
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2000-12-06 13:43:03 +0800
committerwill <will@FreeBSD.org>2000-12-06 13:43:03 +0800
commit7b34590ab5c52efce32b000fa2a5701f737443f8 (patch)
treee02911b4f18e24b1f9bdfdc1029be8340ded044c /astro/p5-GPS/Makefile
parentcf524efdcca7c54404d6bc0ffa684f20a1322009 (diff)
downloadfreebsd-ports-gnome-7b34590ab5c52efce32b000fa2a5701f737443f8.tar.gz
freebsd-ports-gnome-7b34590ab5c52efce32b000fa2a5701f737443f8.tar.zst
freebsd-ports-gnome-7b34590ab5c52efce32b000fa2a5701f737443f8.zip
Add p5-GPS 0.12, a perl module that gives access to several GPS protocols
such as Garmin, NMEA, and Magellan. PR: 23317 Submitted by: Jeremy Shaffner <jeremy@external.org>
Diffstat (limited to 'astro/p5-GPS/Makefile')
-rw-r--r--astro/p5-GPS/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/astro/p5-GPS/Makefile b/astro/p5-GPS/Makefile
new file mode 100644
index 000000000000..4cb912d39dbc
--- /dev/null
+++ b/astro/p5-GPS/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-GPS
+# Date created: 5 December 2000
+# Whom: Jeremy Shaffner <jeremy@external.org>
+#
+# $FreeBSD$
+
+PORTNAME= GPS
+PORTVERSION= 0.12
+CATEGORIES= astro perl5
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= perl-gps
+PKGNAMEPREFIX= p5-
+DISTNAME= perl-GPS-${PORTVERSION}
+
+MAINTAINER= jeremy@external.org
+
+USE_PERL5= YES
+
+MAN3= GPS::Garmin.3 \
+ GPS::Serial.3 \
+ GPS::Garmin::Handler.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+do-configure:
+ @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL
+
+.include <bsd.port.mk>