aboutsummaryrefslogtreecommitdiffstats
path: root/astro/phoon
diff options
context:
space:
mode:
authorvs <vs@FreeBSD.org>2005-10-14 16:11:57 +0800
committervs <vs@FreeBSD.org>2005-10-14 16:11:57 +0800
commit05181b854060a744fc50ecba448990916360be1f (patch)
treee2752e64fc8daa33b532ceb94e337c187bdb82af /astro/phoon
parentee85d37e065571e3b559d89b50870c281d6eea29 (diff)
downloadfreebsd-ports-gnome-05181b854060a744fc50ecba448990916360be1f.tar.gz
freebsd-ports-gnome-05181b854060a744fc50ecba448990916360be1f.tar.zst
freebsd-ports-gnome-05181b854060a744fc50ecba448990916360be1f.zip
Use MAKE_ARGS
Approved by: maintainers
Diffstat (limited to 'astro/phoon')
-rw-r--r--astro/phoon/Makefile4
-rw-r--r--astro/phoon/files/patch-Makefile33
2 files changed, 4 insertions, 33 deletions
diff --git a/astro/phoon/Makefile b/astro/phoon/Makefile
index 111aa212bec8..602835c2a264 100644
--- a/astro/phoon/Makefile
+++ b/astro/phoon/Makefile
@@ -17,6 +17,10 @@ COMMENT= Displays the phase of the moon
WRKSRC= ${WRKDIR}/${PORTNAME}
USE_REINPLACE= yes
+MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}" \
+ BINDIR=${LOCALBASE}/bin \
+ MANDIR=${MANPREFIX}/man/man1
+
MAN1= phoon.1
PLIST_FILES= bin/phoon
diff --git a/astro/phoon/files/patch-Makefile b/astro/phoon/files/patch-Makefile
deleted file mode 100644
index 93a0a4c417d7..000000000000
--- a/astro/phoon/files/patch-Makefile
+++ /dev/null
@@ -1,33 +0,0 @@
---- Makefile.orig Thu May 15 09:07:10 2003
-+++ Makefile Thu May 15 09:08:24 2003
-@@ -1,13 +1,13 @@
- # Makefile for phoon
-
--BINDIR = /usr/local/bin
--MANDIR = /usr/local/man/man1
-+BINDIR = ${PREFIX}/bin
-+MANDIR = ${MANPREFIX}/man/man1
-
- DEFINES = -DOS_BSD
- #DEFINES = -DOS_SYSV
-
--CC = gcc
--CFLAGS = -O $(DEFINES)
-+CC ?= gcc
-+CFLAGS ?= ${CFLAGS}
-
- LDFLAGS = -s
-
-@@ -15,10 +15,10 @@
- all: phoon
-
- phoon: phoon.o date_parse.o astro.o
-- $(CC) $(LDFLAGS) -o phoon phoon.o date_parse.o astro.o -lm
-+ ${CC} $(LDFLAGS) -o phoon phoon.o date_parse.o astro.o -lm
-
- .c.o:
-- $(CC) $(CFLAGS) -c $<
-+ ${CC} $(CFLAGS) -c $<
-
- date_parse.o: date_parse.h
- astro.o: astro.h