aboutsummaryrefslogtreecommitdiffstats
path: root/astro/planets
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2014-05-08 02:19:04 +0800
committermarino <marino@FreeBSD.org>2014-05-08 02:19:04 +0800
commit7d55e635aae800b7aabc76164d96449a53cbf858 (patch)
tree1a962ff9ed4f992255667ba64f4073916d0641a2 /astro/planets
parente6c6aaf2e7dc66e263616fb134504b7a18685454 (diff)
downloadfreebsd-ports-gnome-7d55e635aae800b7aabc76164d96449a53cbf858.tar.gz
freebsd-ports-gnome-7d55e635aae800b7aabc76164d96449a53cbf858.tar.zst
freebsd-ports-gnome-7d55e635aae800b7aabc76164d96449a53cbf858.zip
astro/planets: Unbreak after Ocaml 4.01 with Debian patch
While using one of Debian's patches to fix this build, remove the hardcoded depends and replace with USE_OCAML instead. Also convert to USES+=tar while we are here.
Diffstat (limited to 'astro/planets')
-rw-r--r--astro/planets/Makefile7
-rw-r--r--astro/planets/files/patch-options.ml106
2 files changed, 109 insertions, 4 deletions
diff --git a/astro/planets/Makefile b/astro/planets/Makefile
index 88dfa9ffdd49..5dc7582666bb 100644
--- a/astro/planets/Makefile
+++ b/astro/planets/Makefile
@@ -3,19 +3,18 @@
PORTNAME= planets
PORTVERSION= 0.1.13
+PORTREVISION= 1
CATEGORIES= astro
MASTER_SITES= GENTOO/distfiles \
http://planets.homedns.org/dist/
-EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= Orbital simulator
LICENSE= GPLv2
-BUILD_DEPENDS= ocaml:${PORTSDIR}/lang/ocaml
-
-USES= gmake
+USES= gmake tar:tgz
+USE_OCAML= yes
USE_XORG= x11
ALL_TARGET= ${PORTNAME}
diff --git a/astro/planets/files/patch-options.ml b/astro/planets/files/patch-options.ml
new file mode 100644
index 000000000000..51cdf4657bb1
--- /dev/null
+++ b/astro/planets/files/patch-options.ml
@@ -0,0 +1,106 @@
+--- options.ml
++++ options.ml
+@@ -93,7 +93,7 @@ end
+ (*********************************************************************)
+ (* 'a is the data type, 'b is the widget type *)
+
+-class virtual ['a,'b] option ?name ~text ~set:(set:'a->unit) ~get () =
++class virtual ['a,'b,'c] option ?name ~text ~set:(set:'a->unit) ~get () =
+ let name = (match name with
+ None -> random_name 10
+ | Some name -> name ) in
+@@ -104,7 +104,7 @@ object (self)
+ val name = name
+ val text = (text : string)
+
+- method virtual build_widget : live:bool -> 'b
++ method virtual build_widget : live:bool -> 'b
+ method display ~live parent =
+ ignore (self#build_widget ~live parent);
+ match widget with
+@@ -126,9 +126,9 @@ end
+
+ (*********************)
+
+-class ['b] toggle_option ?name ~text ~set ~get () =
++class ['b,'c] toggle_option ?name ~text ~set ~get () =
+ object (self)
+- inherit [bool,'b] option ?name ~text ~set ~get ()
++ inherit [bool,'b,'c] option ?name ~text ~set ~get ()
+
+ method set_tk bool =
+ Textvariable.set tk_var (if bool then "true" else "false")
+@@ -153,9 +153,9 @@ end
+
+ (*********************)
+
+-class ['b] int_scale_option ?name ~min ~max ~text ~set ~get () =
++class ['b,'c] int_scale_option ?name ~min ~max ~text ~set ~get () =
+ object (self)
+- inherit [int,'b] option ?name ~text ~set ~get ()
++ inherit [int,'b,'c] option ?name ~text ~set ~get ()
+ val min = min
+ val max = max
+
+@@ -192,10 +192,10 @@ end
+
+ (*******************************************************)
+
+-class ['b] float_scale_option ?name ~min ~max ?(resolution=1.0)
++class ['b, 'c] float_scale_option ?name ~min ~max ?(resolution=1.0)
+ ~text ~set ~get () =
+ object (self)
+- inherit [float, 'b] option ?name ~text ~set ~get ()
++ inherit [float, 'b, 'c] option ?name ~text ~set ~get ()
+ val min = min
+ val max = max
+
+@@ -236,10 +236,10 @@ let string_of_float x =
+ then string ^ "0"
+ else string
+
+-class ['b] float_entry_option ?name ?(mult=1.1)
++class ['b, 'c] float_entry_option ?name ?(mult=1.1)
+ ~text ~set ~get () =
+ object (self)
+- inherit [float, 'b] option ?name ~text ~set ~get ()
++ inherit [float, 'b, 'c] option ?name ~text ~set ~get ()
+
+ val mutable entry = None
+
+@@ -303,9 +303,9 @@ end
+
+ (*******************************************************)
+
+-class ['b] float_entry_display ?name ~text ~set ~get () =
++class ['b, 'c] float_entry_display ?name ~text ~set ~get () =
+ object (self)
+- inherit [float, 'b] option ?name ~text ~set ~get ()
++ inherit [float, 'b, 'c] option ?name ~text ~set ~get ()
+
+ val mutable display = None
+
+@@ -337,9 +337,9 @@ end
+
+ (*******************************************************)
+
+-class ['b] int_entry_display ?name ~text ~set ~get () =
++class ['b, 'c] int_entry_display ?name ~text ~set ~get () =
+ object (self)
+- inherit [int, 'b] option ?name ~text ~set ~get ()
++ inherit [int, 'b, 'c] option ?name ~text ~set ~get ()
+
+ val mutable display = None
+
+@@ -371,9 +371,9 @@ end
+
+ (*******************************************************)
+
+-class ['b] void_entry_display ?name ~text () =
++class ['b, 'c] void_entry_display ?name ~text () =
+ object (self)
+- inherit [unit, 'b] option ?name ~text
++ inherit [unit, 'b, 'c] option ?name ~text
+ ~set:(fun x -> ()) ~get:(fun () -> ())
+ ()
+