aboutsummaryrefslogtreecommitdiffstats
path: root/astro/py-astLib
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2017-11-30 23:50:30 +0800
committermat <mat@FreeBSD.org>2017-11-30 23:50:30 +0800
commit32512cab3e8dd90b7cd0525bb5dc98007db431e2 (patch)
treed296c82a71504382f4faefa0bf8d7be384ea1105 /astro/py-astLib
parentb4ddc365e88ebdb48627086b02365b74119cf189 (diff)
downloadfreebsd-ports-gnome-32512cab3e8dd90b7cd0525bb5dc98007db431e2.tar.gz
freebsd-ports-gnome-32512cab3e8dd90b7cd0525bb5dc98007db431e2.tar.zst
freebsd-ports-gnome-32512cab3e8dd90b7cd0525bb5dc98007db431e2.zip
Convert Python ports to FLAVORS.
Ports using USE_PYTHON=distutils are now flavored. They will automatically get flavors (py27, py34, py35, py36) depending on what versions they support. There is also a USE_PYTHON=flavors for ports that do not use distutils but need FLAVORS to be set. A USE_PYTHON=noflavors can be set if using distutils but flavors are not wanted. A new USE_PYTHON=optsuffix that will add PYTHON_PKGNAMESUFFIX has been added to cope with Python ports that did not have the Python PKGNAMEPREFIX but are flavored. USES=python now also exports a PY_FLAVOR variable that contains the current python flavor. It can be used in dependency lines when the port itself is not python flavored. For example, deskutils/calibre. By default, all the flavors are generated. To only generate flavors for the versions in PYTHON2_DEFAULT and PYTHON3_DEFAULT, define BUILD_DEFAULT_PYTHON_FLAVORS in your make.conf. In all the ports with Python dependencies, the *_DEPENDS entries MUST end with the flavor so that the framework knows which to build/use. This is done by appending '@${PY_FLAVOR}' after the origin (or @${FLAVOR} if in a Python module with Python flavors, as the content will be the same). For example: RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR} PR: 223071 Reviewed by: portmgr, python Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D12464
Diffstat (limited to 'astro/py-astLib')
-rw-r--r--astro/py-astLib/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/astro/py-astLib/Makefile b/astro/py-astLib/Makefile
index ff33bdd0602b..beaaed8dd727 100644
--- a/astro/py-astLib/Makefile
+++ b/astro/py-astLib/Makefile
@@ -14,15 +14,15 @@ LICENSE= LGPL21
LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${PYNUMPY} \
- ${PKGNAMEPREFIX}scipy>=0.7.0:science/py-scipy \
- ${PKGNAMEPREFIX}pillow>0:graphics/py-pillow \
- ${PKGNAMEPREFIX}pyfits>=1.1:astro/py-pyfits \
- ${PKGNAMEPREFIX}matplotlib>=0.98:math/py-matplotlib
+ ${PKGNAMEPREFIX}scipy>=0.7.0:science/py-scipy@${FLAVOR} \
+ ${PKGNAMEPREFIX}pillow>0:graphics/py-pillow@${FLAVOR} \
+ ${PKGNAMEPREFIX}pyfits>=1.1:astro/py-pyfits@${FLAVOR} \
+ ${PKGNAMEPREFIX}matplotlib>=0.98:math/py-matplotlib@${FLAVOR}
RUN_DEPENDS:= ${BUILD_DEPENDS}
PORTSCOUT= skipv:0.15,0.17,0.17.1 # incorrect versioning upstream
-USES= python
+USES= python:2.7
USE_PYTHON= autoplist distutils
post-install: