aboutsummaryrefslogtreecommitdiffstats
path: root/astro/readosm
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2015-02-24 22:04:55 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2015-02-24 22:04:55 +0800
commit97126d055616558fc253d1061aa57e38337a49da (patch)
tree56bda605b380bf8adfb2eed5260f742cc7b420e4 /astro/readosm
parentd6e5c5b7945993853342ad1374625dbc5703007d (diff)
downloadfreebsd-ports-gnome-97126d055616558fc253d1061aa57e38337a49da.tar.gz
freebsd-ports-gnome-97126d055616558fc253d1061aa57e38337a49da.tar.zst
freebsd-ports-gnome-97126d055616558fc253d1061aa57e38337a49da.zip
ReadOSM is an open source library to extract valid data from within an Open
Street Map input file. Such OSM files come in two different formats: * files identified by the .osm suffix simply are plain XML files. * files identified by the .osm.pbf suffix does containt the same identical data, but adopting the Google's Protocol Buffer serialization format and thus requiring much less storage space. WWW: https://www.gaia-gis.it/fossil/readosm/index PR: 197262 Submitted by: coder@tuxfamily.org
Diffstat (limited to 'astro/readosm')
-rw-r--r--astro/readosm/Makefile26
-rw-r--r--astro/readosm/distinfo2
-rw-r--r--astro/readosm/pkg-descr10
-rw-r--r--astro/readosm/pkg-plist6
4 files changed, 44 insertions, 0 deletions
diff --git a/astro/readosm/Makefile b/astro/readosm/Makefile
new file mode 100644
index 000000000000..52e72eb633f0
--- /dev/null
+++ b/astro/readosm/Makefile
@@ -0,0 +1,26 @@
+# Created by: Loïc BARTOLETTI <coder@tuxfamily.org>
+# $FreeBSD$
+
+PORTNAME= readosm
+PORTVERSION= 1.0.0
+CATEGORIES= astro geography devel
+MASTER_SITES= http://www.gaia-gis.it/gaia-sins/
+DISTNAME= ${PORTNAME}-${PORTVERSION}d
+
+MAINTAINER= coder@tuxfamily.org
+COMMENT= Extract valid data from within an Open Street Map input file
+
+LICENSE= MPL LGPL21 GPLv2
+LICENSE_COMB= dual
+
+LIB_DEPENDS= libexpat.so:${PORTSDIR}/textproc/expat2
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}d
+GNU_CONFIGURE= yes
+USES= gmake libtool pkgconfig pathfix
+
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib ${ICONV_LIB}
+USE_LDCONFIG= yes
+
+.include <bsd.port.mk>
diff --git a/astro/readosm/distinfo b/astro/readosm/distinfo
new file mode 100644
index 000000000000..3e5f0209ca8a
--- /dev/null
+++ b/astro/readosm/distinfo
@@ -0,0 +1,2 @@
+SHA256 (readosm-1.0.0d.tar.gz) = f056d26489610699802a2a44e315750383af303cf7dcdc580c52bb5ed4d136e3
+SIZE (readosm-1.0.0d.tar.gz) = 1095751
diff --git a/astro/readosm/pkg-descr b/astro/readosm/pkg-descr
new file mode 100644
index 000000000000..6623d2ca2d6f
--- /dev/null
+++ b/astro/readosm/pkg-descr
@@ -0,0 +1,10 @@
+ReadOSM is an open source library to extract valid data from within an Open
+Street Map input file. Such OSM files come in two different formats:
+
+* files identified by the .osm suffix simply are plain XML files.
+* files identified by the .osm.pbf suffix does containt the same identical
+data, but adopting the Google's Protocol Buffer serialization format and thus
+requiring much less storage space.
+
+
+WWW: https://www.gaia-gis.it/fossil/readosm/index
diff --git a/astro/readosm/pkg-plist b/astro/readosm/pkg-plist
new file mode 100644
index 000000000000..14ef5754bb4d
--- /dev/null
+++ b/astro/readosm/pkg-plist
@@ -0,0 +1,6 @@
+include/readosm.h
+lib/libreadosm.a
+lib/libreadosm.so
+lib/libreadosm.so.1
+lib/libreadosm.so.1.0.0
+libdata/pkgconfig/readosm.pc