aboutsummaryrefslogtreecommitdiffstats
path: root/astro/rmap/Makefile
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2000-07-02 15:22:55 +0800
committerwill <will@FreeBSD.org>2000-07-02 15:22:55 +0800
commit89a3e5ac219f726db6a086ad7fe8e9b97b22c891 (patch)
tree2c3f4f5db4234a114ad95dbb5442d0d0fe501ffa /astro/rmap/Makefile
parentd8de32095dcf6ef34fdc2783ec822ed7ca192fe3 (diff)
downloadfreebsd-ports-gnome-89a3e5ac219f726db6a086ad7fe8e9b97b22c891.tar.gz
freebsd-ports-gnome-89a3e5ac219f726db6a086ad7fe8e9b97b22c891.tar.zst
freebsd-ports-gnome-89a3e5ac219f726db6a086ad7fe8e9b97b22c891.zip
Add rmap, a neat program that generates an image of the Earth at a specific
location in the world (based on longitude and latitude). PR: 17676 Submitted by: Trevor Johnson <trevor@jpj.net>
Diffstat (limited to 'astro/rmap/Makefile')
-rw-r--r--astro/rmap/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/astro/rmap/Makefile b/astro/rmap/Makefile
new file mode 100644
index 000000000000..e26d236d73b7
--- /dev/null
+++ b/astro/rmap/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: rmap
+# Date created: 29 Mar 2000
+# Whom: trevor@jpj.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= rmap
+PORTVERSION= 1.2
+CATEGORIES= astro
+MASTER_SITES= http://www.reza.net/rmap/
+
+MAINTAINER= trevor@jpj.net
+
+LIB_DEPENDS= gd.1:${PORTSDIR}/graphics/gd \
+ gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+
+MAN1= rmap.1
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I ${LOCALBASE}/include/gd/" \
+ LIBS="-L${LOCALBASE}/lib -lgnugetopt"
+
+.include <bsd.port.mk>