aboutsummaryrefslogtreecommitdiffstats
path: root/astro/roadnav
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-03-24 19:30:42 +0800
committerbapt <bapt@FreeBSD.org>2014-03-24 19:30:42 +0800
commit903c478f1e9dc3383dc3e86e0a227f648956e9ed (patch)
treecf3573181a2b31d346cea8d984e1864c4fb7bf10 /astro/roadnav
parent3825b6ea2b0891201e3cb7df9229c5fa949b7a4e (diff)
downloadfreebsd-ports-gnome-903c478f1e9dc3383dc3e86e0a227f648956e9ed.tar.gz
freebsd-ports-gnome-903c478f1e9dc3383dc3e86e0a227f648956e9ed.tar.zst
freebsd-ports-gnome-903c478f1e9dc3383dc3e86e0a227f648956e9ed.zip
Use wx 2.8 (unicode version)
Fix build with modern c++ compilers [1] Obtained from: Gentoo
Diffstat (limited to 'astro/roadnav')
-rw-r--r--astro/roadnav/Makefile6
-rw-r--r--astro/roadnav/files/patch-src__GPSInterface_Serial.cpp11
-rw-r--r--astro/roadnav/files/patch-src__TTS_Festival.cpp11
3 files changed, 26 insertions, 2 deletions
diff --git a/astro/roadnav/Makefile b/astro/roadnav/Makefile
index 06eff1473278..16cb329f4d8e 100644
--- a/astro/roadnav/Makefile
+++ b/astro/roadnav/Makefile
@@ -3,7 +3,7 @@
PORTNAME= roadnav
PORTVERSION= 0.19
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= astro geography
MASTER_SITES= SF/${PORTNAME}/Roadnav/${PORTVERSION}
@@ -12,9 +12,11 @@ COMMENT= 3D GPS mapping program
BUILD_DEPENDS= ${LOCALBASE}/lib/libroadnav.a:${PORTSDIR}/astro/libroadnav
-USE_WX= 2.6+
+USE_WX= 2.8+
WX_COMPS= wx contrib
+WX_UNICODE= yes
USES= gmake
+CXXFLAGS+= -Wnon-pod-varargs
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-wx-prefix=${LOCALBASE} --with-wx-config=${WX_CONFIG}
diff --git a/astro/roadnav/files/patch-src__GPSInterface_Serial.cpp b/astro/roadnav/files/patch-src__GPSInterface_Serial.cpp
new file mode 100644
index 000000000000..bf1fcdf25cad
--- /dev/null
+++ b/astro/roadnav/files/patch-src__GPSInterface_Serial.cpp
@@ -0,0 +1,11 @@
+--- ./src/GPSInterface_Serial.cpp.orig 2007-10-09 04:02:14.000000000 +0200
++++ ./src/GPSInterface_Serial.cpp 2014-03-24 12:27:07.000000000 +0100
+@@ -243,7 +243,7 @@
+
+ // Echo DeLorme Tripmate's and Earthmate's hello message
+ LibRoadnavDebug1(wxT("SerialIO"), wxT("Echoing hello message: %s"), strSentence.c_str());
+- sprintf(szOut, "%s\r\n", strSentence.mb_str(*wxConvCurrent));
++ sprintf(szOut, "%s\r\n", static_cast<const char *>(strSentence.mb_str(*wxConvCurrent)));
+ WriteSerial(szOut);
+ }
+ else if (!VerifyGPSChecksum(strSentence)) // check NMEA validity
diff --git a/astro/roadnav/files/patch-src__TTS_Festival.cpp b/astro/roadnav/files/patch-src__TTS_Festival.cpp
new file mode 100644
index 000000000000..e838cc21c6f4
--- /dev/null
+++ b/astro/roadnav/files/patch-src__TTS_Festival.cpp
@@ -0,0 +1,11 @@
+--- ./src/TTS_Festival.cpp.orig 2007-10-09 04:02:14.000000000 +0200
++++ ./src/TTS_Festival.cpp 2014-03-24 12:28:17.000000000 +0100
+@@ -88,7 +88,7 @@
+ ppszArgs[2],
+ 64 + strText.Length(),
+ wxT("echo \\(SayText \\\"%ss\\\"\\) | festival"),
+- strText.mb_str(*wxConvCurrent)
++ static_cast<const char *>strText.mb_str(*wxConvCurrent)
+ );
+
+ wxExecute(ppszArgs, wxEXEC_SYNC);