aboutsummaryrefslogtreecommitdiffstats
path: root/astro/seti_applet
diff options
context:
space:
mode:
authorsteve <steve@FreeBSD.org>2000-07-10 11:07:30 +0800
committersteve <steve@FreeBSD.org>2000-07-10 11:07:30 +0800
commit3a5a323f7d2c9730c122e37da256a47657c3903f (patch)
treedb1f6e5d029dcc34687bc819a96026333fccdc2e /astro/seti_applet
parentd2254b6efaaf80271fbac355c39200893cd16dbe (diff)
downloadfreebsd-ports-gnome-3a5a323f7d2c9730c122e37da256a47657c3903f.tar.gz
freebsd-ports-gnome-3a5a323f7d2c9730c122e37da256a47657c3903f.tar.zst
freebsd-ports-gnome-3a5a323f7d2c9730c122e37da256a47657c3903f.zip
Adding seti_appelt version 0.2.2.
An applet that displays the current status of a seti@home client. PR: 19607 Submitted by: HIYAMA Takeshi <th@cis.ibaraki.ac.jp>
Diffstat (limited to 'astro/seti_applet')
-rw-r--r--astro/seti_applet/Makefile31
-rw-r--r--astro/seti_applet/distinfo1
-rw-r--r--astro/seti_applet/files/patch-aa11
-rw-r--r--astro/seti_applet/pkg-comment1
-rw-r--r--astro/seti_applet/pkg-descr4
-rw-r--r--astro/seti_applet/pkg-message14
-rw-r--r--astro/seti_applet/pkg-plist16
7 files changed, 78 insertions, 0 deletions
diff --git a/astro/seti_applet/Makefile b/astro/seti_applet/Makefile
new file mode 100644
index 000000000000..779b53bd3de7
--- /dev/null
+++ b/astro/seti_applet/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: seti_applet
+# Date Created: 1 Jul 2000
+# Whom: HIYAMA Takeshi <th@cis.ibaraki.ac.jp>
+#
+# $FreeBSD$
+#
+
+PORTNAME= seti_applet
+PORTVERSION= 0.2.2
+CATEGORIES= astro gnome
+MASTER_SITES= http://download.sourceforge.net/seti-applet/
+
+MAINTAINER= th@cis.ibaraki.ac.jp
+
+LIB_DEPENDS= panel_applet.4:${PORTSDIR}/x11/gnomecore \
+ gnome.4:${PORTSDIR}/x11/gnomelibs
+RUN_DEPENDS= setiathome:${PORTSDIR}/astro/setiathome
+
+USE_X_PREFIX= yes
+GLIB_CONFIG?= ${LOCALBASE}/bin/glib12-config
+GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
+
+GNU_CONFIGURE= yes
+
+CONFIGURE_ENV= GLIB_CONFIG="${GLIB_CONFIG}" \
+ GTK_CONFIG="${GTK_CONFIG}"
+
+post-install:
+ ${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/astro/seti_applet/distinfo b/astro/seti_applet/distinfo
new file mode 100644
index 000000000000..a4f6b366581c
--- /dev/null
+++ b/astro/seti_applet/distinfo
@@ -0,0 +1 @@
+MD5 (seti_applet-0.2.2.tar.gz) = abb117d1737556eaa00b5eb1f7eda1da
diff --git a/astro/seti_applet/files/patch-aa b/astro/seti_applet/files/patch-aa
new file mode 100644
index 000000000000..765bec012659
--- /dev/null
+++ b/astro/seti_applet/files/patch-aa
@@ -0,0 +1,11 @@
+--- src/seti_applet.c.orig Fri Jun 30 20:00:34 2000
++++ src/seti_applet.c Fri Jun 30 20:00:45 2000
+@@ -705,7 +705,7 @@
+ g_free ( sa.setidir );
+ }
+ gnome_config_push_prefix ( path );
+- sa.setidir = gnome_config_get_string ( "setiapplet/setidir=/usr/local/seti" );
++ sa.setidir = gnome_config_get_string ( "setiapplet/setidir=/var/db/setiathome" );
+ sa.updateinterval = gnome_config_get_int ( "setiapplet/updateinterval=10" );
+ sa.fileupdateinterval = gnome_config_get_int ( "setiapplet/fileupdateinterval=120" );
+ sa.showcpu = gnome_config_get_int ( "setiapplet/showcpu=1" );
diff --git a/astro/seti_applet/pkg-comment b/astro/seti_applet/pkg-comment
new file mode 100644
index 000000000000..efe2613306ec
--- /dev/null
+++ b/astro/seti_applet/pkg-comment
@@ -0,0 +1 @@
+An applet that displays the current status of a seti@home client
diff --git a/astro/seti_applet/pkg-descr b/astro/seti_applet/pkg-descr
new file mode 100644
index 000000000000..821403a7c5ea
--- /dev/null
+++ b/astro/seti_applet/pkg-descr
@@ -0,0 +1,4 @@
+Displays in an applet (in text in this release) the current status of
+any running seti@home client.
+
+WWW: http://seti-applet.sourceforge.net/
diff --git a/astro/seti_applet/pkg-message b/astro/seti_applet/pkg-message
new file mode 100644
index 000000000000..0e67633f694a
--- /dev/null
+++ b/astro/seti_applet/pkg-message
@@ -0,0 +1,14 @@
+ seti@home client must be installed.
+ You can find it in /usr/ports/astro/setiathome
+
+ To enable start/stop seti@home client,
+ please run "setiathome" as your login name.
+ If you installed "setiathome" by ports or package,
+ change the line 9 of /usr/local/etc/rc.d/setiathome.sh
+ seti_user=nobody
+ ^^^^^^
+ to your login name before setting up working directory.
+ If you already done this as nobody, do
+ /usr/local/etc/rc.d/setiathome.sh stop
+ chown -R "YOUR LOGIN NAME" /var/db/setiathome
+
diff --git a/astro/seti_applet/pkg-plist b/astro/seti_applet/pkg-plist
new file mode 100644
index 000000000000..a95a78c43d76
--- /dev/null
+++ b/astro/seti_applet/pkg-plist
@@ -0,0 +1,16 @@
+bin/seti_applet
+etc/CORBA/servers/seti_applet.gnorba
+share/gnome/applets/Monitors/seti_applet.desktop
+share/gnome/help/seti_applet/C/configuration.html
+share/gnome/help/seti_applet/C/docbook.css
+share/gnome/help/seti_applet/C/images/adv_prop.gif
+share/gnome/help/seti_applet/C/images/basic_prop.gif
+share/gnome/help/seti_applet/C/index.html
+share/gnome/help/seti_applet/C/operation.html
+share/gnome/help/seti_applet/C/startingsetiprocess.html
+share/gnome/help/seti_applet/C/topic.dat
+share/gnome/help/seti_applet/C/x42.html
+share/gnome/pixmaps/seti_applet-logo-green.png
+@dirrm share/gnome/help/seti_applet/C/images
+@dirrm share/gnome/help/seti_applet/C
+@dirrm share/gnome/help/seti_applet