aboutsummaryrefslogtreecommitdiffstats
path: root/astro/sunclock
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-04-20 01:56:05 +0800
committermiwi <miwi@FreeBSD.org>2008-04-20 01:56:05 +0800
commitbce9b81f9d6099820f3839d7809d6b08c1d2ae7b (patch)
treef5dd7c3a8dbebad79bdb5e844aeb69c59a9fd12c /astro/sunclock
parent2eea5f1d2e44418020f8f4db08d40bea6915b6e8 (diff)
downloadfreebsd-ports-gnome-bce9b81f9d6099820f3839d7809d6b08c1d2ae7b.tar.gz
freebsd-ports-gnome-bce9b81f9d6099820f3839d7809d6b08c1d2ae7b.tar.zst
freebsd-ports-gnome-bce9b81f9d6099820f3839d7809d6b08c1d2ae7b.zip
- Remove unneeded dependency from gtk12/gtk20 [1]
- Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORG - Remove X11BASE support in favor of LOCALBASE or PREFIX - Use USE_LDCONFIG instead of INSTALLS_SHLIB - Remove unneeded USE_GCC 3.4+ Thanks to all Helpers: Dmitry Marakasov, Chess Griffin, beech@, dinoex, rafan, gahr, ehaupt, nox, itetcu, flz, pav PR: 116263 Tested on: pointyhat Approved by: portmgr (pav)
Diffstat (limited to 'astro/sunclock')
-rw-r--r--astro/sunclock/Makefile6
-rw-r--r--astro/sunclock/files/patch-Imakefile6
-rw-r--r--astro/sunclock/files/patch-editkit_Imakefile2
3 files changed, 7 insertions, 7 deletions
diff --git a/astro/sunclock/Makefile b/astro/sunclock/Makefile
index a964b6c2d69f..81d8d749710c 100644
--- a/astro/sunclock/Makefile
+++ b/astro/sunclock/Makefile
@@ -20,10 +20,10 @@ LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
png.5:${PORTSDIR}/graphics/png
USE_BZIP2= yes
-USE_XPM= yes
+USE_XORG= xpm
USE_IMAKE= yes
-CFLAGS+= -I${LOCALBASE}/include -I${X11BASE}/include
-CPPFLAGS+= -I${LOCALBASE}/include -I${X11BASE}/include
+CFLAGS+= -I${LOCALBASE}/include
+CPPFLAGS+= -I${LOCALBASE}/include
MAN1= sunclock.1
diff --git a/astro/sunclock/files/patch-Imakefile b/astro/sunclock/files/patch-Imakefile
index 894fa1bb12a1..41a15e7fa378 100644
--- a/astro/sunclock/files/patch-Imakefile
+++ b/astro/sunclock/files/patch-Imakefile
@@ -34,12 +34,12 @@
-#JINC=-I/usr/include
-
-CCOPTIONS=-O -DZLIB -DSHAREDIR=\"$(DESTDIR)$(SHAREDIR)\"
-+XPMLIBDIR=-L${X11BASE}/lib
-+XPMINC=-I${X11BASE}/include/X11
++XPMLIBDIR=-L${LOCALBASE}/lib
++XPMINC=-I${LOCALBASE}/include/X11
+JLIBDIR=-L${LOCALBASE}/lib
+ZLIBDIR=-L${LOCALBASE}/lib
+JINC=-I${LOCALBASE}/include
-+CCOPTIONS=-DZLIB -DSHAREDIR=\"$(DESTDIR)$(SHAREDIR)\" -DNEW_CTIME -I${LOCALBASE}/include -I${X11BASE}/include -L${LOCALBASE}/lib -L${X11BASE}/lib
++CCOPTIONS=-DZLIB -DSHAREDIR=\"$(DESTDIR)$(SHAREDIR)\" -DNEW_CTIME -I${LOCALBASE}/include -L${LOCALBASE}/lib
#endif
SRCS=sunclock.c astro.c widgets.c tildepath.c dirlist.c \
diff --git a/astro/sunclock/files/patch-editkit_Imakefile b/astro/sunclock/files/patch-editkit_Imakefile
index 00d1538a8f78..a73976658268 100644
--- a/astro/sunclock/files/patch-editkit_Imakefile
+++ b/astro/sunclock/files/patch-editkit_Imakefile
@@ -5,7 +5,7 @@
XCOMM
-CFLAGS = -O2 -fomit-frame-pointer -pipe -Wall -DTHREED -DGREEK -DJUSTIFY -DSHAREDIR="\"$(SHAREDIR)\""
-+COPTS = -DTHREED -DGREEK -DJUSTIFY -DSHAREDIR="\"$(SHAREDIR)\"" -I${LOCALBASE}/include -I${X11BASE}/include -L${X11BASE}/lib -L${LOCALBASE}/lib
++COPTS = -DTHREED -DGREEK -DJUSTIFY -DSHAREDIR="\"$(SHAREDIR)\"" -I${LOCALBASE}/include -L${LOCALBASE}/lib
+
+CCOPTIONS=${COPTS}