aboutsummaryrefslogtreecommitdiffstats
path: root/astro/viking
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2012-05-21 11:09:59 +0800
committermiwi <miwi@FreeBSD.org>2012-05-21 11:09:59 +0800
commita67aae030412ff4d7d70a289f58d49fc9c9981c8 (patch)
tree5407cf58405913e27db7667c7e60c210dc2fab80 /astro/viking
parenteb4bc15f91a5b23e2b15d2a1c93af934d6575f7b (diff)
downloadfreebsd-ports-gnome-a67aae030412ff4d7d70a289f58d49fc9c9981c8.tar.gz
freebsd-ports-gnome-a67aae030412ff4d7d70a289f58d49fc9c9981c8.tar.zst
freebsd-ports-gnome-a67aae030412ff4d7d70a289f58d49fc9c9981c8.zip
- Update to 1.3
PR: 168020 Submitted by: Ports Fury
Diffstat (limited to 'astro/viking')
-rw-r--r--astro/viking/Makefile36
-rw-r--r--astro/viking/distinfo4
-rw-r--r--astro/viking/files/patch-src-vikgpslayer.c81
-rw-r--r--astro/viking/pkg-plist57
4 files changed, 50 insertions, 128 deletions
diff --git a/astro/viking/Makefile b/astro/viking/Makefile
index 783b81fe9859..3904f597b18c 100644
--- a/astro/viking/Makefile
+++ b/astro/viking/Makefile
@@ -6,45 +6,49 @@
#
PORTNAME= viking
-PORTVERSION= 1.2.2
+PORTVERSION= 1.3
CATEGORIES= astro
MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= Program to manage GPS data (tracks, waypoints, etc)
+LICENSE= GPLv2 # (or later)
+
LIB_DEPENDS= curl.6:${PORTSDIR}/ftp/curl \
expat.6:${PORTSDIR}/textproc/expat2
RUN_DEPENDS= gpsbabel:${PORTSDIR}/astro/gpsbabel
-OPTIONS= GPSD "Enable realtime GPS tracking" off
+OPTIONS= GEOTAG "Enable Geotag support" on \
+ GPSD "Enable realtime GPS tracking" off
-CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CPPFLAGS}
-LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+USE_GNOME= gnomedocutils gtk20
+USE_PERL5_RUN= yes
+USE_GETTEXT= yes
+USE_GMAKE= yes
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
INSTALLS_OMF= yes
-USE_GMAKE= yes
-USE_GNOME= gnomedocutils gtk20 libglade2
-USE_PERL5_RUN= yes
+MAKE_JOBS_SAFE= yes
+
+CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
+LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
.include <bsd.port.options.mk>
-.if defined(WITH_GPSD)
-LIB_DEPENDS+= gps.20:${PORTSDIR}/astro/gpsd
+.if defined(WITH_GEOTAG)
+LIB_DEPENDS+= exif.12:${PORTSDIR}/graphics/libexif
.else
-CONFIGURE_ARGS+= --disable-realtime-gps-tracking
+CONFIGURE_ARGS+= --disable-geotag
.endif
-.if !defined(WITHOUT_NLS)
-USE_GETTEXT= yes
-PLIST_SUB+= NLS=""
+.if defined(WITH_GPSD)
+LIB_DEPENDS+= gps.20:${PORTSDIR}/astro/gpsd
.else
-CONFIGURE_ARGS+= --disable-nls
-PLIST_SUB+= NLS="@comment "
+CONFIGURE_ARGS+= --disable-realtime-gps-tracking
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|gps_poll|gps_read|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e '/^AM_CFLAGS/s| -g | |' ${WRKSRC}/src/Makefile.in
.include <bsd.port.mk>
diff --git a/astro/viking/distinfo b/astro/viking/distinfo
index f55c27d940d1..3a7d3f03613b 100644
--- a/astro/viking/distinfo
+++ b/astro/viking/distinfo
@@ -1,2 +1,2 @@
-SHA256 (viking-1.2.2.tar.gz) = 9f96f9bdfc9cae8c65d391f9e972a987ec7f3d9d662a0e4df8bd14282879b10c
-SIZE (viking-1.2.2.tar.gz) = 1050517
+SHA256 (viking-1.3.tar.gz) = 54dc43b0136722118b8402d51ac8d78180ad59cc37e37ddf3fb6a7ee6bf04fdf
+SIZE (viking-1.3.tar.gz) = 1116537
diff --git a/astro/viking/files/patch-src-vikgpslayer.c b/astro/viking/files/patch-src-vikgpslayer.c
deleted file mode 100644
index 8aafc3f98126..000000000000
--- a/astro/viking/files/patch-src-vikgpslayer.c
+++ /dev/null
@@ -1,81 +0,0 @@
---- src/vikgpslayer.c.orig 2011-03-22 22:23:24.000000000 +0300
-+++ src/vikgpslayer.c 2011-03-22 22:45:18.000000000 +0300
-@@ -1308,7 +1308,7 @@
-
- }
-
--static void gpsd_raw_hook(VglGpsd *vgpsd, gchar *data)
-+static void gpsd_raw_hook(VglGpsd *vgpsd)
- {
- gboolean update_all = FALSE;
- VikGpsLayer *vgl = vgpsd->vgl;
-@@ -1376,10 +1376,14 @@
- static gboolean gpsd_data_available(GIOChannel *source, GIOCondition condition, gpointer data)
- {
- VikGpsLayer *vgl = data;
-+ int nread;
-+
- if (condition == G_IO_IN) {
-- if (!gps_poll(&vgl->vgpsd->gpsd))
-+ if ((nread = gps_read(&vgl->vgpsd->gpsd)) >= 0) {
-+ if (nread)
-+ gpsd_raw_hook(vgl->vgpsd);
- return TRUE;
-- else {
-+ } else {
- g_warning("Disconnected from gpsd. Trying to reconnect");
- rt_gpsd_disconnect(vgl);
- rt_gpsd_connect(vgl, FALSE);
-@@ -1407,23 +1411,15 @@
- static gboolean rt_gpsd_try_connect(gpointer *data)
- {
- VikGpsLayer *vgl = (VikGpsLayer *)data;
--#ifndef HAVE_GPS_OPEN_R
-- struct gps_data_t *gpsd = gps_open(vgl->gpsd_host, vgl->gpsd_port);
-
-- if (gpsd == NULL) {
--#else
- vgl->vgpsd = g_malloc(sizeof(VglGpsd));
-
-- if (gps_open_r(vgl->gpsd_host, vgl->gpsd_port, /*(struct gps_data_t *)*/vgl->vgpsd) != 0) {
--#endif
-+ if (gps_open(vgl->gpsd_host, vgl->gpsd_port, (struct gps_data_t *)vgl->vgpsd) != 0) {
- g_warning("Failed to connect to gpsd at %s (port %s). Will retry in %d seconds",
- vgl->gpsd_host, vgl->gpsd_port, vgl->gpsd_retry_interval);
- return TRUE; /* keep timer running */
- }
-
--#ifndef HAVE_GPS_OPEN_R
-- vgl->vgpsd = realloc(gpsd, sizeof(VglGpsd));
--#endif
- vgl->vgpsd->vgl = vgl;
-
- vgl->realtime_fix.dirty = vgl->last_fix.dirty = FALSE;
-@@ -1439,15 +1435,10 @@
- vik_trw_layer_add_track(vtl, vgl->realtime_track_name, vgl->realtime_track);
- }
-
-- gps_set_raw_hook(&vgl->vgpsd->gpsd, gpsd_raw_hook);
- vgl->realtime_io_channel = g_io_channel_unix_new(vgl->vgpsd->gpsd.gps_fd);
- vgl->realtime_io_watch_id = g_io_add_watch( vgl->realtime_io_channel,
- G_IO_IN | G_IO_ERR | G_IO_HUP, gpsd_data_available, vgl);
--#if HAVE_GPS_STREAM
- gps_stream(&vgl->vgpsd->gpsd, WATCH_ENABLE, NULL);
--#else
-- gps_query(&vgl->vgpsd->gpsd, "w+x");
--#endif
- return FALSE; /* no longer called by timeout */
- }
-
-@@ -1501,11 +1492,7 @@
- }
- if (vgl->vgpsd) {
- gps_close(&vgl->vgpsd->gpsd);
--#ifdef HAVE_GPS_OPEN_R
- g_free(vgl->vgpsd);
--#else
-- free(vgl->vgpsd);
--#endif
- vgl->vgpsd = NULL;
- }
-
diff --git a/astro/viking/pkg-plist b/astro/viking/pkg-plist
index bb1b520d50e9..6099371d0327 100644
--- a/astro/viking/pkg-plist
+++ b/astro/viking/pkg-plist
@@ -1,41 +1,40 @@
bin/viking
-bin/viking-remote
share/applications/viking.desktop
share/gnome/help/viking/C/figures/properties_degree.png
share/gnome/help/viking/C/figures/properties_units.png
share/gnome/help/viking/C/legal.xml
share/gnome/help/viking/C/viking.xml
share/icons/hicolor/48x48/apps/viking.png
-%%NLS%%share/locale/cs/LC_MESSAGES/viking.mo
-%%NLS%%share/locale/da/LC_MESSAGES/viking.mo
-%%NLS%%share/locale/de/LC_MESSAGES/viking.mo
-%%NLS%%share/locale/el/LC_MESSAGES/viking.mo
-%%NLS%%share/locale/en_GB/LC_MESSAGES/viking.mo
-%%NLS%%share/locale/es/LC_MESSAGES/viking.mo
-%%NLS%%share/locale/fr/LC_MESSAGES/viking.mo
-%%NLS%%share/locale/he/LC_MESSAGES/viking.mo
-%%NLS%%share/locale/hu/LC_MESSAGES/viking.mo
-%%NLS%%share/locale/id/LC_MESSAGES/viking.mo
-%%NLS%%share/locale/it/LC_MESSAGES/viking.mo
-%%NLS%%share/locale/ja/LC_MESSAGES/viking.mo
-%%NLS%%share/locale/jv/LC_MESSAGES/viking.mo
-%%NLS%%share/locale/lt/LC_MESSAGES/viking.mo
-%%NLS%%share/locale/lv/LC_MESSAGES/viking.mo
-%%NLS%%share/locale/nb/LC_MESSAGES/viking.mo
-%%NLS%%share/locale/nl/LC_MESSAGES/viking.mo
-%%NLS%%share/locale/pl/LC_MESSAGES/viking.mo
-%%NLS%%share/locale/pt_BR/LC_MESSAGES/viking.mo
-%%NLS%%share/locale/ru/LC_MESSAGES/viking.mo
-%%NLS%%share/locale/sl/LC_MESSAGES/viking.mo
-%%NLS%%share/locale/sv/LC_MESSAGES/viking.mo
-%%NLS%%share/locale/uk/LC_MESSAGES/viking.mo
-%%NLS%%share/locale/zh_CN/LC_MESSAGES/viking.mo
-%%NLS%%share/locale/zh_TW/LC_MESSAGES/viking.mo
+share/locale/cs/LC_MESSAGES/viking.mo
+share/locale/da/LC_MESSAGES/viking.mo
+share/locale/de/LC_MESSAGES/viking.mo
+share/locale/el/LC_MESSAGES/viking.mo
+share/locale/en_GB/LC_MESSAGES/viking.mo
+share/locale/es/LC_MESSAGES/viking.mo
+share/locale/fr/LC_MESSAGES/viking.mo
+share/locale/he/LC_MESSAGES/viking.mo
+share/locale/hu/LC_MESSAGES/viking.mo
+share/locale/id/LC_MESSAGES/viking.mo
+share/locale/it/LC_MESSAGES/viking.mo
+share/locale/ja/LC_MESSAGES/viking.mo
+share/locale/jv/LC_MESSAGES/viking.mo
+share/locale/lt/LC_MESSAGES/viking.mo
+share/locale/lv/LC_MESSAGES/viking.mo
+share/locale/nb/LC_MESSAGES/viking.mo
+share/locale/nl/LC_MESSAGES/viking.mo
+share/locale/pl/LC_MESSAGES/viking.mo
+share/locale/pt_BR/LC_MESSAGES/viking.mo
+share/locale/ru/LC_MESSAGES/viking.mo
+share/locale/sl/LC_MESSAGES/viking.mo
+share/locale/sv/LC_MESSAGES/viking.mo
+share/locale/uk/LC_MESSAGES/viking.mo
+share/locale/zh_CN/LC_MESSAGES/viking.mo
+share/locale/zh_TW/LC_MESSAGES/viking.mo
share/omf/viking/viking-C.omf
-%%NLS%%@dirrm share/locale/jv/LC_MESSAGES
-%%NLS%%@dirrm share/locale/jv
-@dirrmtry share/applications
@dirrm share/omf/viking
+@dirrmtry share/locale/jv/LC_MESSAGES
+@dirrmtry share/locale/jv
@dirrm share/gnome/help/viking/C/figures
@dirrm share/gnome/help/viking/C
@dirrm share/gnome/help/viking
+@dirrmtry share/applications