aboutsummaryrefslogtreecommitdiffstats
path: root/astro/weather/Makefile
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2015-05-27 17:37:18 +0800
committersunpoet <sunpoet@FreeBSD.org>2015-05-27 17:37:18 +0800
commitc59f028710eb95984e1c342249900c41ca8b1c96 (patch)
tree7a16e20949cc94baeee42b9e4f02c07e342ab72f /astro/weather/Makefile
parentc63859ce6d96312046260d89d9e92fa2978dbf4d (diff)
downloadfreebsd-ports-gnome-c59f028710eb95984e1c342249900c41ca8b1c96.tar.gz
freebsd-ports-gnome-c59f028710eb95984e1c342249900c41ca8b1c96.tar.zst
freebsd-ports-gnome-c59f028710eb95984e1c342249900c41ca8b1c96.zip
- Merge PLIST_FILES
Diffstat (limited to 'astro/weather/Makefile')
-rw-r--r--astro/weather/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/astro/weather/Makefile b/astro/weather/Makefile
index 536bbaf340b6..0a97a9ae2055 100644
--- a/astro/weather/Makefile
+++ b/astro/weather/Makefile
@@ -17,6 +17,8 @@ USES= python shebangfix tar:xz
PLIST_FILES= bin/${PORTNAME} \
%%PYTHON_SITELIBDIR%%/${PORTNAME}.py \
+ %%PYTHON_SITELIBDIR%%/${PYCACHE_DIR}${PYCACHE_FILE}.pyc \
+ %%PYTHON_SITELIBDIR%%/${PYCACHE_DIR}${PYCACHE_FILE}.pyo \
man/man1/${PORTNAME}.1.gz \
man/man5/${PORTNAME}rc.5.gz
PORTDATA= airports places stations zctas zones
@@ -35,9 +37,6 @@ PYCACHE_DIR= __pycache__/
PYCACHE_FILE= ${PORTNAME}.cpython-${PYTHON_SUFFIX}
.endif
-PLIST_FILES+= %%PYTHON_SITELIBDIR%%/${PYCACHE_DIR}${PYCACHE_FILE}.pyc \
- %%PYTHON_SITELIBDIR%%/${PYCACHE_DIR}${PYCACHE_FILE}.pyo
-
do-build:
@${PYTHON_CMD} -m compileall ${WRKSRC}/${PORTNAME}.py
@${PYTHON_CMD} -O -m compileall ${WRKSRC}/${PORTNAME}.py