aboutsummaryrefslogtreecommitdiffstats
path: root/astro/xearth
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2013-10-15 22:23:29 +0800
committermat <mat@FreeBSD.org>2013-10-15 22:23:29 +0800
commitb6ee4c4c21ebae15faaa108e9bcd7260ff5881bd (patch)
tree068a16d316bff959e70f12290a996e181d4e801e /astro/xearth
parenta1ce0d07d2fb7b35244d49e857363745c3e82848 (diff)
downloadfreebsd-ports-gnome-b6ee4c4c21ebae15faaa108e9bcd7260ff5881bd.tar.gz
freebsd-ports-gnome-b6ee4c4c21ebae15faaa108e9bcd7260ff5881bd.tar.zst
freebsd-ports-gnome-b6ee4c4c21ebae15faaa108e9bcd7260ff5881bd.zip
Support staging.
PR: ports/182910 Submitted by: mat (me) Approved by: maintainer
Diffstat (limited to 'astro/xearth')
-rw-r--r--astro/xearth/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/astro/xearth/Makefile b/astro/xearth/Makefile
index b40370fbf4bd..a69855722b92 100644
--- a/astro/xearth/Makefile
+++ b/astro/xearth/Makefile
@@ -12,20 +12,19 @@ COMMENT= Set the root window to the image of earth
USE_XORG= x11 xext sm ice xt
USE_XZ= yes
-NO_STAGE= yes
-MAN1= xearth.1
PLIST_FILES= bin/xearth \
+ man/man1/xearth.1.gz \
lib/X11/xearth/freebsd.committers.markers \
lib/X11/xearth/freebsd.ftp.markers
PLIST_DIRS= lib/X11/xearth
do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/xearth ${PREFIX}/bin
- @${INSTALL_MAN} ${WRKSRC}/xearth.man ${MANPREFIX}/man/man1/xearth.1
- @${MKDIR} ${PREFIX}/lib/X11/xearth
+ @${INSTALL_PROGRAM} ${WRKSRC}/xearth ${STAGEDIR}${PREFIX}/bin
+ @${INSTALL_MAN} ${WRKSRC}/xearth.man ${STAGEDIR}${MANPREFIX}/man/man1/xearth.1
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/X11/xearth
# Copy the list of FreeBSD sites & committers locations
.for marker in freebsd.committers.markers freebsd.ftp.markers
- @${INSTALL_DATA} ${FILESDIR}/${marker} ${PREFIX}/lib/X11/xearth
+ @${INSTALL_DATA} ${FILESDIR}/${marker} ${STAGEDIR}${PREFIX}/lib/X11/xearth
.endfor
.include <bsd.port.mk>