aboutsummaryrefslogtreecommitdiffstats
path: root/astro/xglobe
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2013-02-07 23:37:15 +0800
committergahr <gahr@FreeBSD.org>2013-02-07 23:37:15 +0800
commit48ab0ff4606c8da33b7d20af8dc7313bf539d1b3 (patch)
tree7b76d133b6aed2608c7ec527ccc156fab6dc2c1b /astro/xglobe
parent3c94b84bbee6d50bbe2df6bb201f03b07f848728 (diff)
downloadfreebsd-ports-gnome-48ab0ff4606c8da33b7d20af8dc7313bf539d1b3.tar.gz
freebsd-ports-gnome-48ab0ff4606c8da33b7d20af8dc7313bf539d1b3.tar.zst
freebsd-ports-gnome-48ab0ff4606c8da33b7d20af8dc7313bf539d1b3.zip
- Get rid of PTHREAD_CFLAGS and PTHREAD_LIBS (category: astro)
Approved by: portmgr
Diffstat (limited to 'astro/xglobe')
-rw-r--r--astro/xglobe/Makefile2
-rw-r--r--astro/xglobe/files/patch-Makefile2
2 files changed, 2 insertions, 2 deletions
diff --git a/astro/xglobe/Makefile b/astro/xglobe/Makefile
index 51b4ed09fde2..9fd4df41b322 100644
--- a/astro/xglobe/Makefile
+++ b/astro/xglobe/Makefile
@@ -17,7 +17,7 @@ COMMENT= Displays a view of the Earth (like xearth) with a rendered photo map
USE_QT4= corelib gui qt3support moc_build
USE_GMAKE= yes
-MAKE_ENV= PTHREAD_LIBS=${PTHREAD_LIBS} QT_PREFIX=${QT_PREFIX}
+MAKE_ENV= QT_PREFIX=${QT_PREFIX}
do-install:
@${MKDIR} ${DATADIR}
diff --git a/astro/xglobe/files/patch-Makefile b/astro/xglobe/files/patch-Makefile
index b3bca761963c..dd9ce83093a8 100644
--- a/astro/xglobe/files/patch-Makefile
+++ b/astro/xglobe/files/patch-Makefile
@@ -47,7 +47,7 @@
LIB_DIRS = -L$(QT_LIB_DIR) -L$(X11_LIB_DIR)
-LIBS = -lX11 -lqt -lm
-+LIBS = -lX11 -lQt3Support -lQtGui -lm ${PTHREAD_LIBS}
++LIBS = -lX11 -lQt3Support -lQtGui -lm -pthread
# If you want to use the QImageIO lib (to support jpg and png maps) use the
# next two lines and comment the one above
#WITH_QIMGIO = -DWITH_QIMAGEIO