aboutsummaryrefslogtreecommitdiffstats
path: root/astro/xplanet/Makefile
diff options
context:
space:
mode:
authorjedgar <jedgar@FreeBSD.org>2000-02-23 08:42:13 +0800
committerjedgar <jedgar@FreeBSD.org>2000-02-23 08:42:13 +0800
commit2d3d94e88a718d0c278e7a9404d2f4b34a4de888 (patch)
treead11580806d47994000dd842564e87f5c4c752f7 /astro/xplanet/Makefile
parent0952ee82b7ec3a0b56f585dd9dc2547ea4a7cc88 (diff)
downloadfreebsd-ports-gnome-2d3d94e88a718d0c278e7a9404d2f4b34a4de888.tar.gz
freebsd-ports-gnome-2d3d94e88a718d0c278e7a9404d2f4b34a4de888.tar.zst
freebsd-ports-gnome-2d3d94e88a718d0c278e7a9404d2f4b34a4de888.zip
Xplanet was inspired by Xearth, which renders an image of the earth into the X
root window. Xplanet uses the Imlib library to read user supplied maps of the earth (or another planet). Orthographic and mercator projections can be rendered to the root window or saved to a file. An image that the user can rotate interactively can be popped up in a window using OpenGL or Mesa. PR: 16903 Submitted by: Will Andrews <andrews@technologist.com>
Diffstat (limited to 'astro/xplanet/Makefile')
-rw-r--r--astro/xplanet/Makefile79
1 files changed, 79 insertions, 0 deletions
diff --git a/astro/xplanet/Makefile b/astro/xplanet/Makefile
new file mode 100644
index 000000000000..a3178696ee14
--- /dev/null
+++ b/astro/xplanet/Makefile
@@ -0,0 +1,79 @@
+# New ports collection makefile for: xplanet
+# Version required: 0.45
+# Date created: 22 Feb 2000
+# Whom: darius@dons.net.au
+#
+# $FreeBSD$
+#
+
+DISTNAME= xplanet-0.45
+CATEGORIES= astro x11
+MASTER_SITES= http://www.wrightflyer.org/~hari/xplanet/ \
+ http://www.radcyberzine.com/xglobe/
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} photo_1600.jpg
+
+MAINTAINER= andrews@technologist.com
+
+LIB_DEPENDS= Imlib.5:${PORTSDIR}/graphics/imlib \
+ GL.14:${PORTSDIR}/graphics/Mesa3
+
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
+
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-map-extension=jpg
+MAN1= xplanet.1 xplanetbg.1
+
+.include <bsd.port.pre.mk>
+
+.if (!defined(USE_TK80) && !defined(USE_TK81) && !defined(USE_TK82) && !defined(USE_TK83))
+.if exists(${LOCALBASE}/bin/wish8.3)
+USE_TK83= yes
+.elif exists(${LOCALBASE}/bin/wish8.2)
+USE_TK82= yes
+.elif exists(${LOCALBASE}/bin/wish8.1)
+USE_TK81= yes
+.else
+USE_TK80= yes
+.endif
+.endif
+
+.if defined(USE_TK80)
+RUN_DEPENDS= wish8.0:${PORTSDIR}/x11-toolkits/tk80
+WISH= ${LOCALBASE}/bin/wish8.0
+TKVERMSG= "Using Tk 8.0"
+.endif
+
+.if defined(USE_TK81)
+RUN_DEPENDS= wish8.1:${PORTSDIR}/x11-toolkits/tk81
+WISH= ${LOCALBASE}/bin/wish8.1
+TKVERMSG= "Using Tk 8.1"
+.endif
+
+.if defined(USE_TK82)
+RUN_DEPENDS= wish8.2:${PORTSDIR}/x11-toolkits/tk82
+WISH= ${LOCALBASE}/bin/wish8.2
+TKVERMSG= "Using Tk 8.2"
+.endif
+
+.if defined(USE_TK83)
+RUN_DEPENDS= wish8.3:${PORTSDIR}/x11-toolkits/tk83
+WISH= ${LOCALBASE}/bin/wish8.3
+TKVERMSG= "Using Tk 8.3"
+.endif
+
+CONFIGURE_ENV+= WISH=${WISH}
+
+pre-fetch:
+ @${ECHO} ${TKVERMSG}
+ @${ECHO} "Define USE_TK80, USE_TK81, USE_TK82, or USE_Tk83"
+ @${ECHO} "To use a different version of TK"
+
+pre-build:
+ @${PERL} -pi -e "s:/usr/local:${PREFIX}:g" ${WRKSRC}/auxfiles.h
+
+post-install:
+ @${INSTALL_DATA} ${DISTDIR}/photo_1600.jpg ${PREFIX}/share/xplanet/earth.jpg
+
+.include <bsd.port.post.mk>