aboutsummaryrefslogtreecommitdiffstats
path: root/astro/xplanet/Makefile
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2000-07-04 13:34:52 +0800
committerwill <will@FreeBSD.org>2000-07-04 13:34:52 +0800
commitc6a6b5a1629f21cfa8fffb4ed5b506f2d1021c72 (patch)
treecdb775b898be64d2bd03d79616c34cdf354e2dc0 /astro/xplanet/Makefile
parent658a156226a09d33c680227607364e37257b705a (diff)
downloadfreebsd-ports-gnome-c6a6b5a1629f21cfa8fffb4ed5b506f2d1021c72.tar.gz
freebsd-ports-gnome-c6a6b5a1629f21cfa8fffb4ed5b506f2d1021c72.tar.zst
freebsd-ports-gnome-c6a6b5a1629f21cfa8fffb4ed5b506f2d1021c72.zip
Update to 0.70. There should be no more coredumps in this version.
Special thanks to: billf (for the -lm tidbit)
Diffstat (limited to 'astro/xplanet/Makefile')
-rw-r--r--astro/xplanet/Makefile14
1 files changed, 10 insertions, 4 deletions
diff --git a/astro/xplanet/Makefile b/astro/xplanet/Makefile
index 73ed98cd0642..1a6886d93f93 100644
--- a/astro/xplanet/Makefile
+++ b/astro/xplanet/Makefile
@@ -6,24 +6,30 @@
#
PORTNAME= xplanet
-PORTVERSION= 0.60
+PORTVERSION= 0.70
CATEGORIES= astro x11
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://www.radcyberzine.com/xglobe/
MASTER_SITE_SUBDIR= ${PORTNAME}
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} depths_800.jpg
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= will@FreeBSD.org
LIB_DEPENDS= Imlib.5:${PORTSDIR}/graphics/imlib \
- GL.14:${PORTSDIR}/graphics/Mesa3
-
-EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
+ GL.14:${PORTSDIR}/graphics/Mesa3 \
+ jpeg.9:${PORTSDIR}/graphics/jpeg
USE_X_PREFIX= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-map-extension=jpg
+CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include -I${X11BASE}/include" \
+ CPPFLAGS="${CFLAGS} -I${LOCALBASE}/include -I${X11BASE}/include" \
+ LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib -lm"
+MAKE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include -I${X11BASE}/include" \
+ CPPFLAGS="${CFLAGS} -I${LOCALBASE}/include -I${X11BASE}/include" \
+ LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib -lm"
MAN1= xplanet.1 xplanetbg.1
.include <bsd.port.pre.mk>