aboutsummaryrefslogtreecommitdiffstats
path: root/astro
diff options
context:
space:
mode:
authorrene <rene@FreeBSD.org>2011-12-06 07:56:02 +0800
committerrene <rene@FreeBSD.org>2011-12-06 07:56:02 +0800
commit765fbddfcb6bd3e5e730e110d772a32632a97a42 (patch)
treeb5259e7a614d03b118ccf9d6dcd6d09fdd848d79 /astro
parente5ee785c6e6b08d0e7adb67b758297a63d044253 (diff)
downloadfreebsd-ports-gnome-765fbddfcb6bd3e5e730e110d772a32632a97a42.tar.gz
freebsd-ports-gnome-765fbddfcb6bd3e5e730e110d772a32632a97a42.tar.zst
freebsd-ports-gnome-765fbddfcb6bd3e5e730e110d772a32632a97a42.zip
Attempt to fix build on powerpc.
Idea from: bf@ Feature safe: yes
Diffstat (limited to 'astro')
-rw-r--r--astro/boinc-setiathome-enhanced/Makefile6
-rw-r--r--astro/boinc-setiathome-enhanced/files/patch-client__Makefile.am11
2 files changed, 16 insertions, 1 deletions
diff --git a/astro/boinc-setiathome-enhanced/Makefile b/astro/boinc-setiathome-enhanced/Makefile
index 2e00f932ae33..8f72030e24b6 100644
--- a/astro/boinc-setiathome-enhanced/Makefile
+++ b/astro/boinc-setiathome-enhanced/Makefile
@@ -60,10 +60,14 @@ PLIST_SUB+= X11="@comment "
CFLAGS+= -mtune=native
.endif
+.if !empty(MACHINE_CPU:Maltivec)
+CONFIGURE_ARGS+= --enable-altivec
+.endif
+
CONFIGURE_ENV+= BOINCDIR="${NONEXISTENT}"
CONFIGURE_ARGS+= --disable-static-client --disable-server \
- --disable-altivec --disable-tests \
+ --disable-tests \
--with-boinc-platform=${ARCH}-portbld-freebsd
SETI_SITE= setiathome.berkeley.edu
diff --git a/astro/boinc-setiathome-enhanced/files/patch-client__Makefile.am b/astro/boinc-setiathome-enhanced/files/patch-client__Makefile.am
new file mode 100644
index 000000000000..8bf2690d6c2b
--- /dev/null
+++ b/astro/boinc-setiathome-enhanced/files/patch-client__Makefile.am
@@ -0,0 +1,11 @@
+--- client/Makefile.am.orig 2009-09-23 01:50:50.000000000 +0200
++++ client/Makefile.am 2011-12-04 17:19:18.000000000 +0100
+@@ -165,7 +165,7 @@
+ seti_boinc-analyzeFuncs_altivec.o: vector/analyzeFuncs_altivec.cpp
+ if $(CXX) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) \
+ $(CPPFLAGS) $(seti_boinc_CXXFLAGS) $(CXXFLAGS) -DUSE_ALTIVEC \
+- -MT $@ -MD -MP -MF "$(DEPDIR)/$*.Tpo" -faltivec \
++ -MT $@ -MD -MP -MF "$(DEPDIR)/$*.Tpo" -maltivec -mabi=altivec \
+ -c -o $@ $<; then mv -f "$(DEPDIR)/$*.Tpo" "$(DEPDIR)/$*.Po"; \
+ else rm -f "$(DEPDIR)/$*.Tpo"; exit 1; fi
+ seti_boinc-analyzeFuncs_vector.o: vector/analyzeFuncs_vector.cpp